Jump to content

NanoPi M4 V2 Won't Boot Solid RED light

This Guy

Recommended Posts

My NanoPi M4V2 wont boot. It has a solid red light no green at all. I cant access it with SSH. I went through the troubleshooting checklist available for the NanoPi in regards to the red light. Nothing was solved. I tried different SD cards with different types of images and different types of burners. Nothing works. I know that the SD cards, images, and burners are not the problem cuz I tested it on a Raspberry Pi with no problems.

Link to comment
Share on other sites

Have you checked the following?

It seems that there's a version of the linux-dtb-legacy package without the the dtb files for the NanoPi M4 board, and the board won't start without one.  I'm not sure if new images are shipping with that version or not and or even if this issue applies to non-legacy kernel.  In any case, I'd suggest trying an older (archived) image of whichever variant your trying to use just to be sure (https://armbian.systemonachip.net/archive/nanopim4v2/archive/).



Link to comment
Share on other sites



I also have this problem, but I don't have eMMC, only SD.


I downloaded the latest image (Armbian_22.05.4_Nanopim4v2_jammy_current_5.15.48_xfce_desktop) and burned to SD, booted and configured. So far so good. I updated the system, rebooted and the board did not come up again.


I wrote the SD card again using Balena Etcher and it still won't boot. I downloaded the Bullseye variant (Armbian_22.05.4_Nanopim4v2_bullseye_current_5.15.48) and it won't boot either.


I tried OpenELEC and it boots fine. I tried Android from Friendlyelect and it boots fine.


Why did Armbian boot at first but after the update it won't even if I rewrite the same image I used at first?

Link to comment
Share on other sites

On 7/6/2022 at 1:24 PM, piter75 said:

Is anything printed on the serial console during boot?

I connected the UART and did not see any messages, but for some reason I tried again the next day and it just booted, same SD card and same image as before, without rewriting the image. Very strange.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines