Jump to content

No hdmi sound on vim3l khadas


enote
 Share

Go to solution Solved by NicoD,

Recommended Posts

Hi, everyone!
Khadas Vim3l on Ubuntu, armbian.
No hdmi sound, boot without any changes, fully stock!

Tried to boot on 4.9 image from khadas and android pie - success.
Imagies that is no hdmi sound only dummy output:

Armbian_22.02.1_Khadas-vim3l_jammy_edge_5.15.25_xfce_desktop.img
Armbian_22.02.1_Khadas-vim3l_focal_current_5.10.102_xfce_desktop.img
Armbian_22.05.1_Khadas-vim3l_jammy_edge_5.17.5_xfce_desktop.img
Armbian_22.05.1_Khadas-vim3l_focal_current_5.10.110_xfce_desktop.img

How to fix?

Link to comment
Share on other sites

Check forum guidelines to use maximum potential!

  • Solution

This might be a fix. I haven't had the time to test and implement.

 

Steps used to fix audio on Armbian

    Clone @Spikerguy Repository From Manjaro Gitlab
    Ensure you have git installed with,

pi@twisteros:~$ sudo apt install git

Make a destination subdirectory under /home/pi for git pulls and builds,

pi@twisteros:~$ mkdir ~/builds

Change to your new ‘builds’ directory,

pi@twisteros:~$ cd ~/builds

Clone local copies of the Manjaro files:

pi@twisteros:~$ git clone manjaro-arm / packages / community / khadas-utils · GitLab

    Copy Files to Their Correct Locations

pi@twisteros:~$ sudo cp ~/builds/khadas-utils/g12_sound.sh /usr/bin

pi@twisteros:~$ sudo cp ~/builds/khadas-utils/sound.service /usr/lib/systemd/system/

pi@twisteros:~$ sudo cp ~/builds/khadas-utils/G12B-KHADAS-VIM3.conf /usr/share/alsa/cards/

pi@twisteros:~$ sudo ln -s /usr/share/alsa/cards/G12B-KHADAS-VIM3.conf /usr/share/alsa/cards/G12BKHADASVIM3.conf

pi@twisteros:~$ sudo cp ~/builds/khadas-utils/G12B-KHADAS-VIM3.conf /etc/asound.conf

Make sure that /usr/bin/g12_sound.sh is executable. It should already be, and you can check with,

pi@twisteros:~$ ls -l /usr/bin/g12_sound.sh

Otherwise a quck chmod won’t hurt:

pi@twisteros:~$ sudo chmod a+x /usr/bin/g12_sound.sh

    Initialize the Systemd Sound Service Unit

pi@twisteros:~$ sudo systemctl enable sound.service

 

Link to comment
Share on other sites

3 минуты назад, NicoD сказал:
Steps used to fix audio on Armbian

Thank you very much, i will try it.

 

12 минут назад, Igor сказал:


Yes, I'm understand that newer kernel not so compitebly like older. Ive already read faq, and fine tuning, and search it on forum, and khadas forum...  

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...