Jump to content
  • 0

Bluetooth not working

Alexey Guskov


Bluetooth device does not appear on my armbian (kernel is 5.17.5-media, tried on edge-media and current-media as well). 

# hciconfig version
Can't get device info: No such device

# bluetoothctl
Agent registered
[bluetooth]# devices
No default controller available


HCI socket does not seem to be created.

Got this in dmesg:

[   11.990128] Bluetooth: HCI device and connection manager initialized
[   11.990145] Bluetooth: HCI socket layer initialized
[   11.990164] Bluetooth: L2CAP socket layer initialized
[   11.990188] Bluetooth: SCO socket layer initialized
[   12.081220] Bluetooth: HCI UART driver ver 2.3
[   12.081245] Bluetooth: HCI UART protocol H4 registered
[   12.081250] Bluetooth: HCI UART protocol BCSP registered
[   12.081352] Bluetooth: HCI UART protocol LL registered
[   12.081358] Bluetooth: HCI UART protocol ATH3K registered
[   12.081397] Bluetooth: HCI UART protocol Three-wire (H5) registered
[   12.081760] Bluetooth: HCI UART protocol Intel registered
[   12.082139] Bluetooth: HCI UART protocol Broadcom registered
[   12.082205] Bluetooth: HCI UART protocol QCA registered
[   12.082211] Bluetooth: HCI UART protocol AG6XX registered
[   12.082335] Bluetooth: HCI UART protocol Marvell registered
[   12.082530] rockchip-pinctrl pinctrl: pin gpio0-17 already requested by fdd50000.serial; cannot claim for serial0-0
[   12.082544] rockchip-pinctrl pinctrl: pin-17 (serial0-0) status -22
[   12.082550] rockchip-pinctrl pinctrl: could not request pin 17 (gpio0-17) from group bt-enable-h  on device rockchip-pinctrl
[   12.082557] hci_uart_bcm serial0-0: Error applying setting, reverse things back
[   12.297655] cfg80211: failed to load regulatory.db
[   12.308441] brcmfmac mmc2:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.firefly,rk3566-roc-pc.txt failed with error -2
[   12.308466] brcmfmac mmc2:0001:1: Falling back to sysfs fallback for: brcm/brcmfmac43455-sdio.firefly,rk3566-roc-pc.txt
[   12.549006] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[   12.589256] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Feb 27 2018 03:15:32 version 7.45.154 (r684107 CY) FWID 01-4fbe0b04

Looks like wifi firmware loaded okay (not sure if the chip uses same blob for bluetooth and wifi, probably not), but there's some conflict with fdd50000.serial (which is uart0, another strange thing). To me it looks like a bug in .dts, but could not find it so far.

Tried removing uart0 from .dtd. HCI device appears after that, but HCI socket is down and not responding. (Maybe I need to trigger gpio pin to enable bluetooth, but why doesn't it happen automatically?)

Any ideas?

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

Help us fund some #badass gear for our continuous integration build framework

  • 0

Looks like the source of the conflict is here:

&uart0 {
	pinctrl-0 = <&uart0_xfer>; // RK_PC0 is rx and RK_PC1 is tx

&uart1 {
	bluetooth {
		device-wake-gpios = <&gpio2 RK_PC1 GPIO_ACTIVE_HIGH>;
		host-wake-gpios = <&gpio2 RK_PC0 GPIO_ACTIVE_HIGH>;
		shutdown-gpios = <&gpio2 RK_PB7 GPIO_ACTIVE_HIGH>;
		pinctrl-names = "default";
		pinctrl-0 = <&bt_host_wake_l &bt_wake_l &bt_enable_h>; // RK_PB4 and RK_PC1

So, indeed, bluetooth device is conflicting with uart0

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...