43 43
chocho

Armbian for Amlogic S912

Recommended Posts

Ok so, you made me realize that it is actually possible to brick a box only by messing with disk formatting.

 

I first though that, as with a regular computer, only firmware upgrade can brick the mother board. I'll be taking a look at proper firmware flash on freaktab. But from what I have seen one should not expect a high success rate from this method.

Share this post


Link to post
Share on other sites

How can I find the dtb file for my M8S Pro L (s912, 3GB ram)? 
btw, when I use "dd" to write image to sdcard, insert SD card and apply power, android logo still shows up, I dont know why 

Share this post


Link to post
Share on other sites
On 10/12/2018 at 3:45 PM, gnthibault said:

Ok so, you made me realize that it is actually possible to brick a box only by messing with disk formatting.

 

I first though that, as with a regular computer, only firmware upgrade can brick the mother board. I'll be taking a look at proper firmware flash on freaktab. But from what I have seen one should not expect a high success rate from this method.

 

Good news, I bought a USB A male to USB A male on a Win10 64bits, and I was able to unbrick my H96pro+ box, following a tutorial like this one:

 

Share this post


Link to post
Share on other sites

USB keybaord is not recognized by H96 PRO+ 3G/32G with Armbian_5.64_Aml-s9xxx_Ubuntu_bionic_default_4.19.0-rc7_desktop_20181019.img. I used gxm_q200.dtb as dtb.img. Any help or idea? My idea was to move it to EMMC, if everything works.

 

Edit 1: Further i edited uenv.ini and elinux.conf to point to correct dtb in dtb folder. Post that was able to set username and password, but post that it is a blank screen with blinking cursor.

 

Edit 2: Armbian_5.60_Aml-s9xxx_Ubuntu_bionic_default_4.18.7_desktop_20180928.img worked for me

Sent from my ONEPLUS A3003 using Tapatalk

Share this post


Link to post
Share on other sites

Is there any image with Kodi that works (with accelerated HW) ?  I tried Armbian_5.67_Aml-s9xxx_Debian_stretch_default_4.19.0-rc7_desktop_20181117.img.xz .  Then installed kodi through apt-get install kodi.  It installed properly but when I tried to run it it gave me : DRI2 canno9t authenticate and no window appear. Everything else works fine.  (X seems to not be accelerated).  I tried also old one aml-kodi-debian_5.41_arm64.deb and install kodi and aml-codec from deb packages.  Installed properly but when I run it (after fixing libEGL symbolic link) X background appear 4 times on screen, (everything is multiplicated 4 times) and only reboot fix it. I installed librelec and there kodi works fine, but I need to install other things beside kodi...

 

I have Beeklink GT1 Ultimate (S912) with 3G (not sure if they are real or fake).

 

Thank You

 

Edited by spon901

Share this post


Link to post
Share on other sites

Hello, I need some help please.
Every time I made a apt upgrade I have this error message :

E: Write error - ~LZMAFILE (28: No space left on device)

Any advice to solve this. Thanks

Envoyé de mon ONEPLUS A6003 en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Hi all, firstly a big thank you for everyones hard work on this! It's awesome :)

 

I have a weird problem with my S912 based box with gigabit ethernet, all appears ok and indeed will be for days at a time IF the NIC never really gets used much. As soon as I start shoving traffic down it eventually it kinda starts stalling, stops responding then eventually pretty much dies altogether.

 

I'm not sure if it's significant but if I load up the NIC in both directions simultaneously with iPerf3 I got about 900Mbit down and about 80Mbit up but if I just transmit I get 900+Mbit and if I just receive I get 900+Mbit. I'd of thought I would of got a more balanced result here when testing simultaneously in both directions? 

 

As an example of when the NIC starts dying during a recent ping test to it it dropped 188 packets then responded with some pretty incredible latency then stopped again as you can see here: http://pasted.co/0bd5d8aa

 

Any ideas anyone?

 

Thanks in advance!

 

UPDATE 1: Oddly I've noticed I start a ping from the S912 box the response times are slow but WAY faster then if i start a ping from the box it's pinging (so one way round is 100x faster round trip wise)...  plus it also seems if i start a ping from the S912 box i then get a response from the other clients ping requests otherwise it doesn't respond. For reference it's using RTL8211F chipset if it matters.

 

UPDATE 2: If i down the interface and bring it back up on the box with an ifconfig eth0 down && ifconfig eth0 up it brings it back to life and it starts operating normally again.

 

UPDATE 3: I believe the problem has been fixed using this patch - https://patchwork.kernel.org/patch/10712159/ massive thanks to ccaione on #linux-amlogic on IRC for his help on this! :thumbup:

Share this post


Link to post
Share on other sites

¿Has someone been able to have mali drivers for the T820? 

 

I'm trying to get them using mali-midgard-dkms package but it requires linux headers and i can't find the linux-header-4.19.6-aml-s9xxx package anywhere nor the linux-image-4.19.6-aml-s9xxx to build them myself.

 

I would like to use the hardware acceleration that S912 has :(

Share this post


Link to post
Share on other sites

Hello

I tried to run from usb 3 stick Armbian_5.67_Aml-s9xxx_Debian_stretch_default_4.19.6_desktop_20181207 on ugoos am3

and 

Armbian_5.62_Aml-s9xxx_Ubuntu_xenial_default_4.19.0-rc7_desktop_20181018.img

 

in both cases I had problem at bootup and never got in gui screen.

 

All usb devices works in native android 7.12

 

How to run linux on ugoos am3?

 

Screens here https://my-files.ru/0fjgqd

 

Thank you in advance.

 

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
43 43