46 46
chocho

Armbian for Amlogic S912

Recommended Posts

Seeing that CoreElect running:

Linux ICS-X9T 3.14.29 #1 SMP Sun May 12 15:03:58 BST 2019 aarch64 GNU/Linux

 

Old kernel decided to try Armbian_5.44_S9xxx_Ubuntu_bionic_3.14.29_server_20180729.img.xz.

 

Interesting that it booted right up and ethernet interface is working fine now.  I understand that the kernel is old but really all I want is this box to run Armbian Ubuntu Server.

Not interested in using the wireless and or blue tooth interface at this time.

 ____  ___                   
/ ___|/ _ \__  ____  ____  __
\___ \ (_) \ \/ /\ \/ /\ \/ /
 ___) \__, |>  <  >  <  >  <
|____/  /_//_/\_\/_/\_\/_/\_\
                             

Welcome to ARMBIAN 5.44 user-built Ubuntu 18.04.1 LTS 3.14.29   
System load:   1.14 0.78 0.34      Up time:       4 min        
Memory usage:  4 % of 2733MB     IP:            192.168.244.250
CPU temp:      38°C               
Usage of /:    4% of 29G        

[ 0 security updates available, 202 updates total: apt upgrade ]
Last check: 2019-06-21 09:52

Last login: Fri Jun 21 09:49:18 2019 from 192.168.244.232

 

root@HS3-ATL:~# ethtool eth0
Settings for eth0:
    Supported ports: [ TP AUI BNC MII FIBRE ]
    Supported link modes:   10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Half 1000baseT/Full
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Supported FEC modes: Not reported
    Advertised link modes:  10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Half 1000baseT/Full
    Advertised pause frame use: No
    Advertised auto-negotiation: Yes
    Advertised FEC modes: Not reported
    Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                         100baseT/Half 100baseT/Full
    Link partner advertised pause frame use: Symmetric Receive-only
    Link partner advertised auto-negotiation: Yes
    Link partner advertised FEC modes: Not reported
    Speed: 100Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 1
    Transceiver: external
    Auto-negotiation: on
    Supports Wake-on: ug
    Wake-on: d
    Current message level: 0x0000003d (61)
                   drv link timer ifdown ifup
    Link detected: yes

Now I can move on to installing Docker and Home Assistant. 

 

It would be nice if this box's ethernet interface worked with current released kernel.

Share this post


Link to post
Share on other sites

I have left it running now for a few weeks and it runs fine.  It did error out on one update and I rebooted it and updated it again and it is fine.

 

NOTE: this is only for the T95Z Max S912 TVBox.

 

Thinking though of freezing the updates now on it....


 

 _____ ___  ____ _____  ____  ___  _ ____  
|_   _/ _ \| ___|__  / / ___|/ _ \/ |___ \
  | || (_) |___ \ / /  \___ \ (_) | | __) |
  | | \__, |___) / /_   ___) \__, | |/ __/
  |_|   /_/|____/____| |____/  /_/|_|_____|
                                           

Welcome to ARMBIAN 5.73 stable Ubuntu 18.04.2 LTS 3.14.29   
System load:   1.45 1.29 1.22      Up time:       18:57 hours        
Memory usage:  10 % of 2733MB     IP:            192.168.244.250
CPU temp:      35°C               
Usage of /:    29% of 29G        

[ Menu-driven system configuration (beta): sudo apt update && sudo apt install armbian-config ]

Last login: Wed Jul  3 20:46:17 2019 from 192.168.244.232

root@HS3-ATL:~#

Note that I updated the release version to indicate that it is a S912 as it kept going to showing a Rock64 on the update.

I also found that I had a bad SD card running for a while which caused me much grief.

 

This box is running Home Assistant, HomeSeer, Node Red, Mosquitto, Leviton OmniLinkBridge (MQTT) and testing with a Digi 8 port edgeport.

 

So in addition it is running a connection to a UPB controller, ethernet ZWave, RFID.  I am testing a LoRa RFID connection via two transievers with a range of 8 Km.

 

I do not know what dtb file it is using cuz it is not in the uEnv.ini file such that it is using defaults. 

root@HS3-ATL:/boot# ls
aml_autoscript                  fan.sh
aml_autoscript.zip              hdmi.sh
armbianEnv.txt                  Image
armbianEnv.txt.out              initrd.img-4.4.182-rockchip64
armbian_first_run.txt.template  s905_autoscript
boot.cmd                        s905_autoscript.cmd
boot.scr                        System.map-4.4.182-rockchip64
config-4.4.182-rockchip64       uEnv.ini
dtb                             uInitrd
dtb-3.14.29.old                 zImage
dtb.old
root@HS3-ATL:/boot# cat uEnv.ini
bootargs=root=LABEL=ROOTFS rootflags=data=writeback rw console=ttyS0,115200n8 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes fsck.repair=yes net.ifnames=0 mac=${mac}

It just works fine as an Ubuntu server for automation.  I have no keyboard, mouse or HDMI monitor connected to it.

 

Note that the kernel is old:

 

root@HS3-ATL:/boot# uname -a
Linux HS3-ATL 3.14.29 #26 SMP PREEMPT Sun Jul 29 11:26:15 MSK 2018 aarch64 aarch64 aarch64 GNU/Linux

It is only for this model TVBox S912.  Rest of the S912 boxes are running with newest kernels just fine.

IE: when trying a new kernel on this one the Gb NIC wasn't working and only wireless and bluetooth worked.

 

Download and install this build for this box to work.  (note that I never tried WLAN or Bluetooth with it and do not need it).

 

It is listed as Armbian_5.44_S9xxx_Ubuntu_bionic_3.14.29_server_20180729.img.xz dated 07292018.

 

Going to kernels 4.X and 5.X did not work for me with this specific device.

 

Never did boot it to Android or even looked.  Maybe my approach was wrong?

 

Any guidance on updating Android and extracting DTB file for use with Armbian would be appreciated. 

 

Just purchased a second BeeLink BT3 Pro here.  NOT for TV rather just for Automation.

Got the first one new for $65 and second one for $100.  It is not worth the $150 that Amazon is selling them for.

 

I do now see a similiar to BeeLink BT3 pro with an SSD card slow underneath for around $100.

 

For KODI use have settled on using CoreElec with an old kernel just for the HD 4K features.

 

For server use and no video have settled on currently posted kernel.

 

Still liking the footprint versus the RPi (even the RPi 4).

 

 

Share this post


Link to post
Share on other sites

@Petee thank you, network is up in 100Mb after delete the dtb.img I copied .

 

further test:

1. Ubuntu_bionic_3.14.29_server_20180729, after upgrade, OS won't boot

2. debian 3.14.29 20180729, after reboot , network did not work anymore. (not upgrade yet).

3. external usb network adapter test work, in 1Gb/s. (AX88179 chip)

 

now is running 5.10 debian buster with external usb network adapter.

Share this post


Link to post
Share on other sites

Thank you.  Understood.  Thought for a bit that increasing the size of the boot partition would make the updates work better.

 

Yes this one here is still running at 1 Gb after updating.  I did have errors on the second or third update and froze the build.

 

I was able to utilize the 5XX builds with Wireless / Bluetooth running but not Gb Ethernet. 

 

 

Share this post


Link to post
Share on other sites

at last I purchase a SBC and run dietpi (dns/media stream/rss services), t95z plus will stay for test purpose, with wireless connection. (sometimes the usb network will not work after OS reboot, have to manually unplug/plug power supply).

Share this post


Link to post
Share on other sites
(edited)

Hi!

I have a Mecool M8S PRO L S912 3G 16G DDR3 LB tv box, i tried to boot newer 4.x 5.x kernel linux images from sd card , but i cannot booted them. 
There https://yadi.sk/d/pHxaRAs-tZiei I can found only the newer images. Can somebody give me some links for older 3.14 kernel linux (desktop/server) images? Which dtd file should I use to work?

 

Thanks :)

Edited by zabolcs

Share this post


Link to post
Share on other sites

Hello.

I try to write last firmware to my gt1 G912 2/16.

i wrote img file to sdcard with dd.

Reboot gt1 with pressed reset button.

But after reboot i see only twrp.

How to fix it?

Share this post


Link to post
Share on other sites

Hi S912 owners,

 

Since my exchange with @balbes150 I came to the conclusion that the: Tanix-TX92 (Vorke Z6 Plus) Amlogic S912, 3GB RAM, 2,4 & 5 WiFi, USB 2.0,  only 2A PSU, Power Button  sound like a good balance between price and features  USD 52.- from China.

  1. Now I was wondering how happy you are with the Chip/Box per se?
  2. What is the latest Android that runs well on this box (no interruptions in a movie) ?
  3. How is armbian performing in Dual boot, perhaps with Kodi 18?
  4. Can someone recommend a good power supply 5V 3A?

 

Thanks

Share this post


Link to post
Share on other sites

Good Day

 

I have a Mecool K3 Pro (S912) which includes an internal DVB tuner.  I have installed the latest 

 

Armbian_5.94_Aml-g12_Ubuntu_bionic_default_5.2.1_20190821.img

 

from balbes150 using the meson-gxm-s912-kiii-pro.dtb in the uEnv.ini

 

It is working well, except there is no DVB devices in Armbian. I am interested in the DVB-S tuner.

 

If I look at the meson-gxm-s912-kiii-pro.dts device source tree (and the #includes), it seems that AFL1 included the dvb setup in there already. 

 

Does anyone have any input OR was able to get the DVB tuner to work on the K3 Pro for Armbian?

 

Thank you.

Share this post


Link to post
Share on other sites
On 8/19/2019 at 12:20 AM, Tido said:

Power Button 

Please note, the principle of using the button may be different. There are hardware buttons, they work correctly with Linux, there are "soft" buttons, they do not work well with Linux (supported only in Android firmware). What tasks do you plan to solve on this device ? With Tanix products I would recommend to be more careful, there may be problems with running Linux.

 

 

Share this post


Link to post
Share on other sites

Thank you, a valid point. Didn't consider that. The switch on the TX92 has about 4-5 cables (2 for the LED I guess). How can you tell, if a push button on such box is 'working' or not?

 

1 hour ago, balbes150 said:

there may be problems with running Linux.

hmm, can you name something that you have in mind ?

 

Share this post


Link to post
Share on other sites
Just now, balbes150 said:

that equipment

I meant in principle, as it is a "push-button" does it need to be connected to a relay or could it as well be GPIO ?

Share this post


Link to post
Share on other sites
19 minutes ago, ktk said:

@amirul were you able to use wifi on tanix tx9 pro? The firmware is there in the kernel but I think the dtb the problem.

no wifi to date, no biggie for me because I can use wired for what I need to do

Share this post


Link to post
Share on other sites

I run several boxes with armbian, most are s905x and one is s912. Mostly running home services like openhab, zm, etc. 

on s912 I run builds with Java (for my work)

and from time to time I get strange segfaults while never had them on s905x. The issue is persistent on different builds for s912.
 

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x0000ffff8f7817d0, pid=11561, tid=11590
#
# JRE version: OpenJDK Runtime Environment (11.0.4+11) (build 11.0.4+11-post-Ubuntu-1ubuntu218.04.3)
# Java VM: OpenJDK 64-Bit Server VM (11.0.4+11-post-Ubuntu-1ubuntu218.04.3, mixed mode, tiered, compressed oops, g1 gc, linux-aarch64)
# Problematic frame:
# V  [libjvm.so+0x46e7d0]
#
# No core dump will be written. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /home/alex/hs_err_pid11561.log
#
# If you would like to submit a bug report, please visit:
#   https://bugs.launchpad.net/ubuntu/+source/openjdk-lts
#


I was thinking about overheating, but never seen temp above 55

Time       big.LITTLE   load %cpu %sys %usr %nice %io %irq   CPU
15:26:41: 1000/1512MHz  3.12  19%   0%  17%   0%   1%   0% 49.0°C


Has anyone faced similar issues?
 

Share this post


Link to post
Share on other sites

Hi Everyone,

 

I have spent a lot time and effort but could not manage to Beelink GT1 running. Once I boot the device with SD card, it stucks in Beelink logo for a while (waited around 10 mins)

Is this problem might be due to current Android version ? (v6.0)

 

Can you advise which armbian version (kernel version as well) and DTB to use ?

 

Full specs Beelink GT1 2GB / 32GB (G912)

 

Bee-Link-GT1-S912-Specs.jpg

Share this post


Link to post
Share on other sites
9 hours ago, Ceteris_Paribus said:

Can you advise which armbian version (kernel version as well) and DTB to use ?

 

If when you connect the media with Armbian, the regular firmware does not start, then the universal multi-boot works and you need to setup the DTB setting (select the working dtb file).

Share this post


Link to post
Share on other sites

Look's like there is not right dtb file for the Tanix TX9s for now. The box has 2GB of ram and 8GB rom so it's quite unique at the moment. Any idea is there any change to get TX9s and Armbian working together with using dtb file from another S912 device (maybe 16GB rom version)?

Share this post


Link to post
Share on other sites
On 11/12/2019 at 7:32 AM, balbes150 said:

 

If when you connect the media with Armbian, the regular firmware does not start, then the universal multi-boot works and you need to setup the DTB setting (select the working dtb file).

Which DTB file should I use for BeeLink GT1 2gb/16 G912 ?

I tried several files but non of them worked

Share this post


Link to post
Share on other sites
On 11/12/2019 at 7:32 AM, balbes150 said:

 

If when you connect the media with Armbian, the regular firmware does not start, then the universal multi-boot works and you need to setup the DTB setting (select the working dtb file).

I got it working with Armbian_5.76_Aml-s912_Ubuntu_bionic_default_4.20.5_desktop_20190224 image even without putting any dtb file.

 

Is theresomething wrong with Kernel 5 for my box :

 

However, wifi is not working :(

Share this post


Link to post
Share on other sites
(edited)

I'm trying to install armbin on an s10 tv box, same as xgody 912. It has 3g ddr4, 1000Mb ethernet. but no sucess to boot.

 

I tried to decompile dtb from a original rom, hope I didnt made any mistake in all process to unpack, split the meson.dtb and then decompile the meson-gxm-q201-3g.dtb

 

this is the decompilation, maybe for some people it can make sense why it does but any other system that uses dtb with same name.

 

https://gist.github.com/nmocruz/a0baaf537808335ddc8bab2042131624

 

I was able to install once using an old generic armbian for s912 after a few reboot I was able to install, and the /proc/device-tree/model is saying Khadas VIM2, maybe was the first with conditions to boot. 

Edited by Nuno Cruz

Share this post


Link to post
Share on other sites

Hello!

 

Trying to set up Armbian on my Meecool M8S PRO L, based on S912 SoC. Looks like it is supported and balbes150 build should work fine. At least it worked well for my friend in 2018, but old Armbian builds based on 3.14 kernel were removed by balbes150 :(

 

Ok, I look latest build with meson-gxm-q201.dtb at least loads fine and I get the working device:

  • Working USB, mouse/keyboard
  • XFCE starts well, video output works well
  • Audio hdmi output works fine on my TV, but analog output is silent (why? Android sound)
  • ethernet works but only 100 Mb, and completely do not work with other dtb (I tried vega-s96 and s912-kiii-pro)
  • no wifi
  • no bluetooth
  • mouse pointer (cursor) is blinking while playing video, looks like video drivers are not 

Can you help me to build Armbian for my board? At least a working draft version of config will be helpfull. Any ways to get bluetooth working?

 

 

 

 

Share this post


Link to post
Share on other sites
On 11/16/2019 at 1:50 PM, Ceteris_Paribus said:

I got it working with Armbian_5.76_Aml-s912_Ubuntu_bionic_default_4.20.5_desktop_20190224 image even without putting any dtb file.

 

Is theresomething wrong with Kernel 5 for my box :

 

However, wifi is not working :(

 

Hi everyone ! Can somebody upload this version ? I need it desperately

 

Armbian_5.76_Aml-s912_Ubuntu_bionic_default_4.20.5_desktop_20190224

Share this post


Link to post
Share on other sites
On 2/1/2020 at 1:08 PM, Ceteris_Paribus said:

 

Hi everyone ! Can somebody upload this version ? I need it desperately

 

Armbian_5.76_Aml-s912_Ubuntu_bionic_default_4.20.5_desktop_20190224

 

HI, did you find this version?

 

I also have the same problem with the GT1, I have tried all the images without success.

 

Thanks.

Share this post


Link to post
Share on other sites
On 12/5/2016 at 3:42 AM, lvmc said:

@balbes150 and @chocho

 

I learnt how to extract the dtb and dts file from Beelink Android images. I will be documenting it here to help other users, but it is the exactly process @chocho already did.

 

1) update your GT1 device with GT1_104M0.img or GT1_104M0_AP6255.img

 

2) power-up, boot GT1;

 

3) copy boot.img from running Android image


adb pull /dev/block/boot boot.img

4) download split_bootimg.pl tool and run it over boot.img


wget -c http://www.enck.org/tools/split_bootimg_pl.txt -O split_bootimg.pl
chmod a+x split_bootimg.pl
split_bootimg.pl boot.img

Result:


-rw-r--r--   1 lvmc  staff    32M Dec  4 19:28 boot.img
-rw-r--r--   1 lvmc  staff   7.0M Dec  4 20:08 boot.img-kernel
-rw-r--r--   1 lvmc  staff   898K Dec  4 20:08 boot.img-ramdisk.gz
-rw-r--r--   1 lvmc  staff    82K Dec  4 20:08 boot.img-second.gz

5) find the hex addresses of "d0 0d fe ed"


hexdump -C -v boot.img-second.gz |less

Results (hex and decimal addresses):


gxm_q201_1g: 00000800 (2048)
gxm_q201_2g: 0000a800 (43008)

6) extract available dtb sections from boot.img-second.gz


gxm_q201_1g
dd if=boot.img-second.gz of=gxm_q201_1g.dtb bs=2048 skip=1

gxm_q201_2g
dd if=boot.img-second.gz of=gxm_q201_2g.dtb bs=43008 skip=1

7) convert dtb (binary format) to dts (readable)


dtc -I dtb -O dts -o gxm_q201_201_1g.dts gxm_q201_201_1g.dtb
dtc -I dtb -O dts -o gxm_q201_201_2g.dts gxm_q201_201_2g.dtb

*dtc command is available on GNU/Linux

 

There is only one difference between gxm_q201_201_1g.dts and gxm_q201_201_2g.dts


memory@00000000 {
device_type = "memory";
linux,usable-memory = <0x0 0x1000000 0x0 0x3f000000>;
};


memory@00000000 {
device_type = "memory";
linux,usable-memory = <0x0 0x1000000 0x0 0x7f000000>;
};

boot.img, dtb and dts files from previous steps are available at:

https://dl.dropboxusercontent.com/u/11164079/GT1/beelink_gt1.tar.gz

 

beelink_gt1/boot


-rw-r--r--  1 lvmc  staff    32M Dec  4 19:28 boot.img
-rw-r--r--  1 lvmc  staff   7.0M Dec  4 20:08 boot.img-kernel
-rw-r--r--  1 lvmc  staff   898K Dec  4 20:08 boot.img-ramdisk.gz
-rw-r--r--  1 lvmc  staff    82K Dec  4 20:08 boot.img-second.gz

beelink_gt1/dtb_dts


-rw-r--r--  1 lvmc  staff    80K Dec  4 20:24 gxm_q201_1g_00000800.dtb
-rw-r--r--  1 lvmc  staff    48K Dec  4 20:25 gxm_q201_1g_00000800.dts
-rw-r--r--  1 lvmc  staff    40K Dec  4 20:18 gxm_q201_2g_0000a800.dtb
-rw-r--r--  1 lvmc  staff    48K Dec  4 20:21 gxm_q201_2g_0000a800.dts

i am using above mentioned commands but split_bootimg.pl does not produce boot.img-second.gz file

Share this post


Link to post
Share on other sites

Hello I try to put Armbian on my H96+ S912 but i got same error with sd car or usb

 

Install /sdcard/aml_autoscript.zip

Finding update package...

Opening update package...

failed to map file

Installation aborted

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
46 46