Jump to content
  • 0

Display + Wi-Fi 5G


SET
 Share

Question

Hello.

 

I downloaded Armbian 22.05 Jammy XFCE for Desktop.

When I boot up my Orange Pi 4 LTS everything looks good.

The first problem was a Wi-Fi 5G password (system dont recognize my password), only 2.4G works.

The second problem (and the main problem) was a display - when X start, my display turn off (I have HDMI-connection).

What I am doing wrong?

Link to comment
Share on other sites

9 answers to this question

Recommended Posts

Armbian is a community driven open source project. Do you like to contribute your code?

  • 0

I did not test 5G wifi connection, this issue seems it has been already raised in the past and honestl I see little room for improvement from armbian side: IMHO there is something missing from the driver or the firmware for the wifi chip.

It was unexpectedly painful to integrate the wifi driver into mainline 5.15 kernel (it worked fine on 5.10) that I totally forgot to test 5G connection; anyway the driver has several shortcomings on its own that the missing 5G functionality does not surprise me.

 

About the HDMI issue, can't say anything: never experienced such issue on my full-hd basic monitor. What monitor are you using? Did you try another cable or another monitor port? Do your monitor has audio? Are you using any kind of adapter?

Link to comment
Share on other sites

  • 0
7 часов назад, jock сказал:

I did not test 5G wifi connection, this issue seems it has been already raised in the past and honestl I see little room for improvement from armbian side: IMHO there is something missing from the driver or the firmware for the wifi chip.

It was unexpectedly painful to integrate the wifi driver into mainline 5.15 kernel (it worked fine on 5.10) that I totally forgot to test 5G connection; anyway the driver has several shortcomings on its own that the missing 5G functionality does not surprise me.

 

About the HDMI issue, can't say anything: never experienced such issue on my full-hd basic monitor. What monitor are you using? Did you try another cable or another monitor port? Do your monitor has audio? Are you using any kind of adapter?

 

I have a very simple monitor too. I don't try another cable. My monitor doesn't have audio. I'll try VGA-HDMI adapter and inform you.

I noticed that the monitor loses the signal after logging in to X.

Link to comment
Share on other sites

  • 0
04.08.2022 в 17:26, jock сказал:

I did not test 5G wifi connection, this issue seems it has been already raised in the past and honestl I see little room for improvement from armbian side: IMHO there is something missing from the driver or the firmware for the wifi chip.

It was unexpectedly painful to integrate the wifi driver into mainline 5.15 kernel (it worked fine on 5.10) that I totally forgot to test 5G connection; anyway the driver has several shortcomings on its own that the missing 5G functionality does not surprise me.

 

About the HDMI issue, can't say anything: never experienced such issue on my full-hd basic monitor. What monitor are you using? Did you try another cable or another monitor port? Do your monitor has audio? Are you using any kind of adapter?

I bought a brand new VGA cable and an HDMI-VGA adapter. After boot the start logo became of terrible quality than over HDMI cable. The result is the same, only now I don't even see a screen for entering a username and password)

photo_2022-08-07_15-44-19.jpg

Link to comment
Share on other sites

  • 0

I agree with @Werner, I was asking if an adapter was in use to understand if there could be an interference with the HDMI signal.

 

The output of these commands can be useful:

xrandr --verbose
get-edid | parse-edid

(you may wish to install read-edid package first for get-edid and parse-edid utils)

Link to comment
Share on other sites

  • 0

Ok, took a look to this.

 

xrandr of course works only when there is an X11 session running; it must can be run from a SSH session of the same user logged in X11 this way:

export DISPLAY=:0
xrandr --verbose

 

About get-edid, it requires the right bus on the command line because autoscanning does not seem to work (can be run either from SSH session or a terminal):

sudo get-edid -b 7 | parse-edid

 

This is what I get, for example, on my system with a basic 21" HP monitor:

paolo@orangepi4-lts:~$ sudo get-edid -b 7 | parse-edid
7
This is read-edid version 3.0.2. Prepare for some fun.
Attempting to use i2c interface
Only trying 7 as per your request.
256-byte EDID successfully retrieved from i2c bus 7
Looks like i2c was successful. Have a good day.
Checksum Correct

Section "Monitor"
        Identifier "HP 22w"
        ModelName "HP 22w"
        VendorName "HPN"
        # Monitor Manufactured week 15 of 2019
        # EDID version 1.3
        # Digital Display
        DisplaySize 480 270
        Gamma 2.20
        Option "DPMS" "true"
        Horizsync 30-80
        VertRefresh 50-60
        # Maximum pixel clock is 170MHz
        #Not giving standard mode: 1920x1080, 60Hz
        #Not giving standard mode: 1280x720, 60Hz
        #Not giving standard mode: 1600x900, 60Hz
        #Not giving standard mode: 1680x1050, 60Hz
        #Not giving standard mode: 1440x900, 60Hz
        #Not giving standard mode: 1280x800, 60Hz
        #Not giving standard mode: 1280x1024, 60Hz

        #Extension block found. Parsing...
        Modeline        "Mode 10" 148.50 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync 
        Modeline        "Mode 0" 148.50 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync 
        Modeline        "Mode 1" 148.500 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
        Modeline        "Mode 2" 148.500 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync
        Modeline        "Mode 3" 74.250 1280 1390 1420 1650 720 725 730 750 +hsync +vsync
        Modeline        "Mode 4" 74.250 1280 1720 1760 1980 720 725 730 750 +hsync +vsync
        Modeline        "Mode 5" 27.027 720 736 798 858 480 489 495 525 -hsync -vsync
        Modeline        "Mode 6" 27.000 720 732 796 864 576 581 586 625 -hsync -vsync
        Modeline        "Mode 7" 27.027 720 736 798 858 480 489 495 525 -hsync -vsync
        Modeline        "Mode 8" 27.000 720 732 796 864 576 581 586 625 -hsync -vsync
        Modeline        "Mode 9" 25.200 640 656 752 800 480 490 492 525 -hsync -vsync
        Modeline        "Mode 11" 148.50 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync 
        Option "PreferredMode" "Mode 10"
EndSection

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...