Jump to content
  • 0

camera driver



I have been reading about webcams, etc. and Linux and am working with my LePotato running Ubuntu 22.04. I added the Arduino CSI-USB converter so I can plug in an RPiHQ cam into the USB port. I see the following in the log messages:
pi@lepotato:~$ dmesg | grep Camera
[    4.431905] usb 1-1.2: Product: Arducam IMX477 HQ Camera
[    8.798501] uvcvideo: Found UVC 1.00 device Arducam IMX477 HQ Camera (0c45:636d)
[    8.806595] input: Arducam IMX477 HQ Camera: Arduc as /devices/platform/soc/d0078080.usb/c9000000.usb/xhci-hcd.2.auto/usb1/1-1/1-1.2/1-1.2:1.0/input/input3


But I have no idea how to test further.


I've tried cheese:


** (cheese:4159): ERROR **: 13:06:46.007: cheese-application.vala:89: Unable to initialize libcheese-gtk
Trace/breakpoint trap (core dumped)


cheese -d [total guess at device] 

same as above


And libcam-hello:

-bash: libcam-hello: command not found


I've tried installing libcam following what I found Googling, but I just keep digging a deeper hole.


I am lost. The camera works fine with Raspbian Bullseye in CSI mode, but my limited knowledge doesn't tell me whether the messages I'm seeing with Armbian mean much. What should I do next?




Link to comment
Share on other sites

1 answer to this question

Recommended Posts

Help us fund some #badass gear for our continuous integration build framework

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...