Jump to content

Pinebook PRO does not boot Armbian_22.08.1_Pinebook-pro_bullseye_current_5.15.63.img


Dianne S.
 Share

Recommended Posts

Armbian Linux community supported weekly builds download

UPDATE: For whatever reason, /boot/boot.scr was corrupt; it had a bunch of garbage prior to the "# DO NOT EDIT THIS FILE" line.  I removed that garbage and now the Pinebook PRO boots... into Manjaro.  Here's the relevant serial console output:

Scanning mmc 1 for bootable partitions...
Scanning mmc 1:1 for extlinux or boot scripts...
Found U-Boot script /boot/boot.scr
3113 bytes read in 19 ms (159.2 KiB/s)
## Executing script at 00500000
Wrong image format for "source" command
SCRIPT FAILED: continuing...

EDIT: Meh, I guess the junk is needed as it's a legacy uImage.  So that's not it.  But obviously the junk at the top of boot.scr is not the correct junk.

Edited by Dianne S.
Update with new info
Link to comment
Share on other sites

I downloaded xfce for PBP from armbian website, flashed to sdcard with etcher and booted successfully.

 

Caveat I don't have emmc chip installed and nothing on SPI.  

 

So yeah could easily be manjaro uboot allergies to trying to pivot to armbian to boot.

 

If possible just wipe emmc

 

 

Link to comment
Share on other sites

Hmm, ok.  I don't want to wipe the emmc until I'm confident I can install Armbian successfully on the emmc; running from the SD card is not a long-term solution.

 

I'll run a test with the emmc switch disabled to see if that at least lets me boot from the SD card.  My SPI is empty also.

 

Thanks,

 

Dianne.

 

Link to comment
Share on other sites

Thanks.  With the emmc disabled, it booted into Armbian.

 

I have a USB-to-emmc adapter.  If I were to simply write the image directly to the emmc from my workstation, would that be expected to work?

 

Regards,

 

Dianne.

 

Link to comment
Share on other sites

7 minutes ago, Dianne S. said:

 

I have a USB-to-emmc adapter.  If I were to simply write the image directly to the emmc from my workstation, would that be expected to work?

 

 

Yep writing image directly to emmc should be fine.   Has been the case historically for me.   

Link to comment
Share on other sites

So, just to close this out:  Writing directly to the emmc did not work.  The system was unable to find the root file system.  It had the wrong UUID somehow, so I changed it with tune2fs.  Still no luck.

I then replaced the rk3399-pinebook-pro.dtb with the one that ships with Manjaro.  That booted, but the laptop screen did not come on.  I could only access it via the serial port.

Finally, I saw this post: https://forum.pine64.org/showthread.php?tid=17215
 

When I replaced rk3399-pinebook-pro.dtb with the version from Kali Linux, it booted, I got the display, and everything worked.  I now finally have Armbian running from the emmc, albeit with the device tree blob from Kali Linux.

 

Link to comment
Share on other sites

5 hours ago, Dianne S. said:

 

When I replaced rk3399-pinebook-pro.dtb with the version from Kali Linux, it booted, I got the display, and everything worked.  I now finally have Armbian running from the emmc, albeit with the device tree blob from Kali Linux.

 

When was your PBP made?  Is it from one of the newer production runs from past year?

 

Mines from 2nd gen. (Pre covid era)    I remember seeing Kali had a few extra patches for the newer PBPs

Link to comment
Share on other sites

Hi.  My PBP is very new; I bought it within the last couple of months.  I decompiled the two .dtb files using dtc, but there are a lot of differences and I'm a bit out of my depth here.  Also, it's probably better to look at the source files rather than the decompiled .dtbs because they will have comments and symbols.  Anyway, for what it is worth, I have attached the two decompiled dtb files.  The kali one works and the armbian one does not, when booting from the emmc.
 

armbian-rk3399-pinebook-pro.dts kali-linux-rk3399-pinebook-pro.dts

Link to comment
Share on other sites

Well, there are a lot of differences between the files, but most of them seem minor (different phandle values, for example).  I wouldn't know how to look for significant differences in the dtbs, so I have to leave this with the Armbian devs.  Thanks to all who helped with suggestions.

Link to comment
Share on other sites

Any progress on this?  Each time the kernel upgrades, it messes up my PBP and I have to re-install the Kali Linux dtb file.  Any pointers to where I can at least find the Armbian dts and dtsi sources so I can start comparing them with Kali?

Link to comment
Share on other sites

On 10/19/2022 at 7:48 PM, Dianne S. said:

Any pointers to where I can at least find the Armbian dts and dtsi sources so I can start comparing them with Kali?

 

Start with https://github.com/armbian/build

 

./compile.sh EXPERT=yes CREATE_PATCHES="yes"


When prompted for kernel patch, go to cache/sources/KERNEL_SOURCE_DIR ... and change in the DTS what needs to be changed. Then add a patch to:
https://github.com/armbian/build/tree/master/patch/kernel/archive/rockchip64-6.0

and

https://github.com/armbian/build/tree/master/patch/kernel/archive/rockchip64-5.19

 

following by creating a pull request.

Link to comment
Share on other sites

Thanks.  However, I have a working solution (using the Kali dtb) and I have no motivation to go chasing this down... I'm not an Armbian dev and don't have the time to put into this.  I would hope that the Pinebook Pro maintainer would be able to do it.

Link to comment
Share on other sites

10 hours ago, Dianne S. said:

However, I have a working solution


Understand, but you will need to workaround each time ... 

 

10 hours ago, Dianne S. said:

I would hope that the Pinebook Pro maintainer would be able to do it.


He hasn't showed up for a while, but we recreated and tested images last night https://www.armbian.com/pinebook-pro/ (kernel 6.0.6) and they boot normally. From SD and from (some) eMMC

 

10 hours ago, Dianne S. said:

I'm not an Armbian dev

 

It is Pine64 responsibility to deal with low level problems. Its only our good will if we invest into their business. Do they deserve? https://blog.brixit.nl/why-i-left-pine64/

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...