ARMBIAN for Amlogic S905 and S905X
30 30

1190 posts in this topic

Recommended Posts

I can not get this version (Armbian_5.34_S9xxx_Ubuntu_xenial_4.9.40_mate_20171112.img.xz) to install on my Mini M8S II (Amlogic S905x).  I have been running an older version for along time without any problems.  I thought I would give you new version a try, but no luck.  I have tried a couple of dtb.img files, but it will not boot.

 

 

Share this post


Link to post
Share on other sites
10 hours ago, clarkss12 said:

I can not get this version (Armbian_5.34_S9xxx_Ubuntu_xenial_4.9.40_mate_20171112.img.xz) to install on my Mini M8S II (Amlogic S905x).  I have been running an older version for along time without any problems.  I thought I would give you new version a try, but no luck.  I have tried a couple of dtb.img files, but it will not boot.

The images with the kernel 4.9.40 is only for those TV boxes, where set a new u-boot (Nougat-Ubuntu). Today, this model Khadas VIM and VIM2.

Share this post


Link to post
Share on other sites

I'm trying to add wifi, but I can't, I'm so stupid on these things, I opened MATE terminal on my s905 with gxbb_p201.dbt file but when I try to insert "modprobe wifi_dummy" or "modprobe dhd" it doesn't work. Terminal says: "could not insert 'wifi_dummy': operation not permitted". I don't understand very well English but I don't thing that the metod was wrong. 

Share this post


Link to post
Share on other sites
8 hours ago, balbes150 said:

The images with the kernel 4.9.40 is only for those TV boxes, where set a new u-boot (Nougat-Ubuntu). Today, this model Khadas VIM and VIM2.

Hi balbes, can you tell me what packages are required to run kodi on the ubuntu server image ? and is there any additional configurations I have to do to make it run flawlessly ? I know you already uploaded arch with kodi but I want to learn how to install kodi on the server image myself.  No desktop environment, just a minimal setup for kodi. I know there's LibreELEC already but it's too limited, I can't install additional packages on it. Thank you.

Share this post


Link to post
Share on other sites
1 hour ago, Davide De Carlo said:

I'm trying to add wifi, but I can't, I'm so stupid on these things, I opened MATE terminal on my s905 with gxbb_p201.dbt file but when I try to insert "modprobe wifi_dummy" or "modprobe dhd" it doesn't work. Terminal says: "could not insert 'wifi_dummy': operation not permitted". I don't understand very well English but I don't thing that the metod was wrong. 

sudo modprobe wifi_dummy

or

sudo modprobe dhd

 

*******************************************

su - (enter the root password)

modprobe wifi_dummy

 

or

 

su - (enter the root password)

modprobe dhd

 

Davide De Carlo likes this

Share this post


Link to post
Share on other sites
23 minutes ago, hillz said:

Hi balbes, can you tell me what packages are required to run kodi on the ubuntu server image ? and is there any additional configurations I have to do to make it run flawlessly ? I know you already uploaded arch with kodi but I want to learn how to install kodi on the server image myself.  No desktop environment, just a minimal setup for kodi. I know there's LibreELEC already but it's too limited, I can't install additional packages on it. Thank you.

All packages that begin at

aml-*

 

https://yadi.sk/d/09xzoZ3Y3PSYBb

 

To add user to all groups that are required to run KODI and its libraries. Probably need to install and configure additional packages that have default images of the desktop (I have not studied for a full list of packages).

Share this post


Link to post
Share on other sites

Today I did an upgrade ("apt-get upgrade") and after it if I run an "apt-get update" I have these errors:

 

Hit:1 http://ftp.de.debian.org/debian testing InRelease
Hit:2 http://security.debian.org jessie/updates InRelease           
Hit:4 http://apt.armbian.com jessie InRelease                           
Ign:3 http://cdn-fastly.deb.debian.org/debian jessie InRelease          
Hit:5 http://cdn-fastly.deb.debian.org/debian jessie-updates InRelease
Hit:6 http://cdn-fastly.deb.debian.org/debian jessie-backports InRelease
Hit:7 http://cdn-fastly.deb.debian.org/debian jessie Release
Reading package lists... Done
W: http: aptMethod::Configuration: could not load seccomp policy: Invalid argument
W: http: aptMethod::Configuration: could not load seccomp policy: Invalid argument
W: http: aptMethod::Configuration: could not load seccomp policy: Invalid argument
W: http: aptMethod::Configuration: could not load seccomp policy: Invalid argument
W: http: aptMethod::Configuration: could not load seccomp policy: Invalid argument

 

what is happening? I'm on Jessie server.

 

Postedit:

I restored the backup that I did before doing the upgrade and I tried a new upgrade with the testing repo disabled, obviously have been updated few packages but I don't have more that error.

 

@balbes150, why yours Armbian versions have been built with the testing repo enabled? They natively include a lot of testing packages.

Share this post


Link to post
Share on other sites
4 hours ago, balbes150 said:

sudo modprobe wifi_dummy

or

sudo modprobe dhd

 

*******************************************

su - (enter the root password)

modprobe wifi_dummy

 

or

 

su - (enter the root password)

modprobe dhd

 

Thanks a lot, now it's all complete. Another question, my Tv Box has 1gb of ram and when I play a video on youtube with ubuntu mate on Chromium lags enough when I put the resolution on 720p or when I put it in fullscreen, the CPU usage reaches 80/90%, I tried all the dtb files. It is normal or am I doing something wrong? How can I increase performance in general?

Share this post


Link to post
Share on other sites
10 hours ago, fatugazuhati said:

why yours Armbian versions have been built with the testing repo enabled?

I already replied earlier to this question. At the time of assembling the images in the standard repositories Jessi didn't have the right versions of packages. Now there have been many changes in the repositories (test disabled) and now I am collecting images of Debian using the official branches Stretch. By the way, to all , I will repeat for the, at the moment (when I checked last time) in the thread Jessi broken packages, which are responsible for mounting a label, so when you try to upgrade from Jessi you risk to not run from external media system.

 

8 hours ago, Davide De Carlo said:

I tried all the dtb files. It is normal or am I doing something wrong? How can I increase performance in general?

Video hardware acceleration is only in KODI. Therefore, any other program (including browsers) use softbuy processing, which need all the resources of the processor (the more powerful the processor, the better the video quality).

If you want to get a full-screen video in the browser - it can be assembled using the library libMali.

Davide De Carlo likes this

Share this post


Link to post
Share on other sites
7 hours ago, balbes150 said:

I already replied earlier to this question. At the time of assembling the images in the standard repositories Jessi didn't have the right versions of packages. Now there have been many changes in the repositories (test disabled) and now I am collecting images of Debian using the official branches Stretch. By the way, to all , I will repeat for the, at the moment (when I checked last time) in the thread Jessi broken packages, which are responsible for mounting a label, so when you try to upgrade from Jessi you risk to not run from external media system.

I'm sorry if my question has been redundant, I'm daily following this thread ,I tried to read it entirely and I always search in it before posting my questions but unfortunately I wasn't been able to found the answers.

 

So should I update to Stretch? The correct ways is the standard "apt-get dist-upgrade" or should I do a clean install?

The broken packages responsible to mounting a label are also present in Jessie for x86 or only in the arm arch?

Share this post


Link to post
Share on other sites
12 hours ago, balbes150 said:

Video hardware acceleration is only in KODI. Therefore, any other program (including browsers) use softbuy processing, which need all the resources of the processor (the more powerful the processor, the better the video quality).

If you want to get a full-screen video in the browser - it can be assembled using the library libMali.

Got it, I have one last thing do to, actually, I need use Kodi because I want use Spotify, Youtube, Soundcloud, NetflixXMBC etc. But when I try to configure an add-on (installed by zip file), Kodi says "No PVR add-on installed, you need a tuner blackend software". I tried enable PVR on Live TV, in setting (they had already enabled), but if I go in TV add-on there isn't anything, how can I add PVR clients? I searched on internet but I haven't find solutions, can you help me? 

 

EDIT: another problem, when I try to plug an External USB device, in my case is an Usb pendrive, Kodi doens't see it. When I use Kodi from Ubuntu Mate works, but if I try to plug when I'm in Kodi Rom doesn't show it

Share this post


Link to post
Share on other sites
Spoiler

RUS

balbes - я уже писал, что мне нужна необслуживаемая система (с удаленным доступом).
Я как раз мучаюсь в попытках использовать hw. Может можешь мне подсказать в каком направлении делать мне тесты и где можно почитать на эту тему информацию? я уверен, что если мне удасться решить свой вопрос - то это будет полезным и другим.
Самым коротким путем, я так понимаю будет разобраться в исходных текстах KODI и понять их реализацию использования GPU без x11, но пока что мне даже не удалось запустить KODI без x11 :(

balbes - I already wrote that I need a maintenance-free system (with remote access).
I'm just tormenting myself in trying to use hw. Maybe you can tell me in which direction to do the tests for me and where can I read the information on this topic? I'm sure that if I manage to solve my question, it will be useful to others.
The shortest way, I understand it will be to understand the source code of KODI and understand their implementation of using GPU without x11, but so far I have not even managed to run KODI without x11 :(

Share this post


Link to post
Share on other sites
14 hours ago, Davide De Carlo said:

Got it, I have one last thing do to, actually, I need use Kodi because I want use Spotify, Youtube, Soundcloud, NetflixXMBC etc. But when I try to configure an add-on (installed by zip file), Kodi says "No PVR add-on installed, you need a tuner blackend software". I tried enable PVR on Live TV, in setting (they had already enabled), but if I go in TV add-on there isn't anything, how can I add PVR clients? I searched on internet but I haven't find solutions, can you help me? 

 

EDIT: another problem, when I try to plug an External USB device, in my case is an Usb pendrive, Kodi doens't see it. When I use Kodi from Ubuntu Mate works, but if I try to plug when I'm in Kodi Rom doesn't show it

1. If you use advanced features KODI, I recommend using Libreelec. You can install one of these systems (LE or Armbian) to eMMC , and the second to run from external media. If you have a model VIM2, you can install in eMMC universal system MultiOS_3in1 (Android+LibreELEC+Armbian or any other variant of Linux).

2. To use a USB stick with KODI you can try to mount it via SSH.

 

2 hours ago, Baloven said:

Maybe you can tell me in which direction to do the tests for me and where can I read the information on this topic?

Spoiler

Ищи информацию об использовании библиотеки MALI. У меня нет конкретной инфы по этому вопросу. Насколько знаю, KODI использует x11 в ограниченном виде, поэтому совсем без x11 не обойтись. Можешь попробовать посмотреть исходники Amlogic на предмет, как они используют в gstreamer работу с фреймбуфером и libamcodec.

Look for information about using the libraries MALI. I have no specific information on this issue. As far as I know, KODI uses x11 in a limited way, so no x11 is not necessary. You can try to view the source code for Amlogic on the subject of how they use gstreamer to work with the framebuffer and libamcodec.

Share this post


Link to post
Share on other sites
1 hour ago, balbes150 said:

1. If you use advanced features KODI, I recommend using Libreelec. You can install one of these systems (LE or Armbian) to eMMC , and the second to run from external media. If you have a model VIM2, you can install in eMMC universal system MultiOS_3in1 (Android+LibreELEC+Armbian or any other variant of Linux).

2. To use a USB stick with KODI you can try to mount it via SSH.

 

  Reveal hidden contents

Ищи информацию об использовании библиотеки MALI. У меня нет конкретной инфы по этому вопросу. Насколько знаю, KODI использует x11 в ограниченном виде, поэтому совсем без x11 не обойтись. Можешь попробовать посмотреть исходники Amlogic на предмет, как они используют в gstreamer работу с фреймбуфером и libamcodec.

Look for information about using the libraries MALI. I have no specific information on this issue. As far as I know, KODI uses x11 in a limited way, so no x11 is not necessary. You can try to view the source code for Amlogic on the subject of how they use gstreamer to work with the framebuffer and libamcodec.

Ok, I will instal Libreelec instead of using Kodi, but I won't install to eMMc because I'm not expert so I could brick the TV box. Can I install Libreleec to SD card and also approach with Ubuntu MATE? Or can I have only one OS at time? 

https://www.amazon.it/VicTsing-Quad-core-Bluetooth-Precaricato-Intrattenimento/dp/B01AMYSGHM/ (I have this TV box, MODEL: VITV-2, Android on this TV box is very slow, so I can't use it, Armbian and Kodi as so much faster than the original system, you would reccomend to install anyway to eMMc Libreleec and Armbian? I'm worried if I could cause a brick if I install these system on the eMMc, I had only 8gb sd scard, so If I do a backup I haven't so much space) 

Share this post


Link to post
Share on other sites
33 minutes ago, Davide De Carlo said:

Ok, I will instal Libreelec instead of using Kodi, but I won't install to eMMc because I'm not expert so I could brick the TV box. Can I install Libreleec to SD card and also approach with Ubuntu MATE? Or can I have only one OS at time? 

https://www.amazon.it/VicTsing-Quad-core-Bluetooth-Precaricato-Intrattenimento/dp/B01AMYSGHM/ (I have this TV box, MODEL: VITV-2, Android on this TV box is very slow, so I can't use it, Armbian and Kodi as so much faster than the original system, you would reccomend to install anyway to eMMc Libreleec and Armbian? I'm worried if I could cause a brick if I install these system on the eMMc, I had only 8gb sd scard, so If I do a backup I haven't so much space) 

1. Start Armbian from SD card.

2. Open a terminal and run the command "sudo ddbr", then follow the prompts. Select the mode for creating a compressed backup. Ddbr utility creates a full backup (on the SD card in the directory /ddbr) of the system that you are now in the internal memory of the TV box.

3. After that you can write on the USB flash drive system Libreelec and connect to the TV box. Notice - to activate the multi-boot is not necessary. Libreelec should automatically start up with USB stick. Check the LE (all devices on your TV box) and if everything is working correctly, you can run the installation LE in the inside memory.

Share this post


Link to post
Share on other sites
1 hour ago, balbes150 said:

1. Start Armbian from SD card.

2. Open a terminal and run the command "sudo ddbr", then follow the prompts. Select the mode for creating a compressed backup. Ddbr utility creates a full backup (on the SD card in the directory /ddbr) of the system that you are now in the internal memory of the TV box.

3. After that you can write on the USB flash drive system Libreelec and connect to the TV box. Notice - to activate the multi-boot is not necessary. Libreelec should automatically start up with USB stick. Check the LE (all devices on your TV box) and if everything is working correctly, you can run the installation LE in the inside memory.

Can I use USB drive (with LibreELEC) and SD Card (with Amrbian) alternately without installing LibreELEC on eMMC (and then without losing android?, i use dtb file "gxbb_p200_1G_1Gigabit")

 

EDIT: I've installed libreelec on usb drive and now I have armbian on sd card and libreelec on usb drive, how can I switch from Armbian to Libreelec (for example) directly without remove pendrive or sdcard? it is possible from terminal (of armbian)?

Share this post


Link to post
Share on other sites
25 minutes ago, Davide De Carlo said:

Can I use USB drive (with LibreELEC) and SD Card (with Amrbian) alternately without installing LibreELEC on eMMC (and then without losing android?, i use dtb file "gxbb_p200_1G_1Gigabit")

 

EDIT: I've installed libreelec on usb drive and now I have armbian on sd card and libreelec on usb drive, how can I switch from Armbian to Libreelec (for example) directly without remove pendrive or sdcard? it is possible from terminal (of armbian)?

You can use unlimited number of systems on external media. When you connect together several media, always run the same system in order of priority - USB -> SD. To run from SD card, you need to be sure to turn the system off USB.

Davide De Carlo likes this

Share this post


Link to post
Share on other sites
21 hours ago, fatugazuhati said:

I'm sorry if my question has been redundant, I'm daily following this thread ,I tried to read it entirely and I always search in it before posting my questions but unfortunately I wasn't been able to found the answers.

 

So should I update to Stretch? The correct ways is the standard "apt-get dist-upgrade" or should I do a clean install?

The broken packages responsible to mounting a label are also present in Jessie for x86 or only in the arm arch?

@balbes150, please could tell me what do do and how?

Share this post


Link to post
Share on other sites
21 minutes ago, balbes150 said:

You can use unlimited number of systems on external media. When you connect together several media, always run the same system in order of priority - USB -> SD. To run from SD card, you need to be sure to turn the system off USB.

 

Got it, thanks. And if I install Libreelec on eMMc can I switch from Libreelec to Armbian (installed on sd card) or viceversa directly from the OS (using a terminal for example)? Or I need power off the system and remove the sd card to load Libreelec/add sd card to load Armbian? (Sorry for my misunderstanding, I'm little confused)

Share this post


Link to post
Share on other sites
1 hour ago, fatugazuhati said:

please could tell me what do do and how?

I apologize for the delay in response. Before upgrading, I recommend doing a full backup (utility ddbr).

1. Then you can try updating via apt. If the system fails to start, you will have to perform a clean installation.

2. I haven't tested the packs mount in x86.

 

1 hour ago, Davide De Carlo said:

Got it, thanks. And if I install Libreelec on eMMc can I switch from Libreelec to Armbian (installed on sd card) or viceversa directly from the OS (using a terminal for example)? Or I need power off the system and remove the sd card to load Libreelec/add sd card to load Armbian? (Sorry for my misunderstanding, I'm little confused)

 

The start order of systems in the presence of external media. If you have a bootable system on a USB , it runs first USB -> if USB is no system (or no USB), checks the system on the SD and if there is, it runs SD -> if there is no system on the SD card , run system from eMMC.

Davide De Carlo likes this

Share this post


Link to post
Share on other sites
22 minutes ago, balbes150 said:

I apologize for the delay in response. Before upgrading, I recommend doing a full backup (utility ddbr).

1. Then you can try updating via apt. If the system fails to start, you will have to perform a clean installation.

2. I haven't tested the packs mount in x86.

 

 

The start order of systems in the presence of external media. If you have a bootable system on a USB , it runs first USB -> if USB is no system (or no USB), checks the system on the SD and if there is, it runs SD -> if there is no system on the SD card , run system from eMMC.

Ok thanks. So I have a problem, to switch from an OS to another I have to unplug the supply power and remove and external media. When I turn off the system (without unplug) I can't power on again with the remote control. I tried to rename "remote.conf" but remote control doesn't work (only with Android it works). So every time I need to power on I need to plug the power supply and insert external media of a determinate system that I want to use. So...

1) there is a way to switch directly from a OS to another?

2) How can I add remote control? (I tried the method on first post but doesn't work for me.)

Share this post


Link to post
Share on other sites
36 minutes ago, balbes150 said:

I apologize for the delay in response. Before upgrading, I recommend doing a full backup (utility ddbr).

1. Then you can try updating via apt. If the system fails to start, you will have to perform a clean installation.

2. I haven't tested the packs mount in x86.

 

Thank you, I'll try to update and I'll report back my experience.
Also the debian Debian Stretch version has been built with the testing repo enabled?

Share this post


Link to post
Share on other sites
28 minutes ago, Davide De Carlo said:

1) there is a way to switch directly from a OS to another?

2) How can I add remote control? (I tried the method on first post but doesn't work for me.)

1. In current versions of LE (at startup LE from the media) in the shutdown menu, it is possible to choose to reload the system, which is located in the internal memory ("Rebot from NAND flash\Android"). Ie if you set Armbian in eMMC and when you run the LE from external media, you can choose a LE to restart the system , which is in the eMMC.

2. What version of LE are you using ?

 

20 minutes ago, fatugazuhati said:

Thank you, I'll try to update and I'll report back my experience.
Also the debian Debian Stretch version has been built with the testing repo enabled?

In image Stretch not use a test repository.

Davide De Carlo likes this

Share this post


Link to post
Share on other sites

As far as I remember, Kszaq (the author of the Assembly LE) uses an additional procedure at the start itself should pull out of Android the desired file to the remote control. Look at the USB stick after the first start and setup LE, you should see the file remote.conf from your TV box.

Share this post


Link to post
Share on other sites

Browsing the web with chromium on ubuntu mate is really slow, opening a few tabs will put the CPU at 100%, I can't even watch youtube videos without lags at full screen 720p, is it just me ? I'm using Tanix TX3 Mini with S905W processor. Is it the problem with the CPU power being too little or is it because the CPU is just too hot that it can't make use of its full CPU performance ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

30 30

  • Support the project

    We need your help to stay focused on the project.

    Choose the amount and currency you would like to donate in below.