54 54
balbes150

ARMBIAN for Amlogic S905 and S905X

Recommended Posts

So guys, i have a new issue which i cannot fix by myself.

wifi dont work. I Tried every dtb file But my wifi modul never worked.

 

so i googled.

i found that i have a rare Chip:

aigale aw-cm273sm

 

is there any way to get the driver for this Modul?

 

kind regards

 

Share this post


Link to post
Share on other sites
On 9/4/2018 at 3:35 PM, chpasha said:

you can try ;) . 3.14 with /root/install.sh command, 4.18 with

1. Execute script “/boot/create-mbr-linux.sh”
2. Execute script “/root/install.sh”

and see if that works :)

Did not work on my Mini M8S, after running the script it didn't even boot from the SD card anymore :(

Share this post


Link to post
Share on other sites
11 hours ago, yurek_m said:

dear k1plus s905d 1gb ram model dtb image linux  4.18 help????????????????????

Alas, I can not help you, I do not have such equipment.

 

6 hours ago, Reddwarf said:

Did not work on my Mini M8S, after running the script it didn't even boot from the SD card anymore

Most likely on your model there is no eMMC (old NAND is used).

Share this post


Link to post
Share on other sites
7 hours ago, Reddwarf said:

Did not work on my Mini M8S, after running the script it didn't even boot from the SD card anymore :(

I had the same issue.

thats because your sd card is mmcblk0 and your nand/emmc is mmcblk1. In the install and create_mbr script this is wrong. You have to make some changes by yourself. After that your box wont boot because the boot partition search for mmcblk1p2 but its actually mmcblk0p2.

 

may you write me personal, may i can help you with that.

 

kind regards,

Share this post


Link to post
Share on other sites
6 hours ago, balbes150 said:

Most likely on your model there is no eMMC (old NAND is used).

I see, so there is no way to install on old NAND?

 

I'm trying on a MXQ Pro+ and seems to have more success but boot hangs. I'll investigte further.

Another question, is there a way to get accelerated video on 4.18?

Share this post


Link to post
Share on other sites
8 hours ago, lizzacore said:

I had the same issue.

thats because your sd card is mmcblk0 and your nand/emmc is mmcblk1. In the install and create_mbr script this is wrong. You have to make some changes by yourself. After that your box wont boot because the boot partition search for mmcblk1p2 but its actually mmcblk0p2.

 

may you write me personal, may i can help you with that.

There are no errors in scripts. The reason is the incorrect operation of u-boot (your u-boot is very outdated and contains an error), which changes the eMMC number depending on the connection or disconnection of the SD card.

 

2 hours ago, Reddwarf said:

Another question, is there a way to get accelerated video on 4.18? 

It's possible, but I don't plan to add it yet.

Share this post


Link to post
Share on other sites
16 minutes ago, balbes150 said:

It's possible, but I don't plan to add it yet.

Any particular reason for that? Armbian is much more versatile and useful WITH HW acceleration....

 

And is it impossible to install to old NAND?

Share this post


Link to post
Share on other sites

If it is possible, could you provide links to the stuff needed to watch hw accelerated videos?

I do believe it's not an easy task, but if it isn't too complicated, why not, i would try.

I know you are doing this in your free time for free, and that is why we all wish to thank you.

I would help you if i've had the knowledge, but i don't know much about Linux and programming.



Share this post


Link to post
Share on other sites
1 minute ago, Tommy21 said:

If it is possible, could you provide links to the stuff needed to watch hw accelerated videos?

I do believe it's not an easy task, but if it isn't too complicated, why not, i would try.

I know you are doing this in your free time for free, and that is why we all wish to thank you.

I would help you if i've had the knowledge, but i don't know much about Linux and programming.


 

+1 :)

Share this post


Link to post
Share on other sites
15 hours ago, Reddwarf said:

Any particular reason for that? Armbian is much more versatile and useful WITH HW acceleration....

HW for kernel 4.18 while in the process of active development (it is actively working in the community of developers LE), when it will take the finished form, you can try to move to Armbian.

 

15 hours ago, Reddwarf said:

And is it impossible to install to old NAND?

You can try to set manually. First, check the reaction to the command

mount /dev/system /mnt

 

13 hours ago, Tommy21 said:

If it is possible, could you provide links to the stuff needed to watch hw accelerated videos?

I do believe it's not an easy task, but if it isn't too complicated, why not, i would try.

I know you are doing this in your free time for free, and that is why we all wish to thank you.

I would help you if i've had the knowledge, but i don't know much about Linux and programming.

http://www.linux-meson.com/doku.php

http://lists.infradead.org/pipermail/linux-amlogic/

Share this post


Link to post
Share on other sites
On 9/12/2018 at 8:33 AM, balbes150 said:

HW for kernel 4.18 while in the process of active development (it is actively working in the community of developers LE), when it will take the finished form, you can try to move to Armbian.

 

You can try to set manually. First, check the reaction to the command

mount /dev/system /mnt

 

http://www.linux-meson.com/doku.php

http://lists.infradead.org/pipermail/linux-amlogic/

I've fixed that issue by myself with editing the script to the "right" mcc.

After that and fixing the boot partition everything works finde now.

 

Now issues about that anymore.

 

Kind regards,

Share this post


Link to post
Share on other sites
On 9/9/2018 at 11:01 AM, lizzacore said:

So guys, i have a new issue which i cannot fix by myself.

wifi dont work. I Tried every dtb file But my wifi modul never worked.

 

so i googled.

i found that i have a rare Chip:

aigale aw-cm273sm

 

is there any way to get the driver for this Modul?

 

kind regards

 

One can help me about that?

 

Kind regards,

Share this post


Link to post
Share on other sites
12 minutes ago, lizzacore said:

Other question: How do i Update from 5.59 20180829 to 5.59 20180908 without dataloss?

Easiest is to back up your /home directory first, also any other directory you have placed stuff in.

Share this post


Link to post
Share on other sites

@balbes150 I'm trying to follow the official guide to build the wireless driver for my mini m8s ii box:

https://docs.armbian.com/User-Guide_Advanced-Features/#how-to-build-a-wireless-driver

The wireless chip is realtek RTL8189FTV. Driver build procedure is in the following link:

http://linux-sunxi.org/Wifi#RTL8189FTV

However, when I run armbian-config and try to install kernel headers, it does nothing. The progress bar goes from 0% to 100% instantly, twice. I've tried to make a bash script as in the official guide, but it just hang up.

How can I get the kernel headers for the latest 5.59 build? (4.18.0-aml-s9xxx)?

I also do apt update and search for the corresponding linux-headers-, but there is no linux-headers-4.18.0-aml-s9xxx. The closest one is linux-headers-4.18.0-rc5-meson or something like that. I installed it and was able to compile the driver, but could not insmod it. The kernel name does not match.

 

The driver rtl8189fs (which is for rtl8189ftv) is included in all armbian releases for kernel 3.14.29, but are missing/removed from kernel 4.x. Is there any problem that prevent such driver to be compiled and included in kernel 4.18? If not, can you build it and include it to subsequent release?

 

Thanks!

 

Share this post


Link to post
Share on other sites

I'm thinking about buying tv box just for linux experiments. My choices are:

- TANIX TX3 MINI-L Amlogic S905W 64-bit 4K TV Box 1GB+8GB Android 7.1

- T96 Mars Android 7.1 Amlogic S905W Quad Core TV Box 1GB RAM 8GB ROM

- MXQ Pro 4K TV Box Amlogic S905W Android 7.1 1G+8G WiFi

- A95X R1 Amlogic S905W TV Box Android 7.1 1GB+8GB 4K x 2K WiFi Ethernet

- TANIX TX3 MINI-H Amlogic S905W 64-bit 4K TV Box 2GB+16GB Android 7.1

- TX3 Mini Amlogic S905W 4K UHD TV Box 2G+16G Android 7.1 DLNA

 

Any recommendations?

Share this post


Link to post
Share on other sites
13 hours ago, Thang said:

@balbes150 I'm trying to follow the official guide to build the wireless driver for my mini m8s ii box:

https://docs.armbian.com/User-Guide_Advanced-Features/#how-to-build-a-wireless-driver

 

I can't help you with native compilation of kernel modules but I can tell you how I cross compile the latest aml-s9xxx kernel source under linux on intel to make executable modules and bootable zimage.
The official way to compile a kernel is to build everything as per https://github.com/150balbes/Build-Armbian or /build but its time and space consuming.

Download commit version around 19th August 2018 from https://github.com/150balbes/Amlogic_s905-kernel
I get the impression 150balbes kernel is a clone of LE development which is mainline with a number of patches.

Toolchain I use is gcc-linaro-7.2.1-2017.11-i686_aarch64-linux-gnu so you will need to setup your environment to run it.

Unpack the kernel download and copy /boot/config-4.18.0-aml-s9xxx to .config in your source.

command to build is:

make EXTRAVERSION=-rc5-amlogics905x ARCH=arm64 CROSS_COMPILE=aarch64-linux-gnu- -j2

Not sure about but your chip k RTL8189FTV but I would have thought it was already in the current kernel

Share this post


Link to post
Share on other sites

Hi guys,

 

just ran into this and find it quite interesting!

 

I am wondering how good is the HW decoding working? Is it possible to decode h.264/h.265 up to 4k?

 

I would like to use this with Emby for Linux, maybe someone have experience with this combination and can give some feedback.

 

Thanks!

Share this post


Link to post
Share on other sites
2 hours ago, balbes150 said:

personally for me, not familiar with any of the models

Can you recommend me some cheap and easy-to-do-linux models not on my list?

Share this post


Link to post
Share on other sites
20 hours ago, neik said:

Hi guys,

 

just ran into this and find it quite interesting!

 

I am wondering how good is the HW decoding working? Is it possible to decode h.264/h.265 up to 4k?

 

I would like to use this with Emby for Linux, maybe someone have experience with this combination and can give some feedback.

 

Thanks!

The hardware should be good enough for 4k since they advertice it with Android, I haven't tested it myself, but full HD works fine under linux with the kernels that support HW acceleration.

Share this post


Link to post
Share on other sites
54 minutes ago, Reddwarf said:

The hardware should be good enough for 4k since they advertice it with Android, I haven't tested it myself, but full HD works fine under linux with the kernels that support HW acceleration.

 

Thanks for the feedback!

 

Although being a bit off-topic I just want to ask one more question: Is this also valid for the S912 SoC? My father has a Beelink GT1 with S912 on which I could play around.

Share this post


Link to post
Share on other sites
9 hours ago, neik said:

 

Thanks for the feedback!

 

Although being a bit off-topic I just want to ask one more question: Is this also valid for the S912 SoC? My father has a Beelink GT1 with S912 on which I could play around.

Yes, the 912 has its own Armbian thread :)

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
54 54