Jump to content
  • 0

Slow speed withe external SSD


gabbas1
 Share

Question

Please delete!

I just found the problem.

 

__________________________________________________________________________________________________________________________________________

Hi guys,

 

i'm running an Odroid C4 with Armbian Jammy.

 

uname -a
Linux Homeserver 6.0.13-meson64 #22.11.2 SMP PREEMPT Sun Dec 18 16:52:19 CET 2022 aarch64 aarch64 aarch64 GNU/Linux

 

Everything works fine so far. Today I just bought an external ssd drive "SanDisk Portable SSD 1TB". I can mount and use it, but the speed seams quit slow to me. The packaging of the ssd say "up to 520MB/s" and the USB 3.0 ports should have higher speed than this:

 

dd if=/dev/zero of=/media/nextcloud/test bs=1M count=1024 conv=fdatasync,notrunc
1024+0 records in
1024+0 records out
1073741824 bytes (1.1 GB, 1.0 GiB) copied, 30.7941 s, 34.9 MB/s


echo 3 | sudo tee /proc/sys/vm/drop_caches (clear cached data)


dd if=/media/nextcloud/test of=/dev/null bs=1M count=1024 
1024+0 records in
1024+0 records out
1073741824 bytes (1.1 GB, 1.0 GiB) copied, 6.17649 s, 174 MB/s

 

It is mounted via fstab like this:

 

UUID=64f28769-a9c1-4011-ad9d-103eceb4bdfc   /media/test   ext4   defaults   0   2

 

After I attached the drive to the usb port dmesg says:

 

[504496.115044] usb 2-1.1: new SuperSpeed USB device number 3 using xhci-hcd
[504496.136011] usb 2-1.1: New USB device found, idVendor=0781, idProduct=55bb, bcdDevice=60.04
[504496.136026] usb 2-1.1: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[504496.136031] usb 2-1.1: Product: Portable SSD
[504496.136036] usb 2-1.1: Manufacturer: SanDisk
[504496.136040] usb 2-1.1: SerialNumber: 323234384B4C343031363830
[504496.165630] scsi host0: uas
[504496.166400] usbcore: registered new interface driver uas
[504497.026910] scsi 0:0:0:0: Direct-Access     SanDisk  Portable SSD     6004 PQ: 0 ANSI: 6
[504497.040786] sd 0:0:0:0: Attached scsi generic sg0 type 0
[504527.525721] sd 0:0:0:0: [sda] tag#22 uas_eh_abort_handler 0 uas-tag 1 inflight: CMD IN 
[504527.525739] sd 0:0:0:0: [sda] tag#22 CDB: opcode=0x9e, sa=0x10 9e 10 00 00 00 00 00 00 00 00 00 00 00 20 00 00
[504527.541708] scsi host0: uas_eh_device_reset_handler start
[504527.621980] usb 2-1.1: reset SuperSpeed USB device number 3 using xhci-hcd
[504527.643980] scsi host0: uas_eh_device_reset_handler success
[504527.649863] sd 0:0:0:0: [sda] 1953525168 512-byte logical blocks: (1.00 TB/932 GiB)
[504527.650022] sd 0:0:0:0: [sda] Write Protect is off
[504527.650031] sd 0:0:0:0: [sda] Mode Sense: 37 00 10 00
[504527.650297] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, supports DPO and FUA
[504527.650448] sd 0:0:0:0: [sda] Preferred minimum I/O size 512 bytes
[504527.650456] sd 0:0:0:0: [sda] Optimal transfer size 1048576 bytes
[504527.670807] sd 0:0:0:0: [sda] Attached SCSI disk

 

lsusb says driver=uas. Is this about rigth?

 

lsusb
Bus 002 Device 003: ID 0781:55bb SanDisk Corp. Portable SSD
Bus 002 Device 002: ID 2109:0817 VIA Labs, Inc. USB3.0 Hub             
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 1cf1:0030 Dresden Elektronik ZigBee gateway [ConBee II]
Bus 001 Device 002: ID 2109:2817 VIA Labs, Inc. USB2.0 Hub             
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lsusb -t
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 5000M
        |__ Port 1: Dev 3, If 0, Class=Mass Storage, Driver=uas, 5000M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
        |__ Port 3: Dev 4, If 0, Class=Communications, Driver=cdc_acm, 12M
        |__ Port 3: Dev 4, If 1, Class=CDC Data, Driver=cdc_acm, 12M

 

Has anyone an idea what I did wrong or what am I missing?

I feel like the ssd has USB 2.0 speeds. Could it be a problem with the driver?

 

For more information see:

https://paste.armbian.com/iyinumakiy
 

 

With kind regards,

Sebastian

Edited by gabbas1
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

Search Before Posting!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...