Jump to content

H96 Pro Plus install issues


Recommended Posts

Donate your old hardware to community. Start a giveaway Raffle!

Please tell us what you have done.  You have provided no information for us to help you debug your issue.  What build are you using, what steps have you done to get to the point you mentioned?

Link to comment
Share on other sites

So I could't reply with the other account so I created a new one.


I used that build here: A source that uses Armbians name without permission, does not participate in its development process and confuses users into thinking they get support from official Armbian while in the same way wasting their ressources which such. (Armbian_23.02.0_amlogic_s912_jammy_6.1.6_server_2023.01.18 and Armbian_23.02.0_amlogic_s912_jammy_5.15.88_server_2023.01.18) and flashed it to the sdcard with etcher

1. Copied the dtb file to root and renamed it to dtb.img (as mentioned in https://github.com/ophub/amlogic-s9xxx-armbian/blob/main/build-armbian/documents/amlogic_model_database.md)

2. Renamed and updated the extlinux.configfile to:

label Armbian
    kernel /zImage
    initrd /uInitrd
    fdt /dtb/amlogic/meson-gxm-octopus-planet.dtb
    append root=UUID=9c561af2-0348-4082-af79-a30f08846abd rootflags=data=writeback rw rootfstype=ext4 console=ttyAML0,115200n8 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes fsck.repair=yes net.ifnames=0 loglevel=1 voutmode=hdmi disablehpd=false overscan=100 sdrmode=auto
3. Updated the uEnv.txt to:

APPEND=root=UUID=9c561af2-0348-4082-af79-a30f08846abd rootflags=data=writeback rw rootfstype=ext4 console=ttyAML0,115200n8 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes fsck.repair=yes net.ifnames=0 cgroup_enable=cpuset cgroup_memory=1 cgroup_enable=memory swapaccount=1

3. Renamed the u-boot-zyxq.bin to u-boot.ext

4. Added SD-Card to the box

5. Tried to run an update in Android with the updater App, but there I had always an error like File not found and with select there was nothing to select

6. Removed power cable, pressed the reset button and pluged it in back and was waiting till I was in android recovery then i released the reset button

Edited by Werner
Link removed + explanation
Link to comment
Share on other sites

  • Werner locked this topic

More specifically, you downloaded from a site that is not Armbian.  They are a fork of armbian, but continue to use the Armbian name without permission.  They do not participate in these forums.  There is no way we can help you since you aren't using Armbian, you will need to go to the location you downloaded your build from and get help there.

Link to comment
Share on other sites

So I tried the official Armbian version as described here in the thread, I have an Alfawise H96 pro + amlogic s912 Box with blue PCB, android 7 and ddr3 3gb ram.

1. I downloaded the following image: https://github.com/armbian/community/releases/download/202304/Armbian_23.02.0-trunk_Aml-s9xx-box_lunar_edge_6.2.0-rc3.img.xz#aml-s9xx-box

2. Write the image in a SD Card with BalenaEtcher

3. I changed the boot configuration in the extlinux.conf as follow:

LABEL Armbian
LINUX /uImage
INITRD /uInitrd

FDT /dtb/amlogic/meson-gxm-q200.dtb

  append root=UUID=da0b20c3-cbcf-4b30-a157-cecc5d4d9a53 rootflags=data=writeback console=ttyAML0,115200n8 console=tty0 rw no_console_suspend consoleblank=0 fsck.fix=yes fsck.repair=yes net.ifnames=0 splash plymouth.ignore-serial-consoles

4. I copied the u-boot-s905x-s912 and changed the name to u-boot.ext

5. Put the sd card in the tv box, press and hold the reset button and plug in the power connector

6. Android Recovery starts


How can I boot the SD card?

Link to comment
Share on other sites

Generally this means that you are holding the reset button too long.  When powered with the reset button pressed it should after a few seconds 'reboot' at that time you can release it.  If you continue to hold for an extended period of time it will go to the android recovery.

Link to comment
Share on other sites

  • SteeMan unlocked this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...