18 18
masteripper

Armbian for Amlogic S802/S812

Recommended Posts

Please check out these options from u-boot using to run from the SD card.

 

 

https://yadi.sk/d/CUHySrWd3GgpqZ

 

I saw that You have already compiled your version, but I have a request, check these files to run. I need to make sure they work and you can include them in the Assembly of the image Armbian for s812.

Share this post


Link to post
Share on other sites
19 hours ago, balbes150 said:

Please check out these options from u-boot using to run from the SD card.

 

 

https://yadi.sk/d/CUHySrWd3GgpqZ

 

I saw that You have already compiled your version, but I have a request, check these files to run. I need to make sure they work and you can include them in the Assembly of the image Armbian for s812.

thanks very much.

I hope is not urgent as I'm travelling for the next couple weeks and can't try them yet.

 

have you any experience with the bootloader script for AMLogic?

I used the following scripts to boot:

- armbian
setenv condev "console=ttyS0,115200n8 console=tty0 no_console_suspend consoleblank=0"
setenv bootargs "root=LABEL=ROOTFS rootflags=data=writeback rw ${condev} fsck.repair=yes net.ifnames=0 mac=${mac}"
setenv kernel_loadaddr "0x14000000"
setenv dtb_loadaddr "0x11800000"
setenv initrd_loadaddr "0x15000000"
setenv boot_start bootm ${kernel_loadaddr} ${initrd_loadaddr} ${dtb_loadaddr}

mmcinfo
fatload mmc 0 ${initrd_loadaddr} uInitrd

fatload mmc 0 ${kernel_loadaddr} uImage
fatload mmc 0 ${dtb_loadaddr} dtb/meson8_k200b_2G_emmc_sdhc.dtb

run boot_start

- lakka.tv and LibreELEC.tv
setenv condev "console=ttyS0,115200n8 console=tty0 no_console_suspend consoleblank=0"
setenv bootargs "${condev} bootfromsd"
mmcinfo
fatload mmc 0 ${loadaddr} kernel

bootm
 

I'm thinking these could be used to prep the script for booting from SD.

thanks again!

Share this post


Link to post
Share on other sites

Hi Balbes150, Latest version of Armbian, lakka and libreelec won't​ boot. Armbian gives colour distortion. LE says can't mount /dev/system. Multi boot is activated. For Minix x8-h I used M8 2G versions. Has this to do with KitKat 4.4 and it's dtb? can I extract dtb? Or am I looking in the wrong direction?

Verstuurd vanaf mijn ONEPLUS A3003 met Tapatalk

Share this post


Link to post
Share on other sites
Hi Balbes150, Latest version of Armbian, lakka and libreelec won't​ boot. Armbian gives colour distortion. LE says can't mount /dev/system. Multi boot is activated. For Minix x8-h I used M8 2G versions. Has this to do with KitKat 4.4 and it's dtb? can I extract dtb? Or am I looking in the wrong direction?

Verstuurd vanaf mijn ONEPLUS A3003 met Tapatalk






thanks very much.
I hope is not urgent as I'm travelling for the next couple weeks and can't try them yet.
 
have you any experience with the bootloader script for AMLogic?
I used the following scripts to boot:
- armbian
setenv condev "console=ttyS0,115200n8 console=tty0 no_console_suspend consoleblank=0"
setenv bootargs "root=LABEL=ROOTFS rootflags=data=writeback rw ${condev} fsck.repair=yes net.ifnames=0 mac=${mac}"
setenv kernel_loadaddr "0x14000000"
setenv dtb_loadaddr "0x11800000"
setenv initrd_loadaddr "0x15000000"
setenv boot_start bootm ${kernel_loadaddr} ${initrd_loadaddr} ${dtb_loadaddr}

mmcinfo
fatload mmc 0 ${initrd_loadaddr} uInitrd

fatload mmc 0 ${kernel_loadaddr} uImage
fatload mmc 0 ${dtb_loadaddr} dtb/meson8_k200b_2G_emmc_sdhc.dtb

run boot_start

- lakka.tv and LibreELEC.tv
setenv condev "console=ttyS0,115200n8 console=tty0 no_console_suspend consoleblank=0"
setenv bootargs "${condev} bootfromsd"
mmcinfo
fatload mmc 0 ${loadaddr} kernel

bootm
 
I'm thinking these could be used to prep the script for booting from SD.
thanks again!

BTW previous version of your work do boot and work

Verstuurd vanaf mijn ONEPLUS A3003 met Tapatalk

Share this post


Link to post
Share on other sites
20 hours ago, lmirel said:

I hope is not urgent as I'm travelling for the next couple weeks and can't try them yet.

 

have you any experience with the bootloader script for AMLogic?

 

1. It's not urgent, you can check when You have time.

2. What exactly You are interested in the script ?

 

9 hours ago, s0nik said:

Latest version of Armbian, lakka and libreelec won't boot. Armbian gives colour distortion. LE says can't mount /dev/system. Multi boot is activated. For Minix x8-h I used M8 2G versions. Has this to do with KitKat 4.4 and it's dtb? can I extract dtb? Or am I looking in the wrong direction?

Most likely in the firmware versions on the basis of 4.4 KitKat uses a different dtb format (for older kernels) and other loader u-boot, which may not work with the new dtb format (for new kernels).

 

Share this post


Link to post
Share on other sites
6 hours ago, balbes150 said:

2. What exactly You are interested in the script ?

the regular use case for when the eMMC fails on these boards (this is the one requiring intervention) is that we end up with an empty flash, unable to boot.

the preloader is looking for boot code on SD, USB device and serial.

the SD script would have to be prepared in such a way that it sets-up the bootloader to boot from SD each of the OSs: armbian, lakka.tv and LibreELEC.

Armbian uses 'aml_autoscript' and 's805_autoscript' but I didn't observe these to be executed at all.

 

this is the case where we can't rely on the existing Android system to help us boot from SD (since the eMMC is broken).

Share this post


Link to post
Share on other sites

1. If eMMC is missing\faulty\completely erased - in these cases always need u-boot on SD card (run u-boot from a USB drive is possible, but I still know of only one manufacturer, which is implemented Khadas VIM on all the other TV boxes there is only a boot loader for the SD card).

2. All I know of u-boot in update mode have the option of running the script with the default name aml_autoscript.

3. Therefore, it is sufficient to write to the SD card standard u-boot and slip him the right script aml_autoscript (using as a basis a ready skriti s905_autoscript for the desired systems.

 

After recording of the image Armbian scripts aml_autoscript and s805_autoscript used for their own purposes. aml_autoscript is a script activate the multi-boot. S805_autoscript the script is a startup script system from external media.

 

Share this post


Link to post
Share on other sites
3 hours ago, balbes150 said:

1. If eMMC is missing\faulty\completely erased - in these cases always need u-boot on SD card (run u-boot from a USB drive is possible, but I still know of only one manufacturer, which is implemented Khadas VIM on all the other TV boxes there is only a boot loader for the SD card).

2. All I know of u-boot in update mode have the option of running the script with the default name aml_autoscript.

3. Therefore, it is sufficient to write to the SD card standard u-boot and slip him the right script aml_autoscript (using as a basis a ready skriti s905_autoscript for the desired systems.

 

After recording of the image Armbian scripts aml_autoscript and s805_autoscript used for their own purposes. aml_autoscript is a script activate the multi-boot. S805_autoscript the script is a startup script system from external media.

 

thanks! I'll take a closer look at 'aml_autoscript' upon my return.

Share this post


Link to post
Share on other sites
On 26-3-2017 at 8:33 AM, balbes150 said:

If possible, check these items.

1. Work wired network

2. Work WiFi

3. The script backups dd_backup_x (when you create a compressed copy). Check recovery, no real need to do.

4. The sound quality (is or is not rattling and interference)

5. Show the output of the command "fw_printenv" and "fdisk -l"

 

Hi, your latest server image works on minix x8h (KitKat 4.4) with M8 2G dtb:

1. Yes works

2. To be Tested

3. not done

4. To be Tested. I'll try installing lubuntu

5. fw_printenv does not work: 

root@vegas812:/etc# fw_printenv
Cannot parse config file '/etc/fw_env.config': No such file or directory
 

Maybe attached information helps?

 

 

dmesg.txt

fdisk.txt

lsusb.txt

udevadm.txt

Share this post


Link to post
Share on other sites

An updated version of the images 20170414. In these images added the ability to automatically use the built-in dtb out of internal memory. If no existing media file "dtb.img", the system tries to load the dtb from the internal memory. This feature is only being tested. Please to those who have the opportunity to check this option. Note that due to the fact that in the last image is the latest version of the kernel, dtb built-in data can not work properly. For example, I have on Tronsmart MXIII Plus when using built-in dtb data from the LE, the system starts normally, but the monitor does not display a picture (in this version I run via ssh and UART). It is important for me to clarify how to work this feature on other models with different firmware. The important thing is that we could start the total system (that you could connect via SSH or UART). If this function is startup dtb data from the internal memory, will be able to work on all models, then there is a chance to have a universal system.

Share this post


Link to post
Share on other sites
On 05/04/2017 at 5:51 PM, balbes150 said:

Please check out these options from u-boot using to run from the SD card.

 

 

https://yadi.sk/d/CUHySrWd3GgpqZ

 

I saw that You have already compiled your version, but I have a request, check these files to run. I need to make sure they work and you can include them in the Assembly of the image Armbian for s812.

I couldn't get any of the builds to boot the board.

I used the usual approach with the BootcardMaker from @mlogic.

it boots fine with the Android bootloader.img and the one I built from the @mlogic buildroot.

Share this post


Link to post
Share on other sites

hello

 

@balbes150

thanks for your work

 

my box

Akimso M8s S812+ 2GB RAM 8GB ROM RTL8723BS WIFI

my problem

the multiboot script run fine

i  boot from USB and SD card fine

i have UART USB adapter

i have android 4.4 root

 

i have try many dtb and S8x jessy xfc and server rom and s9x jessy server rom all boot

all boot the rom  but than i got stuck

with some dtb i got till hdmitx cec: wait for cec not ready

or

i got till GPIO 32 error irq in used and than a loop of starting and closing the CPU1 and 2 and the GPIO 32 and the IRQ

 

please help

 

i am windows user and only the beginning of linux

Share this post


Link to post
Share on other sites

Hi @balbes150

 

thanks for your hard work on this S812 build.

 

I installed the latest build on my MKS 812 with 2GB.

 

One problem that I encountered is that nfs-kernel-server is only running version 2, therefore I can't get it working properly.

 

Is there another method to get NFS v3 or v4 working? 

 

   program vers proto   port  service
    100000    4   tcp    111  portmapper
    100000    3   tcp    111  portmapper
    100000    2   tcp    111  portmapper
    100000    4   udp    111  portmapper
    100000    3   udp    111  portmapper
    100000    2   udp    111  portmapper
    100005    1   udp  32885  mountd
    100005    1   tcp  36498  mountd
    100005    2   udp  55480  mountd
    100005    2   tcp  51519  mountd
    100005    3   udp  55841  mountd
    100005    3   tcp  46495  mountd
    100003    2   tcp   2049  nfs
    100003    2   udp   2049  nfs
    100021    1   udp  54823  nlockmgr
    100021    3   udp  54823  nlockmgr
    100021    4   udp  54823  nlockmgr
    100021    1   tcp  39327  nlockmgr
    100021    3   tcp  39327  nlockmgr
    100021    4   tcp  39327  nlockmgr

 

Share this post


Link to post
Share on other sites
1 hour ago, RaptorSDS said:

i make some UART log files for my rom problems

 

1. Try using the image Ubuntu.

2. Disable the download of WiFi module in Debian and try with dtb n200.

 

4 hours ago, donmarcello said:

Is there another method to get NFS v3 or v4 working? 

We must look at the source code, I don't know what is there.

Share this post


Link to post
Share on other sites
Quote

1. Try using the image Ubuntu.

2. Disable the download of WiFi module in Debian and try with dtb n200.

 

thank you ubuntu works

how i can disable download ? , i could set up eth0 and ssh , i have a wlan0 adapter but it dont find any signal   ( maybe its possible to integrate the RTL8723BS driver from the S9xx (mini M8s) rom to the S812 rom )

Share this post


Link to post
Share on other sites

In the file /etc/modules describes what to load at startup. It can be edited to suit your needs. To remove unnecessary modules or add new ones. If the module is loaded automatically - you can make it to the block list (how to do it is described on the Internet for the desired distribution).

Share this post


Link to post
Share on other sites
Quote

In the file /etc/modules describes what to load at startup.

thank you , after a long day and complet new flash of sdcard i got bcm unload and realtek load ( problem was a misspelling blacklist.conf) , now i stuck at next problem dhcp (dhclient) dont work. 

dhcp run 5 min than stop without any ip .

Share this post


Link to post
Share on other sites

Collected test image to s8xxx on the basis of the kernel 4.11. Tried on MXIII Plus (s812). Kernel starts, but then stops, I do not understand why it is not correct dtb file (it was originally intended for M8S). So please M8S, try this way to see if it will run or not.

 

https://yadi.sk/d/-3WALlEG3FyTvs

Share this post


Link to post
Share on other sites
New link.
 
 
Thank you for the test. Looked at the logs, I see the difference in behavior of the kernel on Your TV console. Specify what model You have (features) ? The control LED can be done through passing parameters in /sys . You can disable / change the description in the dtb file. The new engine uses its own data structure the dtb, so the files from the old kernel will not work with the new kernel, they need to modify and assemble with the new kernel together.
 
 
You can engage in a direct dialogue with the developers.

Share this post


Link to post
Share on other sites

like i wrote befor

 

my box

Akimso M8s S812 ( label as m812+) 2GB RAM  8GB ROM  RTL8723BS WIFI/Bluetooth HDMI SPdif AV(4pin) IR-Remote

i know its a clone ( only 19€ at amazon)

 

 

Share this post


Link to post
Share on other sites

i found leds  at /sys/class and backlight but there are no parameters or triggers i am still on 3.xx kernel , but i am new to linux

Share this post


Link to post
Share on other sites
(edited)

balbes150



А на М8S+ можно твои образы запустить?

У меня одна есть приставка, хочу серверок запустить но сколько не искал так и не нашел.

Edited by zador.blood.stained
Hidden under the spoiler - please use English language on this forum

Share this post


Link to post
Share on other sites
7 hours ago, RaptorSDS said:

i found leds  at /sys/class and backlight but there are no parameters or triggers i am still on 3.xx kernel , but i am new to linux

To control the LED needs to have a description in the DTB file. Then you can set the triggers to the desired state (control activity LED).

 

 

@wzor

 

Yes, this is possible. Can be run on any model. The only thing that may need or choose from existing dtb files are needed, or collect specifically for your model from the original file (can be taken from the finished firmware). By the way, M8S have a chance to run kernel 4.11.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
18 18