Jump to content

Armbian for Amlogic S805 and S802/S812


masteripper
 Share

Recommended Posts

vor einer Stunde schrieb Rohaaq:

I see. But how exactly can I resolve these errors then?

what do you see ? what do mean resolve error ?

you do not need toothpick , you do not need recovery , only insert SD-Card and start the box

 

befor patch

bootloader-->internal memory-->android

 

after patch

without sd-card

bootloader-->sd-card-->usb-->internal memory-->android

or with sd-card

bootloader-->sdcard-->debian

Link to comment
Share on other sites

Help Armbian team helping you

@Rohaaq  A further comment that might help clarify.  Applying 'multiboot' is a one time operation.  It changes the boot environment which only needs to be done once.  So if you have properly applied multiboot (through either toothpick or update methods) then you are done and subsequently all you need to do is insert your sd card and it should first try to boot from there before falling back to booting android from emmc.  If it doesn't boot what you have on your sd card, you either haven't properly installed multiboot or your sd card is incorrectly setup.

Link to comment
Share on other sites

29 minutes ago, RaptorSDS said:

what do you see ? what do mean resolve error ?

you do not need toothpick , you do not need recovery , only insert SD-Card and start the box

 

befor patch

bootloader-->internal memory-->android

 

after patch

without sd-card

bootloader-->sd-card-->usb-->internal memory-->android

or with sd-card

bootloader-->sdcard-->debian

 

5 minutes ago, SteeMan said:

@Rohaaq  A further comment that might help clarify.  Applying 'multiboot' is a one time operation.  It changes the boot environment which only needs to be done once.  So if you have properly applied multiboot (through either toothpick or update methods) then you are done and subsequently all you need to do is insert your sd card and it should first try to boot from there before falling back to booting android from emmc.  If it doesn't boot what you have on your sd card, you either haven't properly installed multiboot or your sd card is incorrectly setup.

 

Ohhh. Sorry, I didn't quite understand this the first time. Installing the .zip file definitely did something, so I reckon that's probably fine. I suppose then there's something wrong with how I've formatted the SD card, but as far as I understand the only thing I need to do is edit the one line of the uEnv.txt file. What else could I be missing?

 

Thanks for the help so far, I really appreciate it.

Link to comment
Share on other sites

vor 7 Stunden schrieb Rohaaq:

What else could I be missing?

this is still a beta for this tv-box.

 

yes when boot from sd-card you should edit uEnv.txt with right dtb file,

but it could happen that none of the dtb work.

if this happen, than please try one of the older Armbian S812 Version 5.xx with Kernel 3.10.xxx there is a higher chance that one dtb is correct for your box.

 

be aware the dtb files not changeable between 5.xx Kernel and 3.10.xx Kernel

 

Link to comment
Share on other sites

Posted (edited)

Does anyone know this board?

 

20220513-220158.jpg


I bought it from  TAOBAO in China.
It has S805 CPU.
SD Card Write Armbian_21.02.0-trunk_Aml-s812_bullseye_current_5.10.0_.img and meson8b-mxq.dtb, the network works, but the screen does not appear.
(At Armbian_5.67_Aml-s805_Debian_stretch_default_3.10.108_desktop_20181207.img & meson8b-mxq.dtb,  Display screen on.)

 

20220513-225328.jpg

 

Someone helps the screen appear on Debian Bullseye.
Or I'd appreciate it if you could help me install the Retropie & Lakka.

Edited by 심승보
Link to comment
Share on other sites

vor einer Stunde schrieb 심승보:

SD Card Write Armbian_21.02.0-trunk_Aml-s812_bullseye_current_5.10.0_.img and meson8b-mxq.dtb, the network works, but the screen does not appear.
(At Armbian_5.67_Aml-s805_Debian_stretch_default_3.10.108_desktop_20181207.img & meson8b-mxq.dtb,  Display screen on.)

 

How about other dtb files from armbian 21.02.0 any other with display , its more easy to look at dtb files from same Kernel.

 

dtb files from 3.10.0 to 5.10 are more difference -->that why there are not compatible .

 

 

Link to comment
Share on other sites

On 5/14/2022 at 12:48 AM, RaptorSDS said:

 

How about other dtb files from armbian 21.02.0 any other with display , its more easy to look at dtb files from same Kernel.

 

dtb files from 3.10.0 to 5.10 are more difference -->that why there are not compatible .

 

 

 

Thank you for your interest!

 

As you said, I tried other DTB files.

 

meson8b-odroidc1.dtb   The display is finally ON! But the network is dead.

meson8b-mxq.dtb   The display output is still dead. But the network works, so I can access SSH.

 

So I changed DTB to DTS and tried to fix it. But there's an error message like the picture below.
Can you give me some advice?

 

There is an error even if I don't fix the file and just do a two-way conversion.

DTB -> DTS -> DTB 

 

Cap-2022-05-15-11-41-21-600.png

Link to comment
Share on other sites

vor 8 Stunden schrieb ArtSHIM:

There is an error even if I don't fix the file and just do a two-way conversion.

your secound dtc string is wrong from dts to dtb

-I = input type you have dtb should  dts

-O = output type you have dts should dtb

-o = output file = ok

 

also odroid use realtek LAN but many HDMI CRC and HDMI i2c

ODROID C1 source file

mxq use internal(amlogic) LAN and standart HDMI output

MXQ source file

 

 

i thing your box need also the HDMI Communication CRC and i2c pins to work

 

 

Link to comment
Share on other sites

Probably I ask really stupid/blindman question, but where do you guys download these old S805 images from?
Like recently mentioned "Armbian_5.67_Aml-s805_Debian_stretch_default_3.10.108_desktop_20181207.img"

I have really old MXQ_S805_V03 with WiFi: RTL8189ETV, and I want to use it as TV box for my grandma with Transmission and videoplayer onboard, but with WiFi enabled.
Years ago I managed to make it multiboot and installed on it Armbian desktop with dts which provided Eth only (I needed it these days, didn't care for Wifi)

Is such setup possible with old (3.1 kernel) images or should I think of converting box back to (buggy/luggy) Android one (if it's possible too)?

Link to comment
Share on other sites

vor einer Stunde schrieb greenais:

download these old S805 images from?

look at this thread somewhere are the yandisk link

 

normally nand install was not possible because no nand driver in the old builds, impressive if you did it

 

why not test the new image with 5.xx kernel also RTL8189 should maybe now work

 

 

--> which Android One (11.x 9.x 8.x...) ? Never saw someone do this because android 4.4 was last build for S805 , this why android one had no driver for this box

Link to comment
Share on other sites

25 minutes ago, RaptorSDS said:

look at this thread somewhere are the yandisk link

 

normally nand install was not possible because no nand driver in the old builds, impressive if you did it

 

why not test the new image with 5.xx kernel also RTL8189 should maybe now work

That's the thing - I couldn't find anything relevant as "S805" is in the tread's name... My hope to find some reply with actual links to existing images just dissolved as a tiny puff)
I really don't remember how I achieved nand-install, probably - manually as @balbes150suggested somewhere...
I really don't mind to give try to modern (5.x kernel) images for S805, but can't find any - seems like only S812 are everywhere, could you give a hand, please?

Link to comment
Share on other sites

vor 36 Minuten schrieb greenais:

"S805" is in the tread's name

yes because S812 and S805 are identicial , you can use same image only dtb has to be the right one

many label as S8xx

Link to comment
Share on other sites

So I downloaded Armbian 5.67 Aml s805 Ubuntu bionic default 3.10.108 desktop 20181207.img.xz from Yandex disk, wrote it to SD. Load my box, can't login. Admin and pass won't work. root 1234

Link to comment
Share on other sites

Hey,

 

right now i´m running an Debian Buster lite (ownhanded dist. upgrade from Armbian_5.67_Aml-s805_Debian_stretch_default_3.10.108_20181207.img) on S805 on a 128gb SD Card. 

Is it possible to clone this running System from the SD to the intern 128GB flash? Or is it better to run it on a fast SD Card?

 

 

 

photo_2022-08-24 06.45.50.jpeg

photo_2022-08-24 06.45.44.jpeg

photo_2022-08-24 16.22.46.jpeg

Link to comment
Share on other sites

Hey @all

 

i´m trying to connect a USB Webcam but i´m not getting video0 available.

The webcam is a Logitech C270. Is it not possible to run USB Webcams with this kernel? 

Or is there a hidden switch that i didn't know about?

 

Quote

pi@aml:~$ lsusb

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 002 Device 002: ID 2c99:0002

Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

pi@aml:~$

Quote

pi@aml:~$ usb-devices

 

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh= 1

😧 Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1

P:  Vendor=1d6b ProdID=0002 Rev=03.10

S:  Manufacturer=Linux 3.10.108 dwc_otg_hcd

S:  Product=DWC OTG Controller

S:  SerialNumber=lm1

😄 #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA

I:  If#=0x0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

 

T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh= 1

😧 Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1

P:  Vendor=1d6b ProdID=0002 Rev=03.10

S:  Manufacturer=Linux 3.10.108 dwc_otg_hcd

S:  Product=DWC OTG Controller

S:  SerialNumber=lm0

😄 #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA

I:  If#=0x0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

 

T:  Bus=02 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=12  MxCh= 0

😧 Ver= 1.10 Cls=02(commc) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1

P:  Vendor=2c99 ProdID=0002 Rev=01.00

S:  Manufacturer=Prusa Research (prusa3d.com)

S:  Product=Original Prusa i3 MK3

😄 #Ifs= 2 Cfg#= 1 Atr=c0 MxPwr=100mA

I:  If#=0x0 Alt= 0 #EPs= 1 Cls=02(commc) Sub=02 Prot=01 Driver=cdc_acm

I:  If#=0x1 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_acm

pi@aml:~$

 

My printer is working but as i wrote not the USB Webcams.

 

Best

 

 

Link to comment
Share on other sites

i thing its a missing driver/modul , you should search on github for one and than "make" and "install" the driver because usb had recognize the right device

 

most Armbian build are very short in the addon package to be small in size and many funktion can be add later

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...