How to disable boot output to uart0?


1 1

Recommended Posts

Hi guys,


I tried to disable console output on uart0 using this guide

But I still get boot output on uart0.


Problem is, that I'm using uart0 for a java application. Java application crashes a few seconds after starting. I got the hint, that I should disable console output on this port, to make it working. See here:

I think that's the problem, because if I unplug my serial device from uart0, java app doesn't crash.


I'm using Banana Pi.

Kernel is Verison 4.8.12.

Armbian is Jessie 5.24 with desktop.


How can I disable the output?




Link to post
Share on other sites

Donate and support the project!

I think it was discussed before.

UART0 output is used by:

  • u-boot and u-boot SPL (can be disabled only by recompiling u-boot)
  • kernel for the boot output (can be disabled via kernel command line)
  • login prompt (can be disabled with "systemctl disable serial-getty@ttyS0.service")


So an easier option may be to use any other UART port


One of the most annoying is kernel because it continue to send occasionally message after boot. I use minicom on ttyS0 on a BPI to access console on other board, and those boards don't like at all the command "<0> usb0 no ipv6 router present"

Link to post
Share on other sites

This topic is now closed to further replies.

1 1