2 2
sooperior

No package updates

Recommended Posts

Hi!

Is it only me or there are no updates to packages? Let me explain, I'm running jessie server on A20 latest stable kernel and when I run apt-get update, apt-get upgrade there are never updates available. I have experienced this for some of the latest releases and now I'm starting to thing that something is wrong with my system. Especially because I have a raspberry pi and that (yes, I know is raspbian) is getting updates to packages from time to time.

I haven't modified or customized anything in the sources list.

And the thing is that I'm getting updates for firmware/kernel when they are available.

 

Any ideas? Is it something normal for armbian (/debian)?

Share this post


Link to post
Share on other sites

apt-get update / upgrade could be temporally broken at certain locations since we changed main download servers to another address yesterday. Actually not, since old is still working.

 

Updates to kernel are 1-2 month or daily if you hook yourself to beta repository. For rest of the packages, they are comming from stock Debian / Ubuntu base and they should get updates from time to time.

 

Just double check if your /etc/apt/sources.list looks similar to this and actually your system could be updated automatically. At least update / download part should be set to auto by default.
 

Share this post


Link to post
Share on other sites

Do an "apt-get update" and look if all repositories could be read successfully.

 

I had the topic on a Wheezy Legacy system that because of the repo move to HTTPS the old configured HTTP URLS did not worked any longer. I needed to change them in /etc/apt/sources.list to https

Share this post


Link to post
Share on other sites

Hi,

 

unattended-upgrade is active by default. So updates (except kernel) are installed automatically. Have a look at /var/log/apt/history.log* for the installation history.

 

Bye,

wahlm

 

From my a20lime2 jessie headless server:

 

Start-Date: 2016-12-14  06:31:10
Commandline: /usr/bin/unattended-upgrade
Upgrade: apt:armhf (1.0.9.8.3, 1.0.9.8.4), libapt-pkg4.12:armhf (1.0.9.8.3, 1.0.9.8.4), apt-utils:armhf (1.0.9.8.3, 1.0.9.8.4), libapt-inst1.5:armhf (1.0.9.8.3, 1.0.9.8.4), apt-transport-https:armhf (1.0.9.8.3, 1.0.9.8.4)
End-Date: 2016-12-14  06:31:25

Start-Date: 2016-12-24  06:38:47
Commandline: /usr/bin/unattended-upgrade
Upgrade: libxml2:armhf (2.9.1+dfsg1-5+deb8u3, 2.9.1+dfsg1-5+deb8u4)
End-Date: 2016-12-24  06:38:49

 

Share this post


Link to post
Share on other sites

That was it, you really hit the point.

When i check history.log (.1 .2) there are traces of the updated packages. Thank you very much for the tip.

 

And by the way, I'm gladly suprised that armbian has this feature turned on, I could never imagine that (and I love to keep my system updated)

 

Hi,

 

unattended-upgrade is active by default. So updates (except kernel) are installed automatically. Have a look at /var/log/apt/history.log* for the installation history.

 

Bye,

wahlm

 

From my a20lime2 jessie headless server:

 

Start-Date: 2016-12-14  06:31:10
Commandline: /usr/bin/unattended-upgrade
Upgrade: apt:armhf (1.0.9.8.3, 1.0.9.8.4), libapt-pkg4.12:armhf (1.0.9.8.3, 1.0.9.8.4), apt-utils:armhf (1.0.9.8.3, 1.0.9.8.4), libapt-inst1.5:armhf (1.0.9.8.3, 1.0.9.8.4), apt-transport-https:armhf (1.0.9.8.3, 1.0.9.8.4)
End-Date: 2016-12-14  06:31:25

Start-Date: 2016-12-24  06:38:47
Commandline: /usr/bin/unattended-upgrade
Upgrade: libxml2:armhf (2.9.1+dfsg1-5+deb8u3, 2.9.1+dfsg1-5+deb8u4)
End-Date: 2016-12-24  06:38:49

 

Share this post


Link to post
Share on other sites

Then I will disable /etc/update-motd.d/40-updates and save some miliseconds in the login process  :P

 

 

 

Speaking of update-motd.d, sorry for a bit off topic.

 

Am I the only one feeling 30-sysinfo uses too much time?  We're talking seconds on my Zero. 

Share this post


Link to post
Share on other sites

Is it really 30-sysinfo? My login takes also time but there are several processes involved in the login

 

Yes, disabling it in /etc/pam.d/sshd makes things go way faster, still not blistering fast, tough.  Disable pam all together really helps, but that is not very useful :-)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
2 2