2 2
zakk

USB Ethernet Gadget - Linux4.X

Recommended Posts

Hi all,

 

I build Armbian for my NanoPi Air with both Linux 3.4 and Linux 4.X, and config usb to be an USB Ethernet Gadget but it does not work with Linux 4.X.

There is nothing showing when "dmesg | grep gadget" on Linux 4.x

 

But in Linux 3.4 I got following messages:

 

root@nanopiair:/# dmesg | grep gadget
[    2.559263] g_ether gadget: using random self ethernet address
[    2.565929] g_ether gadget: using random host ethernet address
[    2.582905] gadget_is_softwinner_otg is not -int
[    2.582923] gadget_is_softwinner_otg is not -int
[    2.583012] g_ether gadget: Ethernet Gadget, version: Memorial Day 2008
[    2.590546] g_ether gadget: g_ether ready
[   13.898453] g_ether gadget: high-speed config #2: RNDIS
root@nanopiair:/#
root@nanopiair:/#
 
 
Do you know how enable the Ethernet Gadget for Linux 4.x?

 

 

 

Thanks in advance,

Share this post


Link to post
Share on other sites

So, Do I have to modify these files?

 

.../Armbian/sources/linux-sun8i-mainline/orange-pi-4.9/arch/arm/boot/dts/sun8i-h3-nanopi-neo.dts

.../Armbian/sources/linux-sun8i-mainline/orange-pi-4.9/arch/arm/boot/dts/sun8i-h3.dtsi

 

How do I enable the gadget?

sorry, I am new on the NanoPi Neo Air board.

Share this post


Link to post
Share on other sites

You need to activate USB OTG and USB PHY support in sun8i-h3-nanopi-neo.dts similar to sun8i-h3-orangepi-one.dts. sun8i-h3.dtsi doesn't require any changes.

You need to check the schematic for your board to find the corrext pin for OTG detect (if it is different from OPi One)

Share this post


Link to post
Share on other sites

I'm not sure if this is relevant, but I recently had to start using mainline on my orange pi zero since pygame was constantly crashing with legacy.  Of course, the onboard wifi isn't available in this release so I started to test the usb wifi gadgets I had on hand.  Some failed miserably.  However the COMFAST CF-WU810N 2.4GHz 802.11b/g/n works like a charm.    No additional drivers necessary.  Just configure wifi.  I've very pleased with the functionality and performance of my current setup and wanted to mention that it's very well for me. 

 

One noteworthy item, however.  To get the wifi device to be called wlan0 rather than a long name with the address in the name I created the following link and rebooted:

 

     sudo ln -s /dev/null /etc/udev/rules.d/80-net-setup-link.rules

 

armbian mods and developers -- thank you for providing mainline.  I understand it's experimental and a never-ending cause for painful reiterations of similar problems, but for my personal projects it's working well.  I had hit a dead-end with legacy and mainline has been solid for some time now.  Also, I like the separation of mainline on the forum.  I think that's a big win.

 

 

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
2 2