1 1
blades

Cubieboard1 problem running from nand <fs mount fail, jump to fel>

Recommended Posts

Hi to all, I have a Cubieboard1 and it seems it can't boot from nand after running nand-sata-install script.

The output I get through ttl is:

HELLO! BOOT0 is starting!
boot0 version : 1.5.1
dram size =1024
Succeed in opening nand flash.
Succeed in reading Boot1 file head.
The size of Boot1 is 0x0003c000.
The file stored in 0X00000000 of block 2 is perfect.
Check is correct.
Ready to disable icache.
Succeed in loading Boot1.
Jump to Boot1.
[       0.133] boot1 version : 1.4.0
[       0.133] pmu type = 3
[       0.134] bat vol = 0
[       0.161] axi:ahb:apb=3:2:2
[       0.161] set dcdc2=1400, clock=1008 successed
[       0.163] key
[       0.175] no key found
[       0.175] flash init start
[       2.468] flash init finish
[       2.468] fs init ok
[       2.469] unkown fs type in the input file, FS_FAIL!
[       2.473] fs mount fail, jump to fel


and stops there.

 

I tested both Debian and Ubuntu server and gui images

Share this post


Link to post
Share on other sites

/tmp/nand-sata-install.log shows mkfs.vfat /dev/nand1 fails.

-----------------------------------------------

mkfs.vfat: invalid option -- 'q'

-----------------------------------------------

I guess "-qF" was added just like what is done for all mkfs.ext4 in the script.

Can this be fixed next version? Cubieboard is declared 'end of support' now.

 

Share this post


Link to post
Share on other sites

It is from vanilla "Armbian_5.25_Cubieboard_Ubuntu_xenial_default_3.4.113_desktop". I did not do "apt-get upgrade" because last time it upgraded kernel to 4.11.

 

Share this post


Link to post
Share on other sites
5 minutes ago, ykchavan said:

It is from vanilla "Armbian_5.25_Cubieboard_Ubuntu_xenial_default_3.4.113_desktop". I did not do "apt-get upgrade" because last time it upgraded kernel to 4.11.


That's not possible unless you manually installed NEXT (4.11.x) packages. default can only upgrade to next default kernel, which is still 3.4.113, last Armbian build is 5.30

Share this post


Link to post
Share on other sites

Yes. This time 'apt-get upgrade' worked fine for me. I am not sure what I did wrong last time. I confirm that after upgrade, 'nand-sata-install' script is not giving above error.

Share this post


Link to post
Share on other sites

This is the log link  http://sprunge.us/PRDE

Somehow usb-wifi dongle is getting detected as 'enx0013ef70247b' and not as 'wlan0'.

Last  installation, I replaced /usr/lib/arm-linux-gnueabihf/mesa/* with '/usr/lib/arm-linux-gnueabihf/glshim/*'. Openarena worked nicely until reboot. Then I started getting 'mali_drm' related errors like mentioned glshim thread.

Share this post


Link to post
Share on other sites
9 minutes ago, ykchavan said:

Somehow usb-wifi dongle is getting detected as 'enx0013ef70247b' and not as 'wlan0'.


That's o.k.

 

49 minutes ago, ykchavan said:

 

This is the log link  http://sprunge.us/PRDE

 


Nothing suspicious.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
1 1