• 0

Problem with new update script




Hi Igor,


while trying to reproduce/fixing my boot problem, I stumbled across some weird things regarding your new update script.


I've put a complete new image on sd-card only (Armbian_4.5_Cubietruck_Ubuntu_trusty_4.2.3) which works fine, boots and reboots.

Then I've tried to use your update script which I called via:

wget -q -O - http://upgrade.armbian.com | bash

with the letter O and a blank between the minus and http, is this correct?


First strange thing I noticed is, that it starts but doesn't run through completely. It ends with this output:



Don't think that this should be the normal behaviour!? And remember that this wasn't the case when I tried this some time ago. What could have happened?


Second strange thing is, that when I call it again, it runs through completely, removes the old kerne-stuff:




but tells me that nothing was upgraded / removed nor installed.....????:




Could this be because everything was already up to date? But then it either shouldn't remove 'old' kernel or should populate /boot again with the latest stuff!?


Looking in /boot, all the new stuff is missing:




So no wonder that it doesn't boot anymore.


Does this make any sense to you? Can you imagine what has happened and whether this is a common thing or something went wrong just at my side?

[Edit:] There's another user that reports similar problem: http://forum.armbian.com/index.php/topic/211-kernel-update-procedure-has-been-changed/?p=2173


Thanks in advance and best regards,


Link to post
Share on other sites

13 answers to this question

Recommended Posts

Donate and support the project!

  • 0

Ign is when there is no change. That's ok.


The problem might be, that your package base is corrupted ... or simply it does not update because there are no packages to update. In this case you need to install them manually / with this script.


Without (install) log I hard to tell what went wrong.

Link to post
Share on other sites

  • 0
apt-get update && apt-get upgrade

ran through smoothly and yesterday some other packages where updated successfully (...libc...), so I assume that the package base shouldn't be corrupted. Otherwise this wouldn't have worked?

But running:

root@seafile:/# wget -qO - http://upgrade.armbian.com | bash
Image Name:
Created:      Tue Oct 20 12:03:57 2015
Image Type:   ARM Linux Script (uncompressed)
Data Size:    1753 Bytes = 1.71 kB = 0.00 MB
Load Address: 00000000
Entry Point:  00000000
   Image 0: 1745 Bytes = 1.70 kB = 0.00 MB
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

All done. Check boot scripts and reboot for changes to take effect!

Visit: forum.armbian.com in case of troubles or just for fun 


results in no kernel update, although I'm still on 4.1.6.


Which log could I check / do you need to further investigate?


With "install them manually" do you mean the steps described in 'how to unbrick the system'? So just download and dpkg -x these files? 


Thanks and best regards,


Link to post
Share on other sites

  • 0

If you still have a running system, than you don't need to use that procedure but directly:

apt-get install linux-image-next-sunxi linux-headers-next-sunxi linux-firmware-image-next-sunxi
apt-get install linux-trusty-root-cubietruck
apt-get install linux-u-boot-next-cubietruck
Link to post
Share on other sites

  • 0
apt-get install linux-u-boot-next-cubietruck

it's actually 

apt-get install linux-u-boot-cubietruck-next

Yeah, that did the trick! I'm on kernel 4.2.3 now! And all the other errors (iptables) also went away!


You're the best, Igor! Thank you very much!


[Edit]: Damn! After Powercycle got stuck again with my boot problem described in other post: http://forum.armbian.com/index.php/topic/341-new-boot-problem/

Link to post
Share on other sites

This topic is now closed to further replies.