Jump to content

compiling mosquitto 1.4


sash99
 Share

Recommended Posts

hi there, i was wondering if there a away to compile mosquitto 1.4. successfully  the current version is 1.3.3 ( or something like that)

 

when I try to compile it it seams to compile correctly and it seams to install correctly.  the broker portion works fine but the client side does not.  when you try to publish or subscribe it complains a file is missing.

 

I needed it for websockets

 

to compile id did this

 

  1. wget https://github.com/warmcat/libwebsockets/archive/v1.3-chrome37-firefox30.tar.gz  
  2. tar xvzf v1.3-chrome37-firefox30.tar.gz  
  3. cd v1.3-chrome37-firefox30  
  4. mkdir build  
  5. cd build  
  6. cmake ..  
  7. make  
  8. sudo make install 
  9. sudo ln -s /usr/local/lib/libwebsockets.so.4.0.0 /usr/lib/libwebsockets.so.4.0.0 

 

  1. wget http://mosquitto.org/files/source/mosquitto-1.4.tar.gz  
  2. tar xvzf mosquitto-1.4.tar.gz  
  3. cd mosquitto-1.4  
  4. nano config.mk  --- change it to read, "WITH_WEBSOCKETS:= yes".
  5. make  
  6. sudo make install 

the broker seams to work  but not the clients it complains about /usr/lib/libmosquitto.so.1: version `MOSQ_1.4' not found  

 

 

does anyone have an idea where I might be going wrong

Link to comment
Share on other sites

Search Before Posting!

Perhaps because you built your websockets library against older libmosquitto. I would try to purge websockets lib and mosquitto and start again with building mosquitto first. This way library will link to new libmosquitto.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...