Jump to content
  • 0

I want to set the video output to HDMI port when the cable is not connected.




I'm using CubieTruck and Armbian mainline up to dated version.


The CT is a headless server, so I don't connect any cable to it.

However, one day the ssh server in CT did not work, I tried to connect CT to a monitor using HDMI cable.

Even though I connect a cable, I could not see anything, and the monitor said 'No signal'.

(Well, if the hdmi cable was connected, and CT is booted with it, the output is ok with hdmi signal.)


If I connect with a vga cable, there is no problem.


Here's what I want.

I want to see the screen when I connect CT with a hdmi cable, even if the cable has not been connected.

(I hope you understand what I mean..)


I followed this, but there was no difference.



Any help would be appreciated.


Link to comment
Share on other sites

14 answers to this question

Recommended Posts

Armbian Linux community supported weekly builds download

  • 0

Yes, I just checked. It's set to VGA if nothing come up on HDMI. This is the console output:

U-Boot 2017.01-armbian (Feb 02 2017 - 02:21:14 +0100) Allwinner Technology

CPU:   Allwinner A20 (SUN7I)
Model: Cubietech Cubietruck
I2C:   ready
DRAM:  2 GiB
*** Warning - bad CRC, using default environment

Setting up a 1024x768 vga console (overscan 0x0)
In:    serial
Out:   vga
Err:   vga
SCSI:  SATA link 0 timeout.
AHCI 0001.0100 32 slots 1 ports 3 Gbps 0x1 impl SATA mode
flags: ncq stag pm led clo only pmp pio slum part ccc apst 
Net:   eth0: ethernet@01c50000
Hit any key to stop autoboot:  0 
6944 bytes read in 156 ms (43 KiB/s)
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
Link to comment
Share on other sites

  • 0

Set some fixed resolution, monitor to hdmi, disabled hdp, disabled edid ... save that into u-boot environment, otherwise it wont work. Plan B: recompile u-boot with disabled VGA support and it should also be fine.

Link to comment
Share on other sites

  • 0

I tried.. but failed. The output is always through the vga port.


Here's my boot.cmd.


setenv video-mode sunxi:1920x1080-24@60,monitor=hdmi,hpd=0,edid=0
Then I compiled it.
sudo mkimage -C none -A arm -T script -d /boot/boot.cmd /boot/boot.scr 

I rebooted the CT, twice(or more), but the result is the same.

I changed the resolutions, but no difference.

Link to comment
Share on other sites

  • 0

I compiled and installed Uboot, but it does not work either.


I compiled uboot using these tools.

OS : Ubuntu 16.04(64bit)
Source : git://git.denx.de/u-boot.git
Toolchain : https://releases.linaro.org/components/toolchain/binaries/6.2-2016.11/arm-linux-gnueabihf/gcc-linaro-6.2.1-2016.11-x86_64_arm-linux-gnueabihf.tar.xz

I successfully made u-boot-sunxi-with-spl.bin, and installed it to my SD card, using dd command.

This is my Uboot file.(https://drive.google.com/file/d/0BwNiQ50_PJd2ZTVRWUg2LW5pVmc/view?usp=sharing)


Vga output is defenitely dead. It's not working at all whether it is connected or not at the boot time.

However, hdmi output is only working when it's connected at the boot time.


I decide not to use hdmi out for the time being.


Anyway, thank you for your concern.

I really appreciate it.

Link to comment
Share on other sites

  • 0

I found that my kernel is3.4.112-sun8i(my board is H3) so I have to change parameters using FEX(/boot/script.bin), not  config file as in  mainline kernel.


But, I didn't found right parameters yet.

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...