1 1
miha

CubieTruck Dev Sunxi softw311 nand magic does not match for MBR 1: softw411

Recommended Posts

Hi,

 

I wrote Armbian_5.25_Cubietruck_Ubuntu_xenial_default_3.4.113.img to sd-card and booted my cubietruck from the card.  ssh in and user creation followed by reboot (rootfs resize) After that i performed apt get update&upgrade and started nand-sata-install.

 

I have SSD hooked to CubieTruck and my goal is boot system from onboard memory (with 3.4-kernel nand is available but not with 4.9...) and roots to /dev/sda1. This was how previous setup was. sd-card slot is broken, I need to use tape to keep card on the reader, another reason why boot from nand would be nice.

 

However, when i start and-sata-install, following is displayed on console:

[  112.701170] Dev Sunxi softw311 nand magic does not match for MBR 1: softw411
[  112.710146] Dev Sunxi softw311 nand magic does not match for MBR 2:         
[  112.719450] Dev Sunxi softw311 nand magic does not match for MBR 3:         
[  112.725528] Dev Sunxi softw311 nand magic does not match for MBR 4:         
[  112.733262] Dev Sunxi softw311 nand header bad for all MBR copies, MBR corrupted or not present.
[  112.743553] Dev Sunxi softw411 nand: part 1, start 65536, size 65536
[  112.749216] Dev Sunxi softw411 nand: part 2, start 131072, size 14909440
[  112.751266]  nand: nand1 nand2
[  112.764254] Dev Sunxi softw311 nand magic does not match for MBR 1: softw411
[  112.770268] Dev Sunxi softw311 nand magic does not match for MBR 2:         
[  112.776448] Dev Sunxi softw311 nand magic does not match for MBR 3:         
[  112.782522] Dev Sunxi softw311 nand magic does not match for MBR 4:         
[  112.790258] Dev Sunxi softw311 nand header bad for all MBR copies, MBR corrupted or not present.
[  112.800339] Dev Sunxi softw411 nand: part 1, start 65536, size 65536
[  112.806096] Dev Sunxi softw411 nand: part 2, start 131072, size 14909440
[  112.808112]  nand: nand1 nand2

It's clear that my CubieTruck fails to boot from nand.  I have searched around the web and conclusion is that i should install old ubuntu-server and flash with LiveSuite (which is not working with my MacOSsierra...)

Is there any other possibilities to get system booting from /den/nand?

 

Br

miha

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
1 1