orange pi pc + wifi AP is not responding (SULVED!)


Recommended Posts

SULVED!

 

Cant get the wifi operate as i want it. i am using the nmtui tool for configuration.

The following logs are with Lan0  connected.

 

-------------------------------------------------------------------------------------

Welcome to ARMBIAN 5.25 stable Ubuntu 16.04.2 LTS 3.4.113-sun8i
System load:   0.43             Up time:       29 min
Memory usage:  27 % of 1000Mb   IP:            192.168.178.19,192.168.178.58
CPU temp:      16°C
Usage of /:    12% of 28G

Last login: Mon Apr 17 17:09:41 2017 from 192.168.178.49
root@myboard:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         *               255.255.255.255 UH    600    0        0 wlan0
default         gateway         0.0.0.0         UG    600    0        0 wlan0
192.168.178.0   *               255.255.255.0   U     100    0        0 eth0
192.168.178.0   *               255.255.255.0   U     600    0        0 wlan0
myboard         *               255.255.255.255 UH    600    0        0 wlan0
myboard         *               255.255.255.255 UH    100    0        0 eth0
 

root@myboard:~# ifconfig

eth0      Link encap:Ethernet  HWaddr 32:57:92:08:e1:50
          inet addr:192.168.178.20  Bcast:192.168.178.20  Mask:255.255.255.255
          inet6 addr: fe80::3057:92ff:fe08:e150/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:162 errors:0 dropped:0 overruns:0 frame:0
          TX packets:109 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:15557 (15.5 KB)  TX bytes:15099 (15.0 KB)
          Interrupt:114

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:43 errors:0 dropped:0 overruns:0 frame:0
          TX packets:43 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3382 (3.3 KB)  TX bytes:3382 (3.3 KB)

wlan0     Link encap:Ethernet  HWaddr 32:57:92:08:e1:51
          inet addr:192.168.178.19  Bcast:192.168.178.19  Mask:255.255.255.255
          inet6 addr: fe80::3057:92ff:fe08:e151/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3437 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2201 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4039926 (4.0 MB)  TX bytes:253307 (253.3 KB)
 

--------------------------------------------------------------------------------------------

Booed without Lan0 connected:
Can ping from board to router 192.168.178.1, but not to pc connected to the router with ip 192.168.178.48

wifi --> router (OK) --> PC ( no respond)

pc --> router (OK) --> Orange via wifi (no respond)

But keep in mind using a different  board instead of orange pi i don't have a problem using this setup.

Please may someone look into this carefully and tell me what may be wrong.

For me it is definitely a routing problem, but what can i do to fix it. Board wifi is definitely up and running othervice i could not ping the router.

One my think it my be a problem with my router but way my DSL W900 has no way to configure routes, and it should work without fielding with the home router.

------------------------------------------------------------------------------------------------

root@myboard:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         *               255.255.255.255 UH    600    0        0 wlan0
default         gateway         0.0.0.0         UG    600    0        0 wlan0
192.168.178.0   *               255.255.255.0   U     600    0        0 wlan0
myboard         *               255.255.255.255 UH    600    0        0 wlan0

 

 

root@myboard:~# ifconfig

eth0      Link encap:Ethernet  HWaddr 32:57:92:08:e1:50
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:238 (238.0 B)
          Interrupt:114

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:31 errors:0 dropped:0 overruns:0 frame:0
          TX packets:31 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2619 (2.6 KB)  TX bytes:2619 (2.6 KB)

wlan0     Link encap:Ethernet  HWaddr 32:57:92:08:e1:51
          inet addr:192.168.178.19  Bcast:192.168.178.19  Mask:255.255.255.255
          inet6 addr: fe80::3057:92ff:fe08:e151/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:593 errors:0 dropped:0 overruns:0 frame:0
          TX packets:447 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:507934 (507.9 KB)  TX bytes:612294 (61.2 KB)

---------------------------------------------------------------------------------------------------

Link to post
Share on other sites
Armbian is a community driven open source project. Do you like to contribute your code?

Cant get the wifi operate as i want it. i am using the nmtui tool for configuration.

The following logs are with Lan0  connected.

 

-------------------------------------------------------------------------------------

Welcome to ARMBIAN 5.25 stable Ubuntu 16.04.2 LTS 3.4.113-sun8i
System load:   0.43             Up time:       29 min
Memory usage:  27 % of 1000Mb   IP:            192.168.178.19,192.168.178.58
CPU temp:      16°C
Usage of /:    12% of 28G

Last login: Mon Apr 17 17:09:41 2017 from 192.168.178.49
root@myboard:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         *               255.255.255.255 UH    600    0        0 wlan0
default         gateway         0.0.0.0         UG    600    0        0 wlan0
192.168.178.0   *               255.255.255.0   U     100    0        0 eth0
192.168.178.0   *               255.255.255.0   U     600    0        0 wlan0
myboard         *               255.255.255.255 UH    600    0        0 wlan0
myboard         *               255.255.255.255 UH    100    0        0 eth0
 

root@myboard:~# ifconfig

eth0      Link encap:Ethernet  HWaddr 32:57:92:08:e1:50
          inet addr:192.168.178.20  Bcast:192.168.178.20  Mask:255.255.255.255
          inet6 addr: fe80::3057:92ff:fe08:e150/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:162 errors:0 dropped:0 overruns:0 frame:0
          TX packets:109 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:15557 (15.5 KB)  TX bytes:15099 (15.0 KB)
          Interrupt:114

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:43 errors:0 dropped:0 overruns:0 frame:0
          TX packets:43 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3382 (3.3 KB)  TX bytes:3382 (3.3 KB)

wlan0     Link encap:Ethernet  HWaddr 32:57:92:08:e1:51
          inet addr:192.168.178.19  Bcast:192.168.178.19  Mask:255.255.255.255
          inet6 addr: fe80::3057:92ff:fe08:e151/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3437 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2201 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4039926 (4.0 MB)  TX bytes:253307 (253.3 KB)
 

--------------------------------------------------------------------------------------------

 

Link to post
Share on other sites

Thank you for taking time to answer! Unfortunately this does not work i use a serial console link via putty for testing and i also checked just to configure wifi without eth0 no way to connect. I have red the thread you did post before and tried everything suggested.  Behavior is the same as with both interfaces configured.  Just wifi configured i can ping from router to the board and from the board to the router (W900 with serial console connected).  i can ping from router to my pc and from my pc to the router but not form orangepi pc + board to the PC.  Absolutely no problem to connect from orangepi pc + board to the internet via wifi only.  Ok i checked all again but there is definitely a problem. All is as i explained. 

 

Link to post
Share on other sites

So finally i found a way around the problem. Just to confirm all what i told above is true the behavior is not as expected. It is possible to use the wifi without eth0 configured if one uses some other way to to connect to the board for setup, in my case i used the SSH Terminal via serial link.  Configured only the wifi with the nmtui tool as client. ( i t also works with the eth0 configured and disconnected lan wire) Set the power management of wifi to always on. By:

 

To turn off power management, go to /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf and you will see

[connection]
wifi.powersave = 2

Change the 3 to a 2 and reboot.

Then run iwconfig and if it worked you should see Power Management:off.

 

Then i added the scripts below to /etc/NetworkManager/dispatcher.d/

cat 99set-reg-domain.sh

#!/bin/bash
status=`cat /sys/class/net/wlan0/operstate`
/bin/bash -n /etc/default/crda && source /etc/default/crda
if [[ $status == 'up' ]]
then
        iw reg set $REGDOMAIN
fi

Don't know if it is relay needed, at this point still nothing changed.

I could connect to the inter net from the orange pi pc + without problem but not from the PC to the board as before.orange-ping-pc-trace.jpgping-pc--orange.jpgavm-mitschnitt-adresse-180.jpg

Then i did some tests with wireshak. I had a look way pinging cant get across the router. i Uses damps from the router to look int the problem. Nothing could be fond. Tareceroute from orangepi board  to the PC worked ping did not work.tacert-pc-mayboard.jpg.

Tacert from PC to the board did not work stopped at router.  

So it looks like the route is just broken in one point form router to the orange board. 

------------------------------------------------------------------------------------------------------

So i stated to setup an DYNsys entry on the router. DynDNS-setup.jpg

Entered the port forwarding and finally all can be reached from my PC with the correct port entry's in the router. Portfreigaben-am-router-configpage.jpgPortfreigaben-am-router.jpg

But i cant see ans reason way it should not work without DYNsys and port-forwarding on the local net. May be i am wrong and this is just the correct way to do it.  If someone can tell me where my conclusions are wrong pleas to it.  

Thank to tKaiser for Answering and all other an the subject to get this all working. here are some more pictures of my setup.

 

 

 

 

Zwischenablage09.jpg

Link to post
Share on other sites

Additional info! There is absolutely nothing wrong with the  WIFI if network manager and wicd is in use. My Problem was on my side.  I connected with the PC via WIFI to the router and from the router also via WIFI to the orangepipc+  As i did show above if ports forwarding was set up in the router i could connect from outside and from my PC. but way not directly?

In my fritz!box it war inhabited to communicate from one wifi interface to an other.  First i configured the wifi on the orangepipc+ to a static address outside of the range DHCP uses.

Then i had to go to the WLAN page of my fritzbox and activate the comunication between WIFI clients.  On other routers this may be a setting like this: Wireless -> Advanced Wireless Settings -> AP Isolation

Wlan-einstellungen.jpg

Link to post
Share on other sites
Guest
This topic is now closed to further replies.