Jump to content

AP6212 in Mainline


Recommended Posts

Check forum guidelines to use maximum potential!

a weird one ... i installed the 0525 image and after an update the networking stopped working. i'm trying the 0526 image to see if that does the same thing.

 

also, should the console login work ? i've tried it connected to a TV and a monitor .... the u-boot messages appear but then nothing ....

 

if it doesnt work, how do you debug the startup ?

 

many thanks

Link to comment
Share on other sites

AP mode does work which is really good. Many thanks again. it was made alittle frustrating without a console login ... do you know why this doesnt work ?

 

I have noticed that sometimes the connection seems to 'stutter' ... you type away and then get all the characters in a surge ? have you noticed such a thing ?

 

i tried the apt-get upgrade and it seemed to zap the network again. not sure why ? It's hard to tell without a console :(

 

the only other issues (minor) are:

sshd doesnt accept ssh-dss keys
        echo "PubkeyAcceptedKeyTypes=+ssh-dss" >> /etc/ssh/sshd_config; /etc/init.d/sshd restart
iptables not installed by default

console tty not working

 

thanks for all the awesome effort by everyone concerned !!!!!!

Link to comment
Share on other sites

11 hours ago, t-bob said:

I have noticed that sometimes the connection seems to 'stutter' ... you type away and then get all the characters in a surge ? have you noticed such a thing ?

No, I don't have such behaviour. My SSH session are pretty normal in STA mode.

 

Link to comment
Share on other sites

On 23.5.2017 at 5:51 PM, martinayotte said:

Ok ! AP6212 is now working on OPiWin

Does it now only work on OPi's IOT device or also on BPI m2+

Link to comment
Share on other sites

It should, the wlan0 is appearing, but for some unknown reason, it could not get response from DHCP request.

I'm also having same kind of issue on BPiM2Ultra.

I didn't get chance recently to pursue the investigation, but I hope I will soon.

 

EDIT : After comparing results between my M2+ and my M2U, the latest is able to scan APs but not the M2+. So, I presume my M2+ is now defective.

Link to comment
Share on other sites

On 5/14/2017 at 4:15 AM, martinayotte said:

Ok ! I've finally found some discripancies in DT between H3 and H5 : the reset-gpios default level in wifi-pwrseq of DT.

Thoses fixes the OPiZeroPlus2-H5 as well as NanoPiM1Plus2-H5. Next nigthlies should reflect that.

(Be aware for those two boards : MicroUSB powering is choking when WiFi get powered. I need some new stronger cables)

A side note : OPiWin still not work with the same medecine, as well as the BanadaPi-M2-Ultra ... I will dig further ...

 

EDIT : For those who trying fresh builds, you sill need @tkaiser firmware hack, which is not part of the images yet :

download /lib/firmware/ap6212/fw_bcm43438a1.bin and copy it under /lib/firmware/brcm/brcmfmac43430-sdio.bin.

 

Currently - for Armbian Stretch / OPIZeroPlus2-H3 - the files in /lib/firmware/ap6212/fw_bcm43438a1.bin and /lib/firmware/brcm/brcmfmac43430-sdio.bin are not identical.

WiFi works with both of them, but when using /lib/firmware/ap6212/fw_bcm43438a1.bin ping times improve!

 

One more thing: When using the ap6212 driver, 14 wifi channels are supported.

When using the driver in the brcm folder, though, only 11 wifi channels are supported.

 

Conclusion: out of the box Armbian Stretch uses the wrong driver for OPIZeroPlus2-H3 - resulting in bad ping times, and reduced number of wifi channels.

Link to comment
Share on other sites

anybody manage to get bluetooth on BPI-M2+ working?

I change dts and already enable uart1 and hook cts_rts but get init time out

 

> /etc/init.d/bluetooth stop
> rfkill unblock all

> echo " " > /dev/ttyS1
> hciattach -t 5 /dev/ttyS1 bcm43xx 1500000
bcm43xx_init
Initialization timed out.
 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...