Jump to content
  • 0

Orange Pi Zero /4.11.0-sun8i/ wlan0 is gone



Recommended Posts

  • 0

Yep, driver and chip are crap and have no future - no-one argues that.
Nobody - literally nobody - in this thread made any development demands: The thread starter @hpapagaj noted the absence of wlan0. @exquisitus very kindly asked a valid question about dev-status. Both got told off (and never posted again as of today - and they're not the only ones). Other users, me included, noted that the disabled driver did not compile and finally patched up a working version - before you guys did. Now the only "demand" there is, is to re-enable the driver for users uncomfortable with or unable to compile their own kernel.

Of course, you can do whatever you like - but be aware that the way you guys communicate does not promote a "vibrant community".




Link to comment
Share on other sites

Open source development is fun. Join Armbian Linux development team today!

  • 0
16 minutes ago, raschid said:

Now the only "demand" there is, is to re-enable the driver for users uncomfortable with or unable to compile their own kernel.

And what happens if this driver breaks in 4.13, 4.14 or any other future kernel version, but nobody is willing to patch it in time (or patch it at all) because developers moved to other hardware with better support? Right, forum threads and posts like "Orange Pi Zero /4.14.0-sun8i/ wlan0 is gone", "devs plz fix", etc.

Having an out-of tree driver (that can be compiled on the device itself! no full kernel recompilation needed!) gives people a chance to freeze the kernel with working driver if they want wireless instead of updating several times per week hoping that improvements will come from nowhere.

Link to comment
Share on other sites

  • 0

OK to round it up........ ( trying to wave with a white flag and wearing a blue helmet.....)


What I would do with a Zero is. Forget about the driver/wifi/wlan0. What do you expect for $6.99?


Run to the nearest Action Supermarket ( or US equivalent) and buy a cheap usb WIFI dongle. I bought one for 3 euro's. Works fine.

This one:



[    4.208943] usb 3-1: new high-speed USB device number 2 using ehci-platform
[    4.418224] usb 3-1: New USB device found, idVendor=148f, idProduct=5370
[    4.418234] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    4.418240] usb 3-1: Product: 802.11 n WLAN
[    4.418245] usb 3-1: Manufacturer: Ralink
[    4.418250] usb 3-1: SerialNumber: 1.0
[    8.589015] usb 3-1: reset high-speed USB device number 2 using ehci-platform
[    8.832680] usbcore: registered new interface driver rt2800usb

Do a little udev magic magic and make a new rule


vi /etc/udev/rules.d/75-persistent-net.rules


SUBSYSTEM=="net", ACTION=="add", ATTR{address}=="00:13:ef:c5:2d:40", NAME="wlan0

And use nmtui to activate.. Of you go.... and forget about the driver.......



[  198.551193] wlan0: associated
[  198.551371] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready




Link to comment
Share on other sites

  • 0

Hello there,


I need to use the XR819 driver because this is what the board I have use.

How do I enable it? I am researching this subject for three weeks now.

Device wlan0 does not exist.


Please advise,




Here is my lsmod:

Module                   Size  Used by
xradio_wlan                94208  0
mac80211                   446464  1 xradio_wlan
cfg80211                     376832  2 mac80211,xradio_wlan
rfkill                             20480  2 cfg80211
sun8i_codec_analog     24576  0
snd_soc_core                118784  1 sun8i_codec_analog
snd_pcm_dmaengine    16384  1 snd_soc_core
snd_pcm                        69632  2 snd_pcm_dmaengine,snd_soc_core
snd_timer                      24576  1 snd_pcm
snd                                45056  3 snd_timer,snd_soc_core,snd_pcm
soundcore                     16384  1 snd
sun4i_gpadc_iio            16384  0
uio_pdrv_genirq            16384  0
uio                                16384  1 uio_pdrv_genirq
usb_f_acm                     16384  1
u_serial                         20480  3 usb_f_acm
g_serial                         16384  0
libcomposite                 40960  2 g_serial,usb_f_acm
pwrseq_simple              16384  1

Link to comment
Share on other sites

  • 0

I run R69.


I might have wrong dts file.

How the wlan0 device is created? By the driver? module?


Where is this log file located?
[ 4.833331] usb usb7: Manufacturer: Linux 4.13.14-sunxi ohci_hcd

[ 4.833342] usb usb7: SerialNumber: 1c1c400.usb

[ 4.834334] hub 7-0:1.0: USB hub found

[ 4.834399] hub 7-0:1.0: 1 port detected


Where do I start debugging this?


Please advise!


Link to comment
Share on other sites

  • 0

There is no Device Tree for this device at this time - and without a dts you will not be able to build a mainline kernel with working wireless.

But you can build a legacy kernel using a "community supported" board configuration ("sunvell-R69.csc"):

./compile.sh BOARD=sunvell-r69.csc

You will find more on building armbian kernels here: https://docs.armbian.com/Developer-Guide_Build-Preparation/


Link to comment
Share on other sites

  • 0



I will do it first thing in my morning.

Still: I want to understand the connection between modules<-driver->device (interface). Can you lead me a little?


The Armbian I have work very well. Just the wlan0 device is missing.

I would like to fix the dts file if I can and donate it to the project.

Link to comment
Share on other sites

  • 0

I can not run the AP neither connect to my wifi router. Is the driver broken in my image or am I missing something?

I followed the instructions in documentation and also tried armbian-config, no success.

The links to the image with kernel 4.11 are down, so I downloaded Armbian 5.34.171121 xenial next with kernel 4.13.14. (board revision 1.1)

 lshw -C network
       description: Wireless interface
       physical id: 9
       logical name: wlan0
       serial: 12:42:9c:b1:36:2e
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=xradio_wlan driverversion=4.13.14-sunxi firmware=N/A link=no multicast=yes wireless=IEEE 802.11

thanks for any help

Link to comment
Share on other sites

  • 0

I have tried with legacy kernel, I could connect to my router. I did clean install of mainline image and right after booting I am able to setup AP via armbianconfig.

I suspect, that my hostapd.conf was corrupted by windows notepad. When I edit configuration files with nano it works.

I found out by running hostapd manually.

sudo hostapd -dd /etc/hostapd.conf

To answer my previous question,  AP works with the mainline image.

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...