You are using development kernel, which we don't support for many reasons.   This indicate some problems with u-boot script. Check and change rootdev parameter in /boot/armbianEnv.txt setenv rootdev "/dev/mmcblk0p1"