Z28 [RK3328] 1/8
12 12

115 posts in this topic

Recommended Posts

On 11/19/2017 at 5:41 AM, Igor said:

My Z28 PRO is running Armbian using this method and our Rock Nightly image https://dl.armbian.com/rock64/Ubuntu_xenial_default_nightly.7z ... of course, fine-tuning is needed since I don't see ethernet nor Wifi, but luckily there is a screen and USB. http://sprunge.us/UeGE

  Reveal hidden contents

entering_mask_rom.png

 

so igor, what do you think, what are the chances for a working distro with eth and wifi for z28 pro (11) within several months? thanx

Share this post


Link to post
Share on other sites
5 hours ago, Blackie said:

Anyone tested "SCISHION V88 Piano" box? https://www.gearbest.com/tv-box/pp_1064854.html

Gigabit ethernet, 4GB ram, nice thermal case design, DRM widevine level 1, ... seems to me like a nice RK3328 box.

The smaller SCISHION box is booting from the card, not sure about this one.

Where do you find information that it supports Widevine Level 1,  what about HDCP-1.x or 2.x???  I don't see any reference for that.  As far as I know, the only inexpensive Chinese boxes that supports Widevine Level 1 and HDCP 1.x is boxes from VideoStrong (Mecool).

Share this post


Link to post
Share on other sites

 

On 11/19/2017 at 11:41 AM, Igor said:

My Z28 PRO is running Armbian using this method and our Rock Nightly

 

thx @Igor for testing armbian's image.

I see that it's using ayufan's kernel source, from what i know his rock64 images have working ethernet on z28 pro, something different in the kernel config or dts ?

Also if i wanted to build armbian rock64 against my z28 pro dts, full disassembled dts not dtsi includes (available in this thread), how would i go about that ?
 

On 11/24/2017 at 2:33 PM, Blackie said:

Anyone tested "SCISHION V88 Piano" box?

I also have spotted that box, haven't found any tests so far.
If i'm correct you should be able to use SDMMC0 (boot sd card slot) along with the GMAC interface, Alfawise decided for some reason not to use it, that's why you can't boot from sdcard on their box..

Share this post


Link to post
Share on other sites
5 minutes ago, mdel said:

Also if i wanted to build armbian rock64 against my z28 pro dts, full disassembled dts not dtsi includes (available in this thread), how would i go about that ?


I didn't get this far yet. I have system on eMMC now, can boot from it and (only) waiting in the corner :) Busy with other stuff.

Share this post


Link to post
Share on other sites

ok, i was more asking if it's a complicated process to get armbian to build a kernel source against a different dts file.

 

i don't know armbian internals but found that some scripts like rk3328-default/packaging-4.x-with-postinstall-scripts.patch or other DT patche files, do a lot of manipulation of dtb "stuff"..  i known there's a detailed armbian documentation and will take a look at it.

 

alternatively if it's easier, maybe simply try to reuse the android dtb, but i don't know much about rockchip, it was simple enough with amlogic and boot scripts..

Share this post


Link to post
Share on other sites

Guys I'm with you! Unfortunately I do not have enough knowledge of linux to help you ( 

I have Z28 PRO RLT8211e + RTL8822bs no sd boot

I try https://github.com/ayufan-rock64/linux-build/releases/ rock64 image and found out that from version 0.5 eth does not work.  looks like  ayufan remove external phy support. 

Do not forget that rockchip has https://github.com/rockchip-linux/rkdeveloptool this util can write\read partition\loader\gpt table via maskrom

Share this post


Link to post
Share on other sites

igor

did you get hdmi output after flashing armbian? i followed zet-labs procedures carefully and got red led and no hdmi output. so it does not seem that it worked for my alfawise z28 pro v11... i don't know what (if anything) i am doing wrong...

here is the output... do you see anything wrong?

 

./flash_tool.sh -c rk3328 -p system -i image/Armbian_5.34.171121_Rock64_Ubuntu_xenial_default_4.4.77.img
PARTITIONS OFFSET: 0 sectors.
Downloading bootloader succeeded.
Write LBA from file (100%)
Reset Device OK.

 

Share this post


Link to post
Share on other sites
15 minutes ago, exquisitus said:

igor

did you get hdmi output after flashing armbian? i


Yes, I do - sometimes boot stops and you don't get a prompt ... haven't dug into it yet. Successful boot takes 6-8s. Then it's possible to log in with a USB keyboard.

Share this post


Link to post
Share on other sites

Finally received my SCISHION V88 Piano box.  I was able to burn the DietPi image for Rock64 to a micro SD card, place it in the micro SD slot, apply power and it booted up to a login.  The ethernet showed up as eth0 but I couldn't connect to anything.  Wireless also wasn't working.  I'm not sure what else is broken.

puneet.behel likes this

Share this post


Link to post
Share on other sites
1 hour ago, rob0809 said:

Finally received my SCISHION V88 Piano box.  I was able to burn the DietPi image for Rock64 to a micro SD card, place it in the micro SD slot, apply power and it booted up to a login.  The ethernet showed up as eth0 but I couldn't connect to anything.  Wireless also wasn't working.  I'm not sure what else is broken.

Thank you very much Rob for reporting. It's still not bad result for a start, booting from SD card seems to be a problem on many other boxes.

I hope some developers could help to resolve the ethernet issues in the future.

Can you test whether USB 3 port is working full speed?

 

Share this post


Link to post
Share on other sites

igor

so we are getting a different outcome from the same procedure... puzzling...

i would like to know why so i can get what you get, because i get nothing...

how is your pcb labeled?

mine is XJH-RK28-V11 20170808.

 

 

Share this post


Link to post
Share on other sites
19 hours ago, Blackie said:

Thank you very much Rob for reporting. It's still not bad result for a start, booting from SD card seems to be a problem on many other boxes.

I hope some developers could help to resolve the ethernet issues in the future.

Can you test whether USB 3 port is working full speed?

 

I'll test it when I get time.

Share this post


Link to post
Share on other sites
17 hours ago, exquisitus said:

how is your pcb labeled?

mine is XJH-RK28-V11 20170808.

 


Mine is V10 20170505 but we don't know what that means :(

Share this post


Link to post
Share on other sites

Finally received my SCISHION V88 Piano box IN android tv box JIO TV WORKING WITHOUT JIO NETWORK AND HOTSTAR WORKING FINE BUT AMAZON PRIME NOT WORKING AND NETFLIX ALSO WORKING FINE

amazon prime not working any solution


Sent from my A1601 using Tapatalk

Share this post


Link to post
Share on other sites
On 12/12/2017 at 8:40 PM, Blackie said:

Thank you very much Rob for reporting. It's still not bad result for a start, booting from SD card seems to be a problem on many other boxes.

I hope some developers could help to resolve the ethernet issues in the future.

Can you test whether USB 3 port is working full speed?

 

Would appreciate insight into ^^ questions. I've also ordered SCISHION V88 to test out.  

Maybe Rob could also test GbE in Android? I was testing another box recently (S905), where the "supposed to be GbE" port doesn't work at all inside Android nor Linux. Link established, IP received from DHCP, but nothing more works. 

Share this post


Link to post
Share on other sites
On 14/7/2017 at 5:35 PM, Da Alchemist said:

Some Time ago I bought a cheap Z28 TV Box fromGearbest for 27€. I was curious about this chip after I saw a Picture of the Rock64 here on Armbian.  When I first connected the Box it only comes up with 720p Resolution, far away from 4K at all.

 

Some other things happened, Rock64 was send to Devs and Developement seems to become more and more Stable, so it tried to check Ayufans Android Image on this Box. I got me the Android Tools and flashed the Image to the box on a Windows Machine . Adroid came up without Network, (as expected) but seeing this Image Booting made me thnking of trying the a Desktop Image on this Box.

The Android Image can be flashed via Android Tools, but not the Linux Image. To make the Box boot from SDCard it has to be Set to Maskrom Mode. This could be easily done with the Android Tool.

1. Start the Android Tool on Windows

2. Go to Upgrade Firmware

3. Load some Firmware for this Box (the one from Ayufan or some of the originals..)

4. Plug a Male to Male USB Cable to the OTG Port of this Box, while Pressing the Reset Button for ca. 5s

5. Now go to "Erase Flash" , Done the Box is now in MaskRom Mode..

 

Just like always prepare a SD Card with an Image and watch Ubuntu comig up on this Cheapo.

 

I am writing now from this Box and even this is an early Stage of Developement, it looks very promising. (Just found that "Take Screenshots" is not working...)

 

 

i can't put it on maskrom mode... it says waiting for maskrom mode fail...

Share this post


Link to post
Share on other sites
On 1/2/2018 at 2:31 PM, fossxplorer said:

@rob0809, wonder how your box is coming along with Linux while i'm early waiting for my boxes to arrive. ;)

 

Sorry, I haven't had much time to play with it over the holidays.  Maybe in the new year.

Share this post


Link to post
Share on other sites

Just installed this image based on armbian burning it to internal emmc using 

 

sudo ./flash_tool.sh -c rk3328 -p system -i image/ioBroker_Image_Rock64_20171211_xenial.img 
 

 I connected to youtube using my mobile as a usb modem.

 

It seems to have hw acceleration, at least youtube videos play way better than ayufan images. I got to install xubuntu-destop as it comes with no desktop. This image is made by a german company named iobroker over the armbian beta for rock64. Cinnamon or Unity does not complain about software rendering, ethernet seems unconfigured.

 

Remove nodejs and everything on the /opt/iobroker folder.

 

Check it

 

http://www.iobroker.net/docu/?p=7736&lang=en

Share this post


Link to post
Share on other sites
On 1/11/2018 at 8:32 PM, jgb said:

Just installed this image based on armbian burning it to internal emmc using 

 

installed it on what device exactly (pcb label, components, etc)?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

12 12

  • Support the project

    We need your help to stay focused on the project.

    Choose the amount and currency you would like to donate in below.