Sign in to follow this  
heyarne

Problems updating armbian-firmware from 5.30 to 5.35

Recommended Posts

Hi!

I'm running a bananapi and I'm having some trouble updating:

 

root@bananapi:~# apt list --upgradable
Listing... Done
armbian-firmware/jessie 5.35 armhf [upgradable from: 5.30]
N: There is 1 additional version. Please use the '-a' switch to see it
root@bananapi:~# apt list --upgradable -a
Listing... Done
armbian-firmware/jessie 5.35 armhf [upgradable from: 5.30]
armbian-firmware/jessie,now 5.30 armhf [installed,upgradable to: 5.35]
root@bananapi:~# apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  armbian-firmware
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/2,095 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] 
(Reading database ... 75762 files and directories currently installed.)
Preparing to unpack .../armbian-firmware_5.35_all.deb ...
Unpacking armbian-firmware (5.35) over (5.30) ...
dpkg: error processing archive /var/cache/apt/archives/armbian-firmware_5.35_all.deb (--unpack):
 trying to overwrite '/lib/firmware/rt2870.bin', which is also in package firmware-ralink 0.43
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/armbian-firmware_5.35_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

How do I best debug this? Thanks in advance.

Share this post


Link to post
Share on other sites
1 hour ago, heyarne said:

Unpacking armbian-firmware (5.35) over (5.30) ...
dpkg: error processing archive /var/cache/apt/archives/armbian-firmware_5.35_all.deb (--unpack):

===> trying to overwrite '/lib/firmware/rt2870.bin', which is also in package firmware-ralink 0.43

dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/armbian-firmware_5.35_all.deb

How do I best debug this? Thanks in advance.

 

I would try to

apt remove firmware-ralink

then rerun the update

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this