USB device, type HID not detected


Recommended Posts

Hi,

 

i recently installed jessie (vanilla) on a cubietruck.

I have problems with a usb stick to be correctly detected.

It is a rf stick to communicate with Homematic devices (HM-CFG-USB).

 

When I plug it in, I get following messages in syslog:

 

Feb  8 21:34:38 localhost kernel: [ 5043.855985] usb 3-1: new full-speed USB device number 8 using ohci-platform
Feb  8 21:34:38 localhost kernel: [ 5044.079007] usb 3-1: New USB device found, idVendor=1b1f, idProduct=c00f
Feb  8 21:34:38 localhost kernel: [ 5044.079041] usb 3-1: New USB device strings: Mfr=4, Product=14, SerialNumber=36
Feb  8 21:34:38 localhost kernel: [ 5044.079060] usb 3-1: Product: HM-CFG-USB
Feb  8 21:34:38 localhost kernel: [ 5044.079077] usb 3-1: Manufacturer: eQ-3
Feb  8 21:34:38 localhost kernel: [ 5044.079093] usb 3-1: SerialNumber: LEQ0659333
Feb  8 21:34:38 localhost kernel: [ 5044.092021] hid-generic 0003:1B1F:C00F.000A: device has no listeners, quitting
Feb  8 21:34:38 localhost mtp-probe: checking bus 3, device 8: "/sys/devices/platform/soc@01c00000/1c14400.usb/usb3/3-1"
Feb  8 21:34:38 localhost mtp-probe: bus: 3, device: 8 was not an MTP device
 
On raspberry / wheezy I have no problems detecting the stick:
Feb  8 19:56:49 raspberrypi kernel: [4414242.954861] usb 1-1.2: new full-speed USB device number 8 using dwc_otg
Feb  8 19:56:49 raspberrypi kernel: [4414243.059928] usb 1-1.2: New USB device found, idVendor=1b1f, idProduct=c00f
Feb  8 19:56:49 raspberrypi kernel: [4414243.059972] usb 1-1.2: New USB device strings: Mfr=4, Product=14, SerialNumber=36
Feb  8 19:56:49 raspberrypi kernel: [4414243.059991] usb 1-1.2: Product: HM-CFG-USB
Feb  8 19:56:49 raspberrypi kernel: [4414243.060008] usb 1-1.2: Manufacturer: eQ-3
Feb  8 19:56:49 raspberrypi kernel: [4414243.060025] usb 1-1.2: SerialNumber: LEQ0659333
Feb  8 19:56:49 raspberrypi kernel: [4414243.077115] hid-generic 0003:1B1F:C00F.0002: hiddev0,hidraw0: USB HID v1.10 Device [eQ-3 HM-CFG-USB] on usb-20980000.usb-1
.2/input0
 
Could someone help me, please?
 
Thanks!
Martin

 

Link to post
Share on other sites
Armbian is a community driven open source project. Do you like to contribute your code?

On 2/8/2016 at 10:39 PM, zador.blood.stained said:

I added hiddev and hidraw options to mainline kernel config, so this should be fixed with new kernel release.

If you want to test it now, you can try installing prebuilt kernel from this topic (you need to install at least linux-image and linux-dtb packages).

 

I have a similar problem with apcupsd on a Odroid XU4 board, see this topic

 

CONFIG_USB_HIDDEV was disabled on the kernel configuration file, while CONFIG_HIDRAW is already enabled.

I build the kernel with CONFIG_USB_HIDDEV enabled, but it is still not working.

Any ideas?

 

Thanks in advance.

 

P.S. In this case

https://forum.odroid.com/viewtopic.php?f=93&t=28978

enabling CONFIG_USB_HIDDEV was enough

https://github.com/hardkernel/linux/commit/be592282a08a2493692448e365e46b52ac715b3f

 

 

 

Link to post
Share on other sites
Guest
This topic is now closed to further replies.