1 1
latze

SPI activation on nanopi Neo

Recommended Posts

(edited)

Hi @all,

I currently try to build a door-opener with a NanoPi Neo and a MFRC522 Rfid-Module.

Unfortunately I don't get the SPI working.

I loaded the newest Armbian-Debian from the Website:

uname -r = 4.14.18-sunxi

and downloaded the SPI-library for NanoPi:

https://github.com/wertyzp/WiringNP

By using 

armbian-config

I activated "pwm", "sei-add-cs1", "spi-jedec-nor" and "spi-spidev".

The problem:

If I try to activate SPI with

gpio load spi

I get the following error-message:

modprobe: FATAL: Module spi-sun7i not found in directory /lib/modules/4.14.18-sunxi
gpio: Unable to load spi-sun7i

So it seems that wiringNp doesn't use "spi-dev" but "spi-sun7i" and I tried to install it from source from:

https://github.com/OLIMEX/OLINUXINO/blob/master/SOFTWARE/A20/A20-build-3.4.90/spi-sun7i.c

Unfortunately I can't find out how to write the Makefile so that I can compile the .ko-file and install the driver.

Can you help me writing the Makefile or have another idea how I could solve the problem?

 

Thanks in advance and greetings,

Latze

Edited by latze

Share this post


Link to post
Share on other sites
On 5/7/2018 at 2:07 AM, latze said:

Hi @all,

I currently try to build a door-opener with a NanoPi Neo and a MFRC522 Rfid-Module.

Unfortunately I don't get the SPI working.

I loaded the newest Armbian-Debian from the Website:


uname -r = 4.14.18-sunxi

and downloaded the SPI-library for NanoPi:


https://github.com/wertyzp/WiringNP

By using 


armbian-config

I activated "pwm", "sei-add-cs1", "spi-jedec-nor" and "spi-spidev".

The problem:

If I try to activate SPI with


gpio load spi

I get the following error-message:


modprobe: FATAL: Module spi-sun7i not found in directory /lib/modules/4.14.18-sunxi
gpio: Unable to load spi-sun7i

So it seems that wiringNp doesn't use "spi-dev" but "spi-sun7i" and I tried to install it from source from:


https://github.com/OLIMEX/OLINUXINO/blob/master/SOFTWARE/A20/A20-build-3.4.90/spi-sun7i.c

Unfortunately I can't find out how to write the Makefile so that I can compile the .ko-file and install the driver.

Can you help me writing the Makefile or have another idea how I could solve the problem?

 

Thanks in advance and greetings,

Latze

Pay attention to the theme I created, I got it and there I brought libraries that used.

https://forum.armbian.com/topic/7635-rfid-mfrc522-on-nanopi-neo/

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
1 1