1 1
Park Namsu

Orangi pi zero uart error with ARMBIAN 5.38 and 5.32

Recommended Posts

Hi.

I want to use uart on 500000 baudrate.

Before i had used it with ARMBIAN 5.32.

But i had some problems about board temperature.

So, i updated it  brand-new image. it was 5.38. 

and then some packet are crashing or missing frequently. 

 

I used same program for this test.

I only counted received packets.

It works fine with ARMBIAN 5.32 user-built Ubuntu 16.04.2 LTS 4.11.7-sun8i

Received packets are 4500000.

But, it doesn't with ARMBIAN 5.38 stable Ubuntu 16.04.4 LTS 4.14.18-sunxi

Received packets are 4504376.

 

I also checked configuration using "setserial".

 

the differece was only irq number.

 

please i need your help.

what should i check? 

 

 

 

 

 

Share this post


Link to post
Share on other sites

I encountered  the same problem as well.

 

Problem still occurs with the ARMBIAN 5.48.180624 nightly Ubuntu 18.04 LTS 4.17.2-sunxi

I observed some packets getting corrupted. After checking, I observed 00 (one byte)is added to the corrupted packets at random locations of the byte[]

 

Packet corruption does not occur in ARMBIAN 5.32 user-built Ubuntu 16.04.2 LTS 4.11.7-sun8i.

Packet corruption  occur in ARMBIAN 5.38 stable Ubuntu 16.04.4 LTS 4.14.18-sunxi

 

I ran my tests in OPiZero board with same program for /dev/ttyS1 port. All ports has the same configuration except irq

Share this post


Link to post
Share on other sites

I ran some further tests and figured in addition to adding 00 bytes to the packet, some byte are missing from the packets as well.

This happenes both in 4.14.18 and 4.17.2 as well.

 

Now I want to change uart base_baud in Orange Pi and test further.

Can someone advise me on how to change the UART clock please?

https://github.com/OrangePiLibra/OrangePi_H5SDK/issues/17 this place suggests to change u-boot on serial_spl.c file. But I can't find serial_spl.c file in the build folder.

 

According to this article (which is not complete) I tried to change dtb file as well. But I failed.

Can some please advice me on how to approach this problem please?

 

I didn't get any response from sun-xi group unfortunately.

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
1 1