Jump to content
  • 0

Cannot control MIC volume on LIME1


Darryl
 Share

Question

I'm running the latest lime1 armbian (linux 4.14) and am having great difficulty controlling the mic levels.

 

amixer yields:

 

Simple mixer control 'Left Mixer Left DAC',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Power Amplifier',0
  Capabilities: volume volume-joined
  Playback channels: Mono
  Capture channels: Mono
  Limits: 0 - 63
  Mono: 48 [76%] [-15.00dB]
Simple mixer control 'Power Amplifier DAC',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Power Amplifier Mixer',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Power Amplifier Mute',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Right Mixer Left DAC',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Right Mixer Right DAC',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
 

 

which does not include any control for the mic. Using alsamixer a mix control is presented in the capture view, but it appears to be a duplicate of the speaker volume adjusting that instead. Playback and record both work, I am just unable to control the recording volume in anyway. Has anybody else had this issue and been able to get the mic volume working on this platform? I'd really appreciate knowing how you resolved it.

 

 

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hello,

I do have the same efect. No MIC / Linein devices in alsamixer or elsewhere

 

uname -a Linux bananapi 4.14.18-sunxi #24 SMP Fri Feb 9 16:24:32 CET 2018 armv7l GNU/Linux

 

arecord -L

null
    Discard all samples (playback) or generate zero samples (capture)
default:CARD=sun4icodec
    sun4i-codec,
    Default Audio Device
sysdefault:CARD=sun4icodec
    sun4i-codec,
    Default Audio Device
dmix:CARD=sun4icodec,DEV=0
    sun4i-codec,
    Direct sample mixing device
dsnoop:CARD=sun4icodec,DEV=0
    sun4i-codec,
    Direct sample snooping device
hw:CARD=sun4icodec,DEV=0
    sun4i-codec,
    Direct hardware device without any conversions
plughw:CARD=sun4icodec,DEV=0
    sun4i-codec,
    Hardware device with all software conversions

 

I enabled analog-codec with armbian-config. Entry "overlays=analog-codec" in /etc/armbianEnv.txt present

U-Boot says, the overlay is loaded. Reboot sequence

 

lsmod

Module                  Size  Used by
sun4i_gpadc_iio        16384  0
evdev                  20480  1
sun4i_codec            32768  3
snd_soc_core          118784  1 sun4i_codec
snd_pcm_dmaengine      16384  1 snd_soc_core
sun4i_ts               16384  0
snd_pcm                65536  4 snd_pcm_dmaengine,snd_soc_core
ir_lirc_codec          16384  0
lirc_dev               16384  1 ir_lirc_codec
snd_timer              24576  1 snd_pcm
sun4i_gpadc            16384  0
snd                    45056  5 snd_timer,snd_soc_core,snd_pcm
nvmem_sunxi_sid        16384  0
soundcore              16384  1 snd
sunxi_cir              16384  0
sun4i_ss               24576  0
uio_pdrv_genirq        16384  0
uio                    16384  1 uio_pdrv_genirq
bonding                94208  0
brcmfmac              159744  0
brcmutil               16384  1 brcmfmac
cfg80211              376832  1 brcmfmac
rfkill                 20480  2 cfg80211
ip_tables              20480  0
x_tables               20480  1 ip_tables
uas                    20480  0
realtek                16384  1

 

CON1 LINEIN is connected with a audio source. But arecord failes.

For me there seems something is missing in devicetree definitions?

 

regards

Link to comment
Share on other sites

Check forum guidelines to use maximum potential!

  • 0

I have the same problem. Besides i have a LIME1 and Cubieboard2, and i have the same problem in both boards. Armbian mainline Kernel

 

It seems an important fail. A solution can be to use Pulse. With Pulse installed, you can see Master and Capture controls if you type 'amixer'

 

I also think there is probably an error with the devicetree definition. If not, maybe there is a problem in the driver sun4i_codec

 

In 3.4 kernel, i can see:

 

Simple mixer control 'Master',0

  Capabilities: pvolume pvolume-joined penum

  Playback channels: Mono

  Limits: Playback 0 - 63

  Mono: Playback 63 [100%]

Simple mixer control 'Master Capture Mute',0

  Capabilities: pswitch pswitch-joined penum

  Playback channels: Mono

  Mono: Playback [on]

Simple mixer control 'LineL',0

  Capabilities: pswitch pswitch-joined penum

  Playback channels: Mono

  Mono: Playback [on]

Simple mixer control 'LineR',0

  Capabilities: pswitch pswitch-joined penum

  Playback channels: Mono

  Mono: Playback [on]

Simple mixer control 'Linein Pre-AMP',0

  Capabilities: volume volume-joined penum

  Playback channels: Mono

  Capture channels: Mono

  Limits: 0 - 7

  Mono: 4 [57%]

Simple mixer control 'Mic Input Mux',0

  Capabilities: volume volume-joined penum

  Playback channels: Mono

  Capture channels: Mono

  Limits: 0 - 15

  Mono: 0 [0%]

Simple mixer control 'Mic Power',0

  Capabilities: pswitch pswitch-joined penum

  Playback channels: Mono

  Mono: Playback [off]

Simple mixer control 'Mic1 Boost',0

  Capabilities: pswitch pswitch-joined penum

  Playback channels: Mono

  Mono: Playback [on]

Simple mixer control 'Mic1 gain',0

  Capabilities: volume volume-joined penum

  Playback channels: Mono

  Capture channels: Mono

  Limits: 0 - 3

  Mono: 0 [0%]

Simple mixer control 'Mic2 Boost',0

  Capabilities: pswitch pswitch-joined penum

  Playback channels: Mono

  Mono: Playback [off]

Simple mixer control 'Mic2 gain',0

  Capabilities: volume volume-joined penum

  Playback channels: Mono

  Capture channels: Mono

  Limits: 0 - 7

  Mono: 4 [57%]

Simple mixer control 'MicL',0

  Capabilities: volume volume-joined penum

  Playback channels: Mono

  Capture channels: Mono

  Limits: 0 - 3

  Mono: 1 [33%]

Simple mixer control 'MicR',0

  Capabilities: volume volume-joined penum

  Playback channels: Mono

  Capture channels: Mono

  Limits: 0 - 3

  Mono: 3 [100%]

Simple mixer control 'Playback',0

  Capabilities: pswitch pswitch-joined penum

  Playback channels: Mono

  Mono: Playback [off]

Simple mixer control 'Capture',0

  Capabilities: cvolume cvolume-joined penum

  Capture channels: Mono

  Limits: Capture 0 - 7

  Mono: Capture 6 [86%]

Simple mixer control 'ADC Input Mux',0

  Capabilities: volume volume-joined penum

  Playback channels: Mono

  Capture channels: Mono

  Limits: 0 - 7

  Mono: 2 [29%]

Simple mixer control 'Fm output',0

  Capabilities: volume volume-joined penum

  Playback channels: Mono

  Capture channels: Mono

  Limits: 0 - 7

  Mono: 3 [43%]

Simple mixer control 'FmL',0

  Capabilities: pswitch pswitch-joined penum

  Playback channels: Mono

  Mono: Playback [on]

Simple mixer control 'FmR',0

  Capabilities: pswitch pswitch-joined penum

  Playback channels: Mono

  Mono: Playback [on]

Simple mixer control 'LINEIN APM',0

  Capabilities: volume volume-joined penum

  Playback channels: Mono

  Capture channels: Mono

  Limits: 0 - 7

  Mono: 0 [0%]

Simple mixer control 'Ldac Left Mixer',0

  Capabilities: pswitch pswitch-joined penum

  Playback channels: Mono

  Mono: Playback [on]

Simple mixer control 'Ldac Right Mixer',0

  Capabilities: pswitch pswitch-joined penum

  Playback channels: Mono

  Mono: Playback [on]

Simple mixer control 'Left Capture Mute',0

  Capabilities: pswitch pswitch-joined penum

  Playback channels: Mono

  Mono: Playback [off]

Simple mixer control 'MIC output volume',0

  Capabilities: volume volume-joined penum

  Playback channels: Mono

  Capture channels: Mono

  Limits: 0 - 7

  Mono: 3 [43%]

Simple mixer control 'Rdac Right Mixer',0

  Capabilities: pswitch pswitch-joined penum

  Playback channels: Mono

  Mono: Playback [on]

Simple mixer control 'Right Capture Mute',0

  Capabilities: pswitch pswitch-joined penum

  Playback channels: Mono

  Mono: Playback [off]

 

In mainline kernel I can see:

 

Simple mixer control 'Left Mixer Left DAC',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Power Amplifier',0
  Capabilities: volume volume-joined
  Playback channels: Mono
  Capture channels: Mono
  Limits: 0 - 63
  Mono: 45 [71%] [-18.00dB]
Simple mixer control 'Power Amplifier DAC',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Power Amplifier Mixer',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Power Amplifier Mute',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Right Mixer Left DAC',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Right Mixer Right DAC',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]

 

 

Maybe the following link is related to this error:

http://lists.infradead.org/pipermail/linux-arm-kernel/2015-December/392419.html

 

 

 

 

 

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...