1 1
andoru

X11 doesn't start after manual install (XU4)

Recommended Posts

So I wanted to set up an Odroid XU4 as a low-power low-cost NAS and "seedbox" for a personal project, and I wanted to have a GUI that doesn't take too many resources (or spin the fan too much) due to the fact that qBittorrent can't run as a thin client, and I don't want to have to use a WebUI, nor do I want to use a different client (Transmission frequently has security issues, and Deluge is a bit too resource-intensive).

I'm currently using the XU4 headless, and only have it hooked up to LAN, so it's a bit difficult to tell what's going on at system initialisation, and since I'm controlling the device through SSH, I'm unable to manually start X11 after booting and logging in.

I've tried to install the desktop packages through the armbian ncurses setup, but I felt it was a bit bloated (I don't really need compositing or any fancy effects, nor do I need all the features in XFCE, and I have no use of PulseAudio), so I decided to set up my own DE, with OpenBox, and no login manager, just so I could VNC into the XU, and look at qBittorrent. 

So I've installed xorg and it's requirements, also OpenBox, I've set up ~/.xinitrc to start openbox-session, and I've set /etc/X11/Xorg.conf to this:

Section "Device"
    Identifier  "Dummy"
    Driver      "dummy"
    VideoRam    256000
    Option      "IgnoreEDID"    "true"
    Option      "NoDDC" "true"
EndSection

Section "Monitor"
    Identifier  "Monitor"
    HorizSync   15.0-100.0
    VertRefresh 15.0-200.0
EndSection

Section "Screen"
    Identifier  "Screen"
    Monitor     "Monitor"
    Device      "Dummy"
    DefaultDepth    24
    SubSection  "Display"
        Depth   24
        Modes   "1920x1080" "1280x1024"
    EndSubSection
EndSection

But for some reason, X11 doesn't seem to start at all (there are no logs under /var/log/) when I boot the device.

 

I've tried issuing this command after browsing around for a solution:

systemctl set-default graphical.target

But it doesn't seem to have fixed anything.

 

Is there something else that needs to be done in order to tell the OS to run X11 at startup? 

Also, does anyone else know of a more efficient way to do this? VNC seems to cause XU's fan to spin constantly, which I assume means it takes a bit of a toll on the device from what I could tell.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
1 1