1 1
dimraz

Does not install mosquitto.

Recommended Posts

Please help me to understand. When you install, it references incorrect versions of packages.

Spoiler


root@DOM:/etc/apt/sources.list.d# sudo apt-get install mosquitto
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mosquitto : Depends: libssl1.0.0 (>= 1.0.0) but it is not installable
             Depends: libwebsockets3 (>= 1.2) but it is not installable
E: Unable to correct problems, you have held broken packages.
 


How can this be corrected?

 

info

Spoiler

BOARD=orangepiplus
BOARD_NAME="Orange Pi+"
BOARDFAMILY=sun8i
VERSION=5.38
LINUXFAMILY=sunxi
BRANCH=next
ARCH=arm
IMAGE_TYPE=stable
BOARD_TYPE=conf
INITRD_ARCH=arm
 

 

Share this post


Link to post
Share on other sites

Did you edit your /etc/apt/sources.list or did you add additionally any sources?

Which armbian do you use (do you use a armbian distro? - because I never had problems with the sources of armbian)

 

What do you get for a message after?:

sudo apt autoremove && sudo apt autoclean && sudo apt clean

sudo apt-get update
sudo apt-get -f install
sudo apt-get install mosquitto mosquitto-clients

 

 

Edited by Tido
changed to one-liner for cleaning, update

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
1 1