1 1
gleam

ATOP - NETWORK-MANAGER

Recommended Posts

Hi all! :-)

To those who made the excellent work for my oroid!

Well done, very well done!

Well, just one point, maybe:

Sep 08 13:47:55 odroidxu4 systemd[1]: Starting Atop process accounting daemon...
Sep 08 13:47:55 odroidxu4 atopacctd[17567]: /run/pacct_shadow.d: File exists
Sep 08 13:47:55 odroidxu4 systemd[1]: atopacct.service: PID file /run/atopacctd.pid not…ctory
Sep 08 13:47:55 odroidxu4 systemd[1]: Failed to start Atop process accounting daemon.
Sep 08 13:47:55 odroidxu4 systemd[1]: atopacct.service: Unit entered failed state.
Sep 08 13:47:55 odroidxu4 systemd[1]: atopacct.service: Failed with result 'resources'.
Hint: Some lines were ellipsized, use -l to show in full.

But "top" allready works fine so this might be a hint.

Another thing:

Raspian doesn't us this network-manager and is nuch easier for configuration.

Sorry for disturbing.

Share this post


Link to post
Share on other sites

Hi Gleam,

 

I don't understand what you want to express with your posting but,  try the search-box right hand top corner. Search for:  atop

While you read all those postings you will find out, why it is not part of armbian

 

I guess you already tried: htop - which comes with armbian

 

So long

Tido

Share this post


Link to post
Share on other sites

Good question .... I purged atop and still have top ... a miracle .... or something like that-

But I got rid off network-manager and it was a genious idea!

The DHCP of the alcatel-ADSL-mdem ist crap and the *****network-manager noticed each new IP got vrom the modem, didn't

know which one to use and resigned managing.

So I first stopped DHCP-client. a little bir better afterwards.

And finally purged network-menager, although some programs recommended it.

Every machine git its own static IP and now works perfect.

Next switching to IPv6 because neither the modem nor the ISP uses it.

Share this post


Link to post
Share on other sites

Wait a minute, instead of fixing the situation of your main Router, you fix every other device around you?

How inefficient is that !

 

Nicht die Symptome beheben sondern die  Ursache.. http://der-sebi.de/schreibt-ueber/symptome-und-ursachen/

 


Disable network manager (permanently) to avoid it restarting after a reboot
   systemctl disable NetworkManager.service

 

Edited by Tido
nmtui added

Share this post


Link to post
Share on other sites

>systemctl disable NetworkManager.service

Nice!

Good hint!

But it needs not to be disabled for it ist gone :-)

>How inefficient is that !

Nor so much because it can't manage IPv6 which i'm going to use.

So I once will have DHCP never again. Never, never! 

Share this post


Link to post
Share on other sites
5 hours ago, Tido said:

systemctl disable NetworkManager.service

 

Not a good idea as Zador already explained: https://forum.armbian.com/topic/6104-network-manager-woes/?do=findComment&comment=46901 -- people not able to cope with NM should better entirely remove it.

 

2 hours ago, gleam said:

So I once will have DHCP never again. Never, never! 

 

Interesting way to 'spend' your own time. One of the first things I always do at new customers is to stop configuring statically assigned addresses on each server machine to centrally configured static IP addresses via DHCP. If name resolution is set up correctly not even this would be necessary since names are consistent and addresses don't matter anyway...

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
1 1