0
jmandawg

Renegade 1.51Ghz instructions not working

Recommended Posts

Hi, on the renegade page: https://www.armbian.com/renegade/

 

It says we can run this cpu at 1.51Ghz, but when i follow the instructions nothing happens, is there a step i'm missing?:

 

root@renegade:/mnt/config# sed -i "s/MAX_SPEED=.*/MAX_SPEED=1510000/" /etc/default/cpufrequtils 
root@renegade:/mnt/config# service cpufrequtils restart
root@renegade:/mnt/config# cpufreq-set -g performance
root@renegade:/mnt/config# armbianmonitor -m
Stop monitoring using [ctrl]-[c]
Time        CPU    load %cpu %sys %usr %nice %io %irq   CPU  C.St.

12:41:39: 1392MHz  1.37  17%   4%   7%   0%   3%   1% 65.4°C  0/6^C

Is there an updated dtb file or overlay somewhere?

Share this post


Link to post
Share on other sites

The higher available cpufreq OPP are distro independent. It's just the linux-dtb-* package that contains now also the 1.5GHz OPP (no idea whether this is already available via official apt.armbian.com or you need to switch to beta repository)

Share this post


Link to post
Share on other sites

I guess it's not there yet, my dtb points to 4.4.155:

 

root@renegade:/boot# ls -al dtb
lrwxrwxrwx 1 root root 23 Sep 15 16:24 dtb -> dtb-4.4.155-rockchip64/
root@renegade:/boot# lscpu
Architecture:          aarch64
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
Thread(s) per core:    1
Core(s) per socket:    4
Socket(s):             1
Model:                 4
CPU max MHz:           1392.0000
CPU min MHz:           408.0000
BogoMIPS:              48.00
Flags:                 fp asimd evtstrm aes pmull sha1 sha2 crc32

 

Share this post


Link to post
Share on other sites
On 9/15/2018 at 6:42 PM, jmandawg said:

on the renegade page: https://www.armbian.com/renegade/

 

It says we can run this cpu at 1.51Ghz

 

Sorry, I was confused all the time. We only added the 1.4 GHz OPP back then: https://github.com/armbian/build/commit/a79d5932cf21c1c7221bfa6cd036a3f47e506318

 

And even more confusion since Igor added 1.5 GHz later: https://github.com/armbian/build/blob/master/patch/kernel/rockchip64-default/enable-1512mhz-opp.patch

 

Does it work now after updating to 5.60?

Share this post


Link to post
Share on other sites
Start-Date: 2018-09-21  17:34:12
Commandline: apt-get upgrade
Upgrade: armbian-firmware-full:arm64 (5.45, 5.60), linux-u-boot-renegade-default:arm64 (5.59.180915, 5.60), armbian-tools-stretch:arm64 (5.59.180915, 5.60), sunxi-tools:arm64 (1.4.2-2~armbian5.59.180915+1, 1.4.2-2~armbian5.60+1), linux-stretch-root-renegade:arm64 (5.59.180915, 5.60), armbian-config:arm64 (5.59.180915, 5.60), hostapd:arm64 (3:2.6-99~armbian5.59.180915+1, 3:2.6-99~armbian5.60+1)
End-Date: 2018-09-21  17:39:56

I updated and it's stll showing the same info after reboot no 1.51GHz:

 

root@renegade:~# uname -r
4.4.152-rk3328
root@renegade:~# lscpu
Architecture:          aarch64
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
Thread(s) per core:    1
Core(s) per socket:    4
Socket(s):             1
Model:                 4
CPU max MHz:           1392.0000
CPU min MHz:           408.0000
BogoMIPS:              48.00
Flags:                 fp asimd evtstrm aes pmull sha1 sha2 crc32

root@renegade:~# ls -al /boot/dtb
lrwxrwxrwx 1 root root 23 Sep 15 16:24 /boot/dtb -> dtb-4.4.155-rockchip64/

Do i need to switch to nightly development build?  

Share this post


Link to post
Share on other sites
4 hours ago, jmandawg said:

Do i need to switch to nightly development build?  


It should also be in a stable build. Since this feature is not really essential, I will not investigate at this moment why it is not there. We provide nightly builds and build tools. Use that first.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
0