1 1
junnikokuki

Orange Pi Lite2 wireless support

Recommended Posts

Hi,

I recently read from github testings of orange pi lite2 testing that wireless is working. But I download from the official website of https://dl.armbian.com/orangepilite2/Debian_stretch_dev_nightly.7z(built 0824) and burn it, it starts, but the wireless is missing. I also read that the firmware added ap6255 wireless driver, so I download https://beta.armbian.com/pool/main/a/armbian-firmware-full/armbian-firmware-full_5.59.180915_all.deb and installed it. After reboot, the wireless is still missing. So the support of wireless is built-in or usb? Should I build armbian myself with the lastest code to support the built-in wireless? Thank you.

Share this post


Link to post
Share on other sites

So when will the automate nightly build run? I think wireless support is a big improvement for orange pi lite2 version. It deserves a new build.

Share this post


Link to post
Share on other sites

 

5 hours ago, junnikokuki said:

So when will the automate nightly build run?


Never, since it is not enabled for this board.
 

5 hours ago, junnikokuki said:

It deserves a new build.

 

There is no end-user support for boards/kernels that are still under development because it is too expensive. We barely manage to provide free support for stable builds.

 

We make nightly images for developers and development purposes. 

 

Share this post


Link to post
Share on other sites
33 minutes ago, Igor said:

 


Never, since it is not enabled for this board.
 

 

There is no end-user support for boards/kernels that are still under development because it is too expensive. We barely manage to provide free support for stable builds.

 

We make nightly images for developers and development purposes. 

 

Yeah, I know, it is a wip board. I do not intend to act as an end user, but a tester, only. 

 

 

 

Share this post


Link to post
Share on other sites
20 minutes ago, junnikokuki said:

So I should set 

 

CLI_BETA_TARGET="bionic,stretch:dev"

DESKTOP_BETA_TARGET="bionic,stretch:dev"

 

and then request a pull request?

 


Only CLI images. We don't need the desktop for now.

 

CLI_BETA_TARGET="bionic,stretch:dev"

Share this post


Link to post
Share on other sites
On 9/18/2018 at 1:56 AM, Igor said:


Only CLI images. We don't need the desktop for now.

 

CLI_BETA_TARGET="bionic,stretch:dev"

 

Sorry for testing late, just back from vocation.

The new nightly build is unable to get to the login step.

 

The Armbian_5.59.180824_Orangepilite2_Debian_stretch_dev_4.18.0-rc7.7z, which is able to login, will show this:

 

WechatIMG443.thumb.jpeg.cbcc859ecb575e3d797218da638c9ffa.jpeg

 

and then a black screen with a cursor blinking, then after a long time, the login message showed.

 

The Armbian_5.60.180923_Orangepilite2_Debian_stretch_dev_4.18.9.7z bulid, along with 0918/4.18.8 build, will show:

 

WechatIMG444.thumb.jpeg.27104ba75b78f257a2d61fc7f1a7ab0e.jpeg

 

and then the hdmi screen lost signal.

 

Seems that the simplefb node not found.

 

Other debug messages missing, still waiting for my usb2ttl cable.

 

 

 

Share this post


Link to post
Share on other sites

Unbootable kernel with OPi One Plus confirmed, runs into panic, reading from UART. There is something wrong with the later 4.18.x kernel. 4.18.0-rc7 from @Icenowy sources working well.

 

But this kind a runs off topic I guess ;)

Share this post


Link to post
Share on other sites
34 minutes ago, Werner said:

Unbootable kernel with OPi One Plus confirmed, runs into panic, reading from UART. There is something wrong with the later 4.18.x kernel. 4.18.0-rc7 from @Icenowy sources working well.

 

But this kind a runs off topic I guess ;)


I'll try to bring it up in 4.19.y ... some basic support is getting mainlined and it will be less troublesome. I hope.

Share this post


Link to post
Share on other sites

 

6 minutes ago, Igor said:


I'll try to bring it up in 4.19.y ... some basic support is getting mainlined and it will be less troublesome. I hope.

I am ready to give it a shot whenever you are ready -_-

Share this post


Link to post
Share on other sites
13 hours ago, junnikokuki said:

Other debug messages missing, still waiting for my usb2ttl cable.

or you use just another SBC... (see: the silly approach) :lol:

 

Share this post


Link to post
Share on other sites
6 hours ago, data said:

Since nightly builds are now available, what else do I need in order to enable ap6255 wireless?


If the image boots, it should work out of the box.

Share this post


Link to post
Share on other sites

The ubuntu images boot, but wifi does not. :(

First I tried the 0923 nighly, then upgraded to 0926 last night but wifi does not show up.

I found nothing related to AP6255 nor Broadcom in dmesg.
 

I will try the latest debian later today.

Share this post


Link to post
Share on other sites

 

2 hours ago, data said:

The ubuntu images boot, but wifi does not. :(

First I tried the 0923 nighly, then upgraded to 0926 last night but wifi does not show up.

I found nothing related to AP6255 nor Broadcom in dmesg.
 

I will try the latest debian later today.

The kernel is the same, just the OS on top is different.

Share this post


Link to post
Share on other sites
5 hours ago, data said:

I found nothing related to AP6255 nor Broadcom in dmesg.

Which kernel are you using ? what are the timestamps of those kernel files in /boot ? Are they newer than Sept.7th ?

Did you do the following "grep" on "dmesg" ?

dmesg | grep -i mmc
dmesg | grep -i sdio
dmesg | grep -i brcm

 

Share this post


Link to post
Share on other sites

See all details below:

 

  ___                               ____  _   _     _ _         ____  
 / _ \ _ __ __ _ _ __   __ _  ___  |  _ \(_) | |   (_) |_ ___  |___ \
| | | | '__/ _` | '_ \ / _` |/ _ \ | |_) | | | |   | | __/ _ \   __) |
| |_| | | | (_| | | | | (_| |  __/ |  __/| | | |___| | ||  __/  / __/
 \___/|_|  \__,_|_| |_|\__, |\___| |_|   |_| |_____|_|\__\___| |_____|
                       |___/                                          

Welcome to ARMBIAN 5.61.180926 nightly Ubuntu 18.04.1 LTS 4.18.10-sunxi64   
System load:   0.83 0.32 0.12      Up time:       1 min        
Memory usage:  7 % of 994MB      IP:            10.1.1.162 10.1.1.157
CPU temp:      31°C               
Usage of /:    4% of 29G        

[ General system configuration (beta): armbian-config ]

Last login: Wed Sep 26 20:51:01 2018

root@orangepilite2:~# dmesg |grep -i mmc
[    0.892184] sunxi-mmc 4020000.mmc: could not find pctldev for node /soc/pinctrl@300b000/mmc0-pins, deferring probe
[    0.892214] sunxi-mmc 4022000.mmc: could not find pctldev for node /soc/pinctrl@300b000/mmc2-pins, deferring probe
[    1.118542] sunxi-mmc 4020000.mmc: Got CD GPIO
[    1.143911] sunxi-mmc 4020000.mmc: base:0x(____ptrval____) irq:11
[    1.170113] sunxi-mmc 4022000.mmc: base:0x(____ptrval____) irq:12
[    1.193092] mmc0: host does not support reading read-only switch, assuming write-enable
[    1.197899] mmc0: new high speed SDHC card at address 0007
[    1.198880] mmcblk0: mmc0:0007 SDCIT 29.2 GiB
[    1.200152]  mmcblk0: p1
[    3.368126] EXT4-fs (mmcblk0p1): mounted filesystem with writeback data mode. Opts: (null)
[    5.610572] EXT4-fs (mmcblk0p1): re-mounted. Opts: commit=600,errors=remount-ro
root@orangepilite2:~# dmesg | grep -i sdio
root@orangepilite2:~# dmesg | grep -i brcm

root@orangepilite2:~# uname -a
Linux orangepilite2 4.18.10-sunxi64 #292 SMP Wed Sep 26 16:53:32 CEST 2018 aarch64 aarch64 aarch64 GNU/Linux
root@orangepilite2:~# ls -la /boot
total 33304
drwxr-xr-x  3 root root     4096 Sep 26 21:31 .
drwxr-xr-x 22 root root     4096 Sep 23 23:12 ..
-rw-r--r--  1 root root      165 Sep 26 21:31 armbianEnv.txt
-rw-r--r--  1 root root      165 Sep 26 21:31 armbianEnv.txte
-rw-r--r--  1 root root     1536 Sep 23 23:13 armbian_first_run.txt.template
-rw-r--r--  1 root root   230454 Sep 23 23:13 boot.bmp
-rw-r--r--  1 root root     3018 Sep 23 23:11 boot.cmd
-rw-r--r--  1 root root     4882 Sep 23 23:13 boot-desktop.png
-rw-rw-r--  1 root root     3090 Sep 23 23:14 boot.scr
-rw-r--r--  1 root root   147050 Sep 26 14:53 config-4.18.10-sunxi64
lrwxrwxrwx  1 root root       19 Sep 26 21:00 dtb -> dtb-4.18.10-sunxi64
drwxr-xr-x  3 root root     4096 Sep 26 20:58 dtb-4.18.10-sunxi64
lrwxrwxrwx  1 root root       18 Sep 23 23:12 dtb.old -> dtb-4.18.9-sunxi64
lrwxrwxrwx  1 root root       23 Sep 26 20:59 Image -> vmlinuz-4.18.10-sunxi64
-rw-r--r--  1 root root  8407047 Sep 26 21:00 initrd.img-4.18.10-sunxi64
-rw-r--r--  1 root root        0 Sep 26 20:59 .next
-rw-r--r--  1 root root  3011411 Sep 26 14:53 System.map-4.18.10-sunxi64
lrwxrwxrwx  1 root root       23 Sep 26 21:00 uInitrd -> uInitrd-4.18.10-sunxi64
-rw-r--r--  1 root root  8407111 Sep 26 21:00 uInitrd-4.18.10-sunxi64
-rwxr-xr-x  1 root root 13844488 Sep 26 14:53 vmlinuz-4.18.10-sunxi64
root@orangepilite2:~#

 

Share this post


Link to post
Share on other sites
32 minutes ago, data said:

See all details below:

That is really odd !

@Igor is this nightly has been built differently from the normal WIP DEV build process ?

First odd thing is the kernel 4.18.10-sunxi64, while Armbian config/sources/sun50iw6.conf still pointing to Icenowy's h6-integrate-2-ugly branch, which is a 4.18.0-rc7 ...

Second odd thing, the "dmesg | grep -i mmc" should have shown "mmc1" probing with finally "mmc1: new high speed SDIO card at address 0001", but it is not there, so I presume that my Sept.7th DTS patch is not in this build ...

 

 

Share this post


Link to post
Share on other sites
11 hours ago, martinayotte said:

is this nightly has been built differently from the normal WIP DEV build process ?


Possible. Let me check this during the day.

Share this post


Link to post
Share on other sites

We have a few problems here. First is that sunxi64-next branch was reverted back to 4.14.y since 4.18.y just not ready yet ... in 4.14.y there is no support for H6 ... I can only switch to sunx64-dev, where the board boots, but without http://ix.io/1nK7 HDMI, WiFi and USB3 seem also not to function properly.


@martinayotte
Should I apply this?

diff --git a/config/sources/sun50iw6.conf b/config/sources/sun50iw6.conf
index 16834529..692bb292 100644
--- a/config/sources/sun50iw6.conf
+++ b/config/sources/sun50iw6.conf
@@ -31,6 +31,13 @@ case $BRANCH in
        KERNELDIR=$MAINLINE_KERNEL_DIR
        KERNEL_USE_GCC='> 7.0'
        KERNELPATCHDIR='sunxi-dev-h6'
+
+       KERNELSOURCE=$MAINLINE_KERNEL_SOURCE
+       KERNELBRANCH='branch:linux-4.18.y'
+       KERNELDIR=$MAINLINE_KERNEL_DIR
+       KERNEL_USE_GCC='> 7.0'
+       KERNELPATCHDIR='sunxi-dev'
+
        ;;
 esac
 
diff --git a/patch/kernel/sunxi-dev/p-board-h6-add-THS.patch b/patch/kernel/sunxi-dev/p-board-h6-add-THS.patch
index 8d59cca2..631a40f8 100644
--- a/patch/kernel/sunxi-dev/p-board-h6-add-THS.patch
+++ b/patch/kernel/sunxi-dev/p-board-h6-add-THS.patch
@@ -1012,7 +1012,7 @@ diff --git a/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi b/arch/arm64/boot/dts/
 index 000a681fb515..bec8c4a46ec7 100644
 --- a/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi
 +++ b/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi
-@@ -41,6 +41,32 @@
+@@ -41,6 +41,30 @@
                        opp-microvolt = <880000>;
                        clock-latency-ns = <244144>; /* 8 32k periods */
                };

 

Share this post


Link to post
Share on other sites

Same here.

I am using an external USB3 - Gigabit Ethernet (ASIX AX88179 USB 3.0 Gigabit Ethernet) with no issues so far.

Share this post


Link to post
Share on other sites
20 minutes ago, junnikokuki said:

Mmmmmm, I don't know why have to revert, but 4.18.0 rc7 works well except wifi.


Because that branch is temporarily development branch with a purpose to develop a few things. We only have two choices here - switch to current 4.18.y, say goodbye to HDMI for a while and fix other things, wifi perhaps ... or wait until HDMI is not mainlined. Other options are too expensive.

I have to remind you that this board is under development and regressions are possible. Some are intended, some not.

Share this post


Link to post
Share on other sites
10 minutes ago, Igor said:


Because that branch is temporarily development branch with a purpose to develop a few things. We only have two choices here - switch to current 4.18.y, say goodbye to HDMI for a while and fix other things, wifi perhaps ... or wait until HDMI is not mainlined. Other options are too expensive.

I have to remind you that this board is under development and regressions are possible. Some are intended, some not.

 

Byebye hdmi.

Share this post


Link to post
Share on other sites
6 hours ago, Igor said:

Should I apply this?

I don't know since I was using the current config with Icenowy's ugly branch.

I will have to check if my previous WiFi patch will still be valid when used with Mainline 4.18.y ...

 

Share this post


Link to post
Share on other sites
1 1