Jump to content

Problems with Pi Hole on Orange Pi PC


Goskum
 Share

Recommended Posts

I've been testing Pi Hole for a few days on an Orange Pi PC with ARMBIAN jessie, connected to the network by the ethernet port.

Pi Hole which is the last thing I installed. A few years ago I have OPi PC as UPnP server, VPN, DHCP, print, samba, transmission, jdownloader, BtSync, and something else that now I do not fall (curiously I did not have it as a server dns), without problems of operation since I am using
Since I installed Pi Hole, if the ethernet connection loses link for a moment, for example because the router reboots, the connection stays fried, it is not able to lift when the link returns. This if I turn over the image prior to installing Pi Hole, it does not happen, at the moment I reinstall it it happens again, so I'm pretty clear that it's a pi hole problem.


Anyone else has happened? Does anyone know how to fix it? Thank you.

Link to comment
Share on other sites

Search Before Posting!

Sorry, I was disconnected for a day.

 

Here is the log:

 

http://sprunge.us/63L1hT

 

Finally y did a fresh install of Armbian Strech, configuring all the servers again. I have two OpiPC, one v1.2 and the other v1.3. I did the installation over v1.3, becuse the other is the one I use as server and is in an enclosure with difficult access.

Once everything was configured and tested, I changed the microSD card to the OPiPC v 1.2. What is my surprise, that in the same operating conditions, in v1.2 loses the network connection within a few seconds of starting. If I reconnect the network cable, it has a connection for a few seconds and loses it again.
Finally I have definitively changed the v1.3 for the v1.2, working for now without apparent problems.

You can see "armbianmonitor -u" here:
http://ix.io/1nVD

Could it be that the network card has been damaged?

 

I think not, if I use an image in opipc v1.2 that worked well with armbian jessie, there are no network problems. you can take a look at:

http://sprunge.us/DyusNf

Can it be a problem because of the MAC change?

Thank you

 

Edited by Goskum
add information
Link to comment
Share on other sites

First question is solved.

There was a conflic (i think so) with NetworkManager, it was not managing eth0.

 

I had configure eth0 in /etc/network/interfaces with a static ip. After installation of Pi Hole, say to use that ip beacuse it needs an static ip, when i do that everything becomes unstable. Whe reboot de opi, it get static ip, if loose the ethernet link, it get dhcp ip (wtf???).

 

solved editing /etc/NetworkManager/NetworkManager.conf and change managed=false by managed=true

 

After a reboot, go to "armbian-config" and configure static ip in network. After that, edit /etc/network/interfaces and change the content by:

 

source /etc/network/interfaces.d/*
# Network is managed by Network manager
auto eth0
auto lo
iface lo inet loopback

 

After the next restart everything works correctly again, even disconnecting / connecting the network cable.

 

Now my question is what happens with the change of card between the versions of Opi with armbian strech.

There may be a problem with MACs, are there incompatibility problems between v.12 and v1.3?

 

Thanks.

 

Sorry for my english.... :(

 

 

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...