Jump to content

The list of models that are running Armbian (Amlogic, Rockchip, Allwinner etc)

Recommended Posts

This theme is designed to help potential users with the selection of equipment to run Armbian on TV boxes and other devices with ARM chips. I propose to leave here information about specific models, with a description of the technical parameters of the equipment, which specific versions of Armbian images and what settings or additional steps have been launched.


Pay attention. In this thread are only a good or not run the system on specific models TV box. All discussions and questions, post in other topics.

Link to comment
Share on other sites

  • Tido changed the title to The list of models that are running Armbian (Amlogic, Rockchip etc)
  • balbes150 pinned this topic

Nexbox a95x(soc amlogic s905 ram 1 storage 8)

All image with kernel 3.14 work with generic gxbb_p200.dtb(old u-boot). Don't have now this box, so don't have opportunity check mainline.  It have some exotic wi-fi module without open sources drivers, so no wi-fi.


Sunvell T95X(soc amlogic s905x ram 2 storage 8).

All image with kernel 3.14 and mainline. With stock firmware don't need manipulate with .dtb files(3.14 kernel), for mainline need generic p212 dtb. Wi-fi  sci9082c, didn't test.


It don't have open sources drivers...



Link to comment
Share on other sites

I'm currently running a Beelink GT1 ultimate (S912, 3Go DDR4, 32Go) with your armbian 5.37 based on 3.14.29 debian stretch without specifying any dtb file.  It is used as a server with openmediavault and homeassistant. I'm running armbian from sd card.

I just made upgrades and got armbian-config 5.64 with an uptime of 70 days.

Link to comment
Share on other sites

I'm using scshion v88 pro, s905x, 1gb ram.

It works great with all builds i tried (in latest builds with 4.x kernel there is no wifi, i never had time to compile drivers for RTL8189ES). MBR partition table also works with latest builds.

Still android 7.1 (installed version for nexbox a95x) is much faster for multimedia and until we get fluid youtube in chromium i will stick with android.

Edited by zogu
Link to comment
Share on other sites

Caidao T1 - s905x 2gb ram



ARMBIAN 5.62 user-built Ubuntu 18.04.1 LTS 4.18.7-aml-s9xxx

ARMBIAN 5.60 user-built Ubuntu 18.04.1 LTS 4.18.7-aml-s9xxx (non-desktop) +xserver-xorg+xinit+pulseaudio+x2goclient

Armbian_5.84_Aml-s905_Ubuntu_bionic_default_5.1.0-rc1_20190507 meson-gxl-s905x-p212 xserver-xorg+xinit+pulseaudio+x2goclient



S11 TV Box - s905 1gb ram





ARMBIAN 5.60 user-built Ubuntu 18.04.1 LTS 4.18.7-aml-s9xxx

ARMBIAN 5.64 user-built Ubuntu 18.04.1 LTS 4.19.0-rc7-aml-s9xxx 

Armbian_5.77-Aml_s905_Ubuntu_bionic_default_5.0.2_20190401 x2goclient works with sound


Armbian_5.90_Aml-s905_Ubuntu_bionic_default_5.1.0_desktop_20190701 wifi works







BM8 Pro - s912 2gb ram



Armbian_5.67_Aml-s9xxx_Ubuntu_bionic_default_4.19.6_desktop_20181205 +compton intermittent eth

Fix: https://patchwork.kernel.org/patch/10712159/

Armbian_5.77_Aml-s912_Ubuntu_bionic_default_5.0.2_20190318 x2goclient works with sound


running x2goclient via eth connecting to Scientific Linux 7.5 MATE desktop

.xinitrc: x2goclient -geometry 1980x1080 --maximize --thinclient --session=FIRST

/lib/systemd/system/getty@.service: ExecStart=-/sbin/agetty --noclear -a amirul %I $TERM

~/.profile: startx





A5X Max - RK3328 4gb ram


ARMBIAN 5.64 user-built Ubuntu 18.04.1 LTS 4.4.143-rk3328-tv +compton

ARMBIAN 5.67 user-built Ubuntu 18.04.1 LTS 4.4.143-rk3328-tv 20181203 +compton



fine with Kingston DataTraveller 100 G3 128Gb stick

To get 1.51GHz with correct dtb, MAX_SPEED=1512000 in /etc/default/cpufrequtils. Temp upto 83 degrees



Scishion V99 Star - rk3368 octacore 2gb ram


Haven't found a way to boot sdcard yet


T95Z Plus - s912 octacore 3gb ram



Armbian_5.67_Aml-s9xxx_Ubuntu_bionic_default_4.19.7_desktop_20181218, patched meson-gxm-q200.dtb

Armbian_5.71_Aml-s912_Ubuntu_bionic_default_4.20.2_desktop_20190122, meson-gxm-q200 as is


Intermittent USB with Kingston DataTraveller 100 G3 128Gb stick. Maybe try a 3A power adapter? (no change)- use powered HDD docking


Armbian_5.90_Aml-s905_Ubuntu_bionic_default_5.1.0_desktop_20190701 usb stick flaky


TX9 Pro - s912 octacore 3gb ram








fine with unpowered Kingston DataTraveller 100 G3 128Gb usb stick

echo 'on' > '/sys/bus/usb/devices/1-1/power/control' # get rid of annoying mouse glitches



T9 - RK3328 4gb ram


Armbian_5.72_Rk3328-tv_Ubuntu_bionic_default_4.4.154_desktop_20190123.img rk3328-evb.dtb

Boots via SD+USB method but no kb/mouse


rk3328-t9.dtb by @hexdump boots everything except bluetooth


MX10 - RK3328 4Gb ram



Armbian_5.74_Rk3328-tv_Ubuntu_bionic_default_4.4.154_desktop_20190208 rk3328-mx10-fast.dtb

set-default-sink alsa_output.platform-hdmi-sound.stereo-fallback in /etc/pulse/default.pa for hdmi sound

Cpu Temp hits 101 C (!) smooth desktop

caseless, Cpu Temp in the 80s at full load


Magicsee N6 max RK3399 6-core 4Gb ram






All works except bluetooth, good fullscreen video cpu temp in the 80's, excellent desktop

Discovered wifi device not ready, fix by using /lib/firmware/brcm from 4.86

media-rk3399_1.0 best with modesetting no accel, which is as per original. Desktop icons became invisible with compositing

Armbian_5.88_Rk3399-tv_Ubuntu_disco_default_4.4.154_20190612 a bit rough round the edges, prefer bionic



Armbian_5.96_Rk3399-tv_Ubuntu_bionic_default_4.4.154_desktop_20190913 cpu 1.7 & 2.18Ghz

Armbian_20.02.0-rc1.030_Arm-64_bionic_current_5.5.0-rc6_desktop_20200129 rk3399-rock-pi-4.dtb

Link to comment
Share on other sites

Tanix TX3 mini 2GB RAM (S905W)

5.41.1 Ubuntu Xenial 3.14.29 icewm 20180406: everything working, boot from SD, system on HDD


A5X Max 4GB RAM (RK3328)

5.62 Ubuntu Bionic 4.4.143 desktop 20181014: rk3328-evb.dtb, boot from SD, system on HDD, just started testing, wifi and audio not working yet, ethernet okay.


2018-12-19: audio is working.


5.91 Ubuntu Bionic 4.4.154 desktop 20190726: rk3328-mx10-fast.dtb, boot from SD, system on HDD, everything working so far, ethernet, wifi, audio. Playing Test.mp4 on full screen runs very hot, around 93°C,  normal computing tasks are very fluid.


MX10 4GB RAM (RK3328)

5.74 Ubuntu Bionic 4.4.154 desktop 20190202: rk3328-mx10.dtb, boot from SD, system on HDD. As noted elsewhere, the newer models come with the SSV6051 wireless chipset, everything else working except for wifi.


X96Max+ 4GB RAM (S905X3)

20.09 Focal 5.8.7 desktop 20200911: meson-sm1-sei610-ethfix.dtb. Ethernet still at 100Mbps, no wifi, no front display, possibly more things missing. Haven't played with it yet, will try to get them all to work. But Armbian is running solidly.


TX9S 2GB RAM (S912)

20.09 Focal 5.8.7 desktop 20200911: meson-gxm-vega-s96.dtb: everything working (Gigabit, wifi, sound, etc). Very nice box, well designed, excellent air flow, desktop works nicely.

Link to comment
Share on other sites

Old Sunvell R69 just boot with proper microSD card (in my case boot directly with Toshiba Exceria but not but with Samsung or Sandisk).

I'm using images shared in Google Drive from this post 

Sunvell R69 with Allwinner H2+

Running ARMBIAN 5.67 with kernel 4.14.81 
from internal eMMC

HDMI at 1080p 24fps

Wi-Fi OK,

Ethernet OK



Link to comment
Share on other sites

The first great thing @balbes150


Quintaix Q912 , S912 , 3g , 32 rom , in the pendriver SankDisk Ultra 32g  , proved in the microsd samsung evo 64 and SSD 60g kingston.

3.14.29 dtb specific q912_otg.dtb  = all work hdmi 1080p


4.19.7 and 4.20.0 meson-gxm-q200.dtb = bluetooth no work , I started in dvi mode instead of hdmi, and it's weird since I turn off and turn on the monitor and it goes into hdmi mode, and tried everything that occurred to me but nothing worked (if someone has any ideas?). It is a 24 p full hd tv, but even stranger than on the TV in the living room if it works correctly.
In the version 4.21 of the kernel there are changes in the hdmi to see if I am lucky, otherwise I will have to continue with the 3.14.29 that goes phenomenal.




Captura de pantalla_2018-12-29_20-34-17.png

Link to comment
Share on other sites

I am using a Phicomm N1

Armbian runs well on it.

CPU: Amlogic S905D, ARM Cortex-A53, Quad Core 2GHz

GPU: ARM Mali™-450, 4K@60fps Hardware acceleration support, HDMI 2.0

RAM: K4B4G1646E, DDR3-1866MHz 512MB*4=2GB


Port: 1*HDMI 2.0; 2*USB2.0; 1*Gigabit Ethernet

Power Adapter: Input 110-240V~50/60Hz AC; Output 12V/2A DC

Ethernet: RTL8211F Gigabit Ethernet

WIFI/Bluetooth: CYW43455 (same as Raspberry Pi 3B+) 2.4G/5G WiFi IEEE 802.11n/ac with Integrated Bluetooth 4.1


and a Phicomm T1

CPU: Amlogic S912, ARM Cortex-A53, Octa Core 1.5GHz

GPU: ARM Mali™-820, 4K UHD, DOLBY H.265(HEVC)



Port: 1*HDMI 2.0; 1*USB2.0; 100m Ethernet

Power Adapter: Input 110-240V~50/60Hz AC; Output 5V/2A DC

WIFI/Bluetooth: 2.4G/5G WiFi IEEE 802.11n/ac with Integrated Bluetooth 4.1

【Remark: I cannot find a specified DTB file for this device】


and there is another device to recommend.  ZTE9 FunBox.

I hope this box will be supported by Armbian Linux.

The FunBox is powered by NVIDIA’s Tegra4 processor, based on the A15 architecture, and the superior graphics performance is delivered by a 72-core GeForce graphics processor with 2GB DDR3L memory and 8GB of Flash memory.

The specifications make the FunBox the highest performance home entertainment console in 2014.




Edited by Bangliang Shen
Link to comment
Share on other sites

Beelink A1 (rk3328, 4GB ram, 32GB emmc)

Tested with Armbian_5.67_Rk3328-tv_Debian_stretch_default_4.4.154_desktop_20181227.img.xz. Boot with rk3328-evb.dtb, but have to modify some entries to make ethernet and usb2 work.

Link to comment
Share on other sites

On 2/17/2019 at 10:57 PM, Mulder said:

Can you pleae tell me what is working (USB3.0, USB2.0, GBIT LAN, 2.4/5.0 MHz WIFI, Blue Tooth, RAM, ...)? Can you please upload your dtb file?

What work so far:

  • USB2.0/USB3.0
  • Gigabit LAN
  • Wifi both 2.4/5.0 Mhz

What not work:

  • No bluetooth

And I don't know what RAM you mean, I can see mine 4GB but I don't know about the speed etc.

I compiled the wifi driver from this repo. Or you can use the file below to "sudo make install" if you're running current linux kernel (4.4.154). You can see in the attached tar.gz, I only modified "Makefile" a few entries. And also, check the DTB and DTS file below.


I can't commend about stability of this box as I haven't run it continuously, because I always reboot it when the attached USB3 external SSD error. 




Link to comment
Share on other sites

Mecool Km8-P 1G/8G, using Armbian 5.44 with 3.14.29 kernel works fine as Ubuntu 18.04.2 server.


VERY IMPORTANT. If you have a newer Km8-P box with Android 7.1, be advised that u-boot as shipped will not boot any 4.xx or 5.xx kernel (but boots kernel 3.14.29 without problems). You have to revert to an older Android image with Android 6.0 if you want to try any Armbian version > 5.44, check the 4pda thread on Km8-P for firmware images. You can flash the older firmware using the SD card method.

Link to comment
Share on other sites

Tested Beelink A1 (rk3328, 4GB ram, 16GB emmc) with dtb provided by raksan in this thread. Booted from SD card.

Bluetooth not working, and did not test installation to eMMC. Otherwise looks good.

Image tested "Armbian_5.76_Rk3328-tv_Debian_stretch_default_4.4.154_20190306.img"


Edited by Aleksejs
added some details
Link to comment
Share on other sites

TX3 mini - a (2gb 32gb)



All good, Audio, bt, internet, usb-tethering, bluetooth hotspot. USB keyboard/ mouse works perfect.

No overheating issues, max 50.3c on 1hour 98% cpu-load :D



Link to comment
Share on other sites

Relating to the T95Z Max - s912 octacore 3gb ram - purchased in May, 2019 from Amazon.


I can get current Armbian releases to boot fine except it appears that the network interface doesn't come up with the standard release vtb or g200 vtb file.


Bluetooth, Wireless, USB (even see USB 3.0 now) works.  Display does not show when booting these in Armbian.



Link to comment
Share on other sites

MagicSee N5 Max (Amlogix S905x2), 4GB RAM, 64GB eMMC


Image: Armbian_5.89_Aml-s905_Ubuntu_bionic_dev_5.2.0-rc4_desktop_20190621


Boot: from USB key, had to use Android Backup/Update utility to boot, not yet installed on eMMC


Three dtbs working (sort-of):

  1. meson-g12a-x96-max.dtb -- boots, ethernet dead, wifi works initially but has huge error rate and eventually hangs the box, bluetooth, audio untested
  2. meson-g12a-x96-max-rmii.dtb -- same as (1)
  3. meson-g12b-khadas-vim3.dtb -- boots, ethernet working (appears to be 1Gbit), wifi not working, bluetooth, audio untested

Note that this is a fairly low power box and will run off a 2A USB charger. I was even able to get it to boot on power from my iPad Pro 2018 (USB-C).

Link to comment
Share on other sites

H96 Max X2 (with S905X2 cpu) 4GB Ram ad 32GB Emmc


I purchased this box thinking I was getting an X96 Max (the naming of all these different boxes is very confusing).  But it turns out that it works well with current builds of balbes150's Armbian.  It works with the meson-g12a-x96-max-rmii.dtb.  It works well installed to eMMC.  The wifi does not work, and I haven't tried bluetooth or hdmi audio.

Link to comment
Share on other sites

Tanix TX9 Pro


DTB used: meson-gxm-q200.dtb


Everything works except:


-Shutdown (act as Restart)

-IR (remote doesnt work and IR packages fail to install)

-VFD (front display stuck on boot, will try to use OpenVFD and will update)

Edited by ktk
Fogot some things that didnt work
Link to comment
Share on other sites

I am using Magicsee Iron TV box. It has Amlogic S905x 2GB RAM.

Armbian_5.78_Aml-s905_Ubuntu_bionic_default_5.1.0-rc1_desktop_20190409 works.


Main issue is Wi-Fi module not detected.

I have problem finding kernel headers to compile the TRL8189es module.


Link to comment
Share on other sites

I have working Amlogic S805, 2GB RAM and 8GB NAND flash (like this one: https://www.aliexpress.com/item/32476254383.html )


Booting with Armbian_5.67_Aml-s805_Debian_stretch_default_3.10.108_desktop_20181207.img with meson8b_m201_1G.dtb from Samsung 32GB uSD card.

RTL8723BS working after modprobe 8723bs command

Only 1GB RAM visible to armbian.


Does anybody have dtb (dts) for this device with 2GB in device tree



Link to comment
Share on other sites

I just received a new TX3 box with the s905x3 chipset.  I was able to successfully install Armbian_5.99_Aml-g12_Ubuntu_bionic_dev_5.4.0-rc6_20191110.img using the meson-sm1-sei610.dtb

The box boots with HDMI and ethernet working.  No WIFI or Bluetooth.

I was able to install on both an SD card and internal mmc.

I haven't yet tried running a GUI desktop.

I also tried using the dtb from 5.4 in a 5.3 environment and that does not boot.  So it would appear that 5.4 is the first kernel version that supports the s905x3 chipset.

Link to comment
Share on other sites

BestTV R3300-L

CPU: S905L
RAM: Samsung K4B4G1646E-BCMA 512MB * 2 = 1GB
ROM: Samsung KLM8G1WEPD-B031 8GB eMMC * 1 = 8GB
USB2.0 * 1, MicroUSB * 1, AV * 1, HDMI * 1, Micro Sdcard Reader * 1, 10/100M eth * 1, IR * 1


Sumavision Q7

CPU: S905L
ROM: Micron 29F64G08CBABB * 1 = 8GB
AP: SGM8905
USB2.0 * 2, AV * 1, HDMI * 1, Micro Sdcard Reader * 1, 10/100M eth * 1, IR * 1


Both booting with Armbian_19.11.3_Aml-g12_bionic_legacy_5.3.0 + meson-gxl-s905x-nexbox-a95x.dtb



Link to comment
Share on other sites

I bought a DEALDIG BOXD6 (s912 3GB/32GB) with seems a clone of a Beelink GT1 Ultimate.

This box works great with Armbian (bluetooth, WiFi):

    _    __  __ _     
   / \  |  \/  | |    
  / _ \ | |\/| | |    
 / ___ \| |  | | |___
/_/   \_\_|  |_|_____|
Welcome to Ubuntu Eoan with Armbian Linux 5.3.0-aml-g12
System load:   0.00 0.14 0.25   Up time:       20 min           Local users:   3            
Memory usage:  14 % of 2805MB   IP:  
CPU temp:      50°C           
Usage of /:    42% of 28G    

0 mise à jour peut être installée immédiatement.
0 de ces mises à jour est une mise à jour de sécurité.

*** /dev/mmcblk1p2 will be checked for errors at next reboot ***
*** /dev/mmcblk1p2 will be checked for errors at next reboot ***

Last login: Fri Dec  6 14:19:08 2019


inxi -Fxs
System:    Host: Dealdig-BOXD6 Kernel: 5.3.0-aml-g12 aarch64 bits: 64 compiler: gcc v: 7.4.1 Console: N/A
           Distro: Ubuntu 19.10 (Eoan Ermine)
Machine:   Type: ARM Device System: Amlogic Meson GXM (S912) Q201 Development Board details: N/A
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Touch Keyboard K400 Plus
           charge: 55% (should be ignored) status: Discharging
CPU:       Topology: 8-Core (2-Die) model: ARMv8 v8l variant: cortex-a53 bits: 64 type: MCP MCM arch: v8l rev: 4
           features: Use -f option to see features bogomips: 0
           Speed: 1512 MHz min/max: 100/1512:1000 MHz Core speeds (MHz): 1: 1512 2: 1512 3: 1512 4: 1512 5: 1000
           6: 1000 7: 1000 8: 1000
Graphics:  Device-1: meson-gxm-dw-hdmi driver: meson_dw_hdmi v: N/A bus ID: N/A
           Device-2: meson-gxm-mali driver: panfrost v: kernel bus ID: N/A
           Display: server: X.Org 1.20.5 driver: modesetting unloaded: fbdev resolution: 1920x1080~60Hz
           OpenGL: renderer: panfrost v: 2.1 Mesa 19.2.1 direct render: Yes
Audio:     Device-1: meson-gxm-dw-hdmi driver: meson_dw_hdmi bus ID: N/A
           Device-2: meson-gx-audio-core driver: meson_gx_audio_core bus ID: N/A
           Device-3: simple-audio-card driver: asoc_simple_card bus ID: N/A
           Sound Server: ALSA v: k5.3.0-aml-g12
Network:   Device-1: meson-gxbb-dwmac driver: meson8b_dwmac v: N/A port: N/A bus ID: N/A
           IF: eth0 state: down mac: 98:13:39:XX:XX:XX
           Device-2: pwm-clock driver: pwm_clock v: N/A port: N/A bus ID: N/A
           IF-ID-1: wlan0 state: up mac: 10:d0:7a:XX:XX:XX

Drives:    Local Storage: total: 28.91 GiB used: 11.60 GiB (40.1%)
           ID-1: /dev/mmcblk1 model: SLD32G size: 28.91 GiB
Partition: ID-1: / size: 27.57 GiB used: 11.50 GiB (41.7%) fs: ext4 dev: /dev/mmcblk1p2
           ID-2: /boot size: 121.7 MiB used: 99.9 MiB (82.1%) fs: vfat dev: /dev/mmcblk1p1
           ID-3: /var/log size: 48.4 MiB used: 7.3 MiB (15.1%) fs: ext4 dev: /dev/zram0
Sensors:   Message: No sensors data was found. Is sensors configured?
Info:      Processes: 258 Uptime: 7m Memory: 2.74 GiB used: 914.2 MiB (32.6%) Init: systemd runlevel: 5
           Compilers: gcc: 9.2.1 clang: 9.0.0-2 Shell: bash v: 5.0.3 inxi: 3.0.36


Link to comment
Share on other sites

Starting from version 19.11.4, armbian TV supports Tanix TX6 with Allwinner H6 processor, 3Gb RAM, USB 3.0, LAN 100Mb, mali T720.

Given that Panfrost has added support for the mali T720 (which is used in this model), it is a promising enough model to use.

There are already Libreelec and Armbian for this TV box model.   :)


+ Eachlink H6 (Allwinner H6)   Hurry up to buy these models before the sellers learned about this possibility and raised the price ....     :)




Link to comment
Share on other sites

two more h6 tv box recommendations and one warning: i can recommend the "q plus" h6 box (with the coloured ring around the box below the top) and the "mx 10 pro 6k" h6 box (with some geometric pattern imprinted/embossed on the top, beware that there are some close named ones like with 4k or mini in their names which are quite different - i only mean the one with the exact name as given) - both are quite cheap and work well with linux and should work well with armbian then as well ... for the mx10 pro 6k i'm not sure if it is possible to easily attach a serial console (there seem to be connection points half under the heat sink, so not that easily accessible) for the q plus it is possible for sure.


the warning is about the the box pictured at the beginning of this thread:

it is available very often and cheap these days, but at least mine was 2/16g instead of the 4/32g i bought it as (it faked the numbers in android), it was not able to boot linux on it and i was not able to get any useful serial port output from it (although it seems to have something which looks like proper connectors) - so better avoid this one in case you plan to run linux or armbian on it ...


best wishes - hexdump


p.s.: while we are at warnings - avoid anything with a rockchip rk3318 - it does not seem to be supported at all by u-boot and linux ...

Link to comment
Share on other sites

First of - massive thanks to@jernej, @hexdump and @balbes150 for making these devices useful!

I have two TV boxes that successfully boot balbes150's armbian distros:



The first one is called T95max+

This is a quad-core Amlogic S905X3 device

I have 4G RAM/32G rom version.

Booting armbian with meson-g12a-sei510.dtb,

eth0 works


I quite like this box, it's cheap on aliexpress,

it's easy to open, got a small-ish board,

real 4G RAM (not like the H6 one). Will be building

a compute rig of several of these!


T95max - I foolishly thought it'd have the same

hardware as the first one but alas it's an Allwinner H6


Using the RK_AML_AW repo with U-BOOT-TANIX-TX6

and sun50i-h6-tanix-tx6.dtb - booting successfully!

Many thinks to the abovementioned guys for getting this

one covered as I was preparing to toss it to the bin ;


It's a 4G RAM but only ~3 available, HDMI+sound+eth0

work. This one is crappy as a TV box, only does 720p

max in android so I would no recommend it. But it will

be useful after the "upgrade"































@balbes150 I love your choice of the test clips! ;

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines