0
jxdqwer

Nanopi Neo4 armbian5.65 MAC address is no fixed

Recommended Posts

4 hours ago, jxdqwer said:

Nanopi Neo4 armbian5.65

 

You forget on most important data. Which kernel do you use? 

armbianmonitor -u

And remember that this image is not declared stable yet since (such) minor issues weren't fully resolved yet.

Share this post


Link to post
Share on other sites
15 hours ago, jxdqwer said:

Nanopi Neo4 armbian5.65 Mac address is no fixed。

Every times setup my Neo4 the MAC address is diffenence。

Who can help me.

forgive my pool English.

Thanks

if you didnt use the Network-Manager for configuring your eth0, but the /etc/network/interfaces 

the you could use the following idea to set a MAC-Address:
http://www.youritronics.com/how-to-set-the-mac-address-from-etcnetworkinterfaces-in-debian/

 

look for the line
hwaddress ether 00:01:04:1b:2C:1F

#This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 1.1.1.2
netmask 255.255.255.0
network 1.1.1.255
broadcast 1.1.1.255
gateway 1.1.1.1
dns-nameservers 1.1.1.1
dns-search .com
hwaddress ether 00:01:04:1b:2C:1F

 

Share this post


Link to post
Share on other sites
On 11/6/2018 at 2:08 AM, guidol said:

if you didnt use the Network-Manager for configuring your eth0, but the /etc/network/interfaces 

the you could use the following idea to set a MAC-Address:
http://www.youritronics.com/how-to-set-the-mac-address-from-etcnetworkinterfaces-in-debian/

 

look for the line
hwaddress ether 00:01:04:1b:2C:1F


#This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 1.1.1.2
netmask 255.255.255.0
network 1.1.1.255
broadcast 1.1.1.255
gateway 1.1.1.1
dns-nameservers 1.1.1.1
dns-search .com
hwaddress ether 00:01:04:1b:2C:1F

 

Thank you.It's useful,

auto eth0

iface eth0 inet dhcp

hwaddress ether xx:xx:xx:xx:xx:xx

Share this post


Link to post
Share on other sites
On 11/12/2018 at 2:41 PM, Igor said:

I meet the same problem,but your link is only the code in github. Can you tell me how to enable it to keep my mac addr and use network manager.Because I use ipv6.

And I set /etc/network/interface,but ipv6 didn't work,I don't know why

Share this post


Link to post
Share on other sites
On 11/12/2018 at 2:41 PM, Igor said:

[    5.690456] vendor storage:20160801 ret = -1
[    5.702108] Adding 117712k swap on /dev/zram4.  Priority:5 extents:1 across:117712k SS
[    5.748492] zram0: detected capacity change from 0 to 52428800
[    5.855128] EXT4-fs (zram0): mounted filesystem without journal. Opts: discard
[    7.509822] nr_pdflush_threads exported in /proc is scheduled for removal
[    7.852571] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    7.853012] rk_gmac-dwmac fe300000.ethernet: rk_get_eth_addr: rk_vendor_read eth mac address failed (-1)
[    7.853052] rk_gmac-dwmac fe300000.ethernet: rk_get_eth_addr: generate random eth mac address: 5a:b7:f0:5b:53:d4
[    7.853058] rk_gmac-dwmac fe300000.ethernet: rk_get_eth_addr: rk_vendor_write eth mac address failed (-1)
[    7.853066] rk_gmac-dwmac fe300000.ethernet: rk_get_eth_addr: mac address: 5a:b7:f0:5b:53:d4
[    7.853071] eth0: device MAC address 5a:b7:f0:5b:53:d4
[    7.867585] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[    7.867692] dhd_open: Enter ffffffc03e8ff000
[    7.867698] 
               Dongle Host Driver, version 1.579.77.41.2 (r)
[    7.867702] wl_android_wifi_on in 1

 

I think this is the root cause "[    7.853012] rk_gmac-dwmac fe300000.ethernet: rk_get_eth_addr: rk_vendor_read eth mac address failed (-1)"

log for you.

how to fix it?

 

a.txt

Share this post


Link to post
Share on other sites
On 1/10/2019 at 12:29 PM, littlema said:

but your link is only the code in github


This way it is possible to set MAC address with NetworkManager and that's all I know/can help about this. You can also use nmtui-edit and set MAC spoofing via "GUI" tools. Read NetworkManager manuals if you run into troubles. This has nothing to do with Armbian.

 

On 1/10/2019 at 12:29 PM, littlema said:

And I set /etc/network/interface


This way you override NM settings. Again, check generic Debian/Ubuntu manual for setting this up. And I am not sure if its always possible to set MAC this way.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
0