Jump to content
  • 0

Nanopi Duo USB CAM Error


philip
 Share

Question

I connected FA-CAM202 ( 2M USB cam provided by FriendlyArm) to USB2 pins on Nanopi Duo, 

The OS is  Armbian Bionic mainline kernel 4.14.y

The V4l applications output error as 

  Unable to start capture: Input/output error                                                     
   i: Error grabbing frames

The dmesg shows 

  uvcvideo: Failed to query (GET_CUR) UVC control 3 on unit 1: -32

  uvcvideo: Failed to set UVC commit control : -32 (exp. 26)

 

This Cam FA-CAM202 is worked on PC while other USB CAM such as Logitech works on the same

configuration of Nanopi Duo, on USB2.  

 

It is more like a driver compatibility issues, do we have parameters to try or something else we can let

the UVC CAM which worked on PC run on Armbian ?

 

Tks

Edited by philip
Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

I've had success with NanoPi Duo v1.1 and using the OTG port. I power off the rail instead of OTG port. The thing is I use the FriendlyElec DTB as the Armbian one doesn't support the OTG port. Now I'm using a different USB camera than you, but that may give you some config ideas. Also, I'd try the official FriendlyElec image and make sure it works.

Link to comment
Share on other sites

Help Armbian team helping you!

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...