Tinkerboard S and Pi-Top CEED


1 1

Recommended Posts

I put a TinkerBoard in a Pi-Top CEED and using TinkerOS 2.0.8 it boots and the LCD works fine.  Using Armbian it looks like it boots but nothing is displayed on the LCD.  The Pi-Top CEED uses a HDMI to 30-pin converter board and the current LCD is a 1920x1080 14in that I used to upgrade the original.  Any ideas why the Raspberry running Raspbian and The Tinkerboard running TinkerOS would work with the display but Armbian wouldn’t?


Link to post
Share on other sites

Donate and support the project!

15 minutes ago, WZ9V said:

Any ideas why the Raspberry running Raspbian and The Tinkerboard running TinkerOS would work with the display but Armbian wouldn’t

Drivers.  I don't know what the HDMI --> TFT adapter is, maybe RTD2660H?  In any case, without one I'd never be able to debug it properly, throwing some kernel modules at it *might* fix it, or not.  If you can get me real tech specs, such as chipsets used, etc, that makes it more likely to get a positive outcome.

Link to post
Share on other sites

This biggest chip I can see on the top side of the HDMI to 30pin board has the number STDP2600 not entirely sure since I couldn't find the magnifiers and had to use the aging Mark 1 eyeballs.


Took picture with phone and magnified part number is STDP2600  if that doesn't sound right I can see if there is some other chip on the bottom of the board.


Pretty sure it is the converter on the hub board because Le Potato board also does not start the video correctly.

Link to post
Share on other sites

Armbian 5.59 Bionic Legacy 4.4.152 boots and displays desktop

Armbian 5.59 Bionic Mainline 4.14.67boots but no desktop


When the FTDI cable arrives I'll capture the serial output of 4.14.67. 

Do you need 4.4.152 also for comparison?


BTW, Legacy stops working if I do the software update in the Armbian config utility.  So it appears it something since that image was updated caused it to break.

Link to post
Share on other sites

I got distracted on some other projects and am circling back to this once again.  @TonyMac32, what output do you need to help troubleshoot what is going on?


I have a serial to USB adapter finally so I can capture the debug console from the Tinkerboard S and I can shell in and run whatever is needed from the cmd line.


TinkerOS boots and displays so the HDMI converter and LCD in the CEED are working.  Armbian 5.75 boots but no display on the LCD.

Link to post
Share on other sites

I tried following all that but I got lost.  I think your saying I need to compile a new kernel with your pull request applied and then switch over to that.  Have never tried building a kernel before, any chance you have a working one for 5.75 bionic desktop you could share?

Link to post
Share on other sites

I moved it back to Armbian 5.75 with the legacy 4.4 kernel and now I don't even see it on the network.  I get the green LED and flashing yellow.


Just to check I re-flashed TinkerOS 2.0.8 and it comes up fine and I see it on the network.

Link to post
Share on other sites

Here is what I see from TinkerOS 2.0.8


cat /sys/devices/platform/display-subsystem/drm/card0/card0-HDMI-A-1/modes



Can't open display


I have a full desktop on the LCD when I run these via a ssh session


Link to post
Share on other sites

May be you don't delete old "next"kernel before installing 4.4

apt purge linux-image-next-rockchip linux-dtb-next-rockchip
dpkg -i linux-image-rockchip_5.77_armhf.deb
dpkg -i linux-dtb-rockchip_5.77_armhf.deb


Link to post
Share on other sites

I never got as far as installing yours.   I couldn’t even get it to start up enough to ssh into it to try and install the packages.


i guess I could extract them on my laptop and try writing them to the eMMC.  I tried all of the current Armbian images and none of them ot past the red LED with a flashing yellow one and no wired ethernet so I could ssh in.

Link to post
Share on other sites

Manually extracting and copying them to the emmc didn't work.  Could be a version mismatch, the image I used was legacy desktop 5.75 and it looked like your debs are for 5.76 based on the directory names.


I guess I could try a nightly to see if that has hopes of working.

Link to post
Share on other sites

1 hour ago, WZ9V said:

Yes.  PC running Linux Mint 19

# Install required software
sudo apt install parted qemu binfmt-support qemu-user-static

# Mount armbian image
sudo losetup /dev/loop0 Armbian_5.75_Tinkerboard_Ubuntu_bionic_next_4.19.20_desktop.img
sudo partprobe /dev/loop0
sudo mount /dev/loop0p1 /mnt

# Copy qemu static binary for arm chrooting
sudo cp -pR /usr/bin/qemu-arm-static /mnt/usr/bin/qemu-arm-static

# From dir, where you place downloaded debs
sudo cp linux-image-rockchip_5.77_armhf.deb dpkg linux-dtb-rockchip_5.77_armhf.deb /mnt/tmp

# Mount system dirs and go chroot
cd /mnt
sudo mount -t devtmpfs dev dev
sudo mount -t sysfs sys sys
sudo mount -t devpts dev/pts dev/pts
sudo mount -t proc proc proc
sudo chroot .

# Now we in arm chroot.

# Do magic
mv /bin/sync /bin/sync2
ln -s /bin/true /bin/sync

# Remove "next"
dpkg -r linux-dtb-next-rockchip linux-image-next-rockchip

# Do install required debs.
dpkg -i /tmp/*.deb

# Optional: you can install openssh-server in this step...
# apt install openssh-server
# adduser test222
# passwd test222
# usermod -G sudo -a test222

# Undo magic
rm /bin/sync
mv /bin/sync2 /bin/sync

# Go to host

# Now we in host

# Unmount image
sudo umount /mnt/*/*
sudo umount /mnt/*
cd /
sudo umount /mnt
sudo sync

# Done. Flash Armbian_5.75_Tinkerboard_Ubuntu_bionic_next_4.19.20_desktop.img to your tinkerboard.


Link to post
Share on other sites

11 minutes ago, WZ9V said:

Downloaded and imaged.  I'm at least seeing the startup messages now.  I'll have to dig up the keyboard and mouse so I can log in and test further.




Do not forget to write if everything is ok. :)

Link to post
Share on other sites

@Azq2, Tried it first thing this morning.  Desktop came up fine once I had keyboard connected to login.


I did the updates, configured WiFi and am typing this on the TinkerBoard powered pi-topCEED.  


Thanks so much for the help

Link to post
Share on other sites

Please, don't forget delete test user for ssh:

userdel -f test222


Also, i released image without openssh and "test222" user: https://zhumar.in/Armbian_5.75_Tinkerboard_Ubuntu_bionic_next_4.19.20_desktop_v3.zip

Not official. Only for test. As own risk.

If any other users with same problem want to test this image.

Until it is fixed in the official release (in progress). 


sha256: 377040dd9c42beaec1531199099d0eb12a547cab3f4e761801bbe1c20afe00b1

Link to post
Share on other sites

This topic is now closed to further replies.

1 1