2 2
sunarowicz

Any remote desktop solution working over Internet?

Recommended Posts

Hello,

 

I spent many hours looking for any working solution how to access my Armbian desktop behind NAT and router with not static IP address over Internet. But I failed at all. In the course of my research I tried VNC Connect by RealVNC, TeamViever, AnyDesk and Google Chrome Remote Desktop. And found neither one working on Armbian. The first tree in the list got installed, but not worked. Maybe because all these were built for Rapsbian, not Armbian. The last one did not get installed at all. No idea why. May be because I had to install it into the Chromium browser, not the Chrome as Chrome is not available for armhf. May be it is not ready for armhf yet.

 

I went through this forum too, bud found only topics on remote desktop solution on local LAN. Did not find any solution working over internet and through NAT and not static IP. Is there really no such solution for Armbian now or am I missing something?

 

I appreciate any ideas.

Share this post


Link to post
Share on other sites
10 minutes ago, sunarowicz said:

all these were built for Rapsbian


None of those were build for Raspbian. They were build for Debian and Armbian is generic Debian / Ubuntu.


This method works in local network:

apt-get -y install xrdp vnc4server xorgxrdp

 

but for the way you want to use it (Teamviewer style) I don't have experiences. Just make sure to use Armbian with a modern 4.19.y kernel to rule out possible kernel related issues.

Share this post


Link to post
Share on other sites

What`s the board you`re using? And is it Armbian Stretch or Bionic?
Teamviewer should work on armhf systems. I`m not sure there`s an arm64 version installable. Maybe you can compile it yourself.

This Armbian thread is about this topic.

To install Teamviewer on armhf:

 

sudo apt-get update

sudo apt-get install libqt5gui5 libqt5qml5 libqt5quick5 libqt5webkit5 libqt5qml5 libqt5core5a qml-module-qtquick-controls qml-module-qtquick2 libqt5widgets5 libqt5x11extras5 qml-module-qtquick-dialogs

wget http://download.teamviewer.com/download/linux/version_12x/teamviewer-host_armhf.deb

sudo dpkg -i teamviewer-host_armhf.deb

 

Share this post


Link to post
Share on other sites

I run ARMBIAN 5.68 user-built Ubuntu 18.04.1 LTS 4.19.13-mt7623 on BananaPi R2. And I use TightVNC server for local access to remote desktop and I'm fine with it for that purpose. But it doesn't solve my need for remote access over the Internet, nor the thread you are pointing me at unfortunately. I know it and went it already through earlier.

 

Yeah, you are right, TeamViewer should work on armhf. But it doesn't. I tried all the available TeamViewer Host versions for armhf, i.e. 12x, 13x and the latest 14x. No one worked for me. But not only for me. I found several posts complaining at similar problems in their forum. I attached my complain to one of them that exactly describes my problems, see here: https://community.teamviewer.com/t5/Linux/Several-Bugs-on-Armbian-and-Orange-Pi-Zero/m-p/51898/highlight/true#M3051. According to my personal experience and information I got from reading their forum, I'm sure they have some unresolved issue there for quite a long time now.

 

BTW: I tried to make it working on my board but different system (Ubuntu 16.04, kernel 4.4.7 from BPI team) one year ago already. I tried TeamViewer and VNC Connect with the same (bad) results as now with Armbian.

Share this post


Link to post
Share on other sites
1 hour ago, manuti said:

3 steps:

1. or me the easy way is use XRDP:


sudo apt-get install xrdp tightvncserver

2. link the dynamic Internet IP using DuckDNS https://www.duckdns.org/ 

3. also you need to open the configure the port forward in your router.

Assuming he has a publically routable IP address.  I've been bitten by ever-increasing amounts of people wondering why dynamic dns doesn't work when they're (unknowingly) behind NAT.

 

@sunarowicz : if you're having connection problems, check the first two octets of your wan connection against the list of reserved private IP spaces.

Share this post


Link to post
Share on other sites

Thank you guys for your ideas. Until recently I was behind NAT. Therefore I totally removed the DDNS solution from my thinking. But recently I changed my ISP and I'm not sure now if I'm still behind NAT or not. So I give it a try. I would still like more easier (in terms of setting up and maintenance) solution like TeamViewer, but if DDNS is my only chance, I will be glad for it. Thank you @manuti for pointing me at it.

Share this post


Link to post
Share on other sites

Still, RDP and VNC are not secure enough to open a port directly to Internet.

I rather suggest x2go, which is much more secure (works over ssh), and also a lot faster. Plus, it allows forwarding of sound, local folders and printers.

http://wiki.x2go.org

Enviado desde mi Aquaris M mediante Tapatalk
 

Share this post


Link to post
Share on other sites
On 1/14/2019 at 4:05 PM, JMCC said:

I rather suggest x2go

I take you suggest and try to give a try in near future, thanks!!

For me, the only advantage to using RDP is you don't need to intall anything on Windows and also you can find Microsoft official client in the Mac App Store.

But I normally for remote "desktop" use I prefer to export the X apps via SSH using: ssh -X user@machine 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
2 2