Jump to content
  • 0

My Armbian does not see my Ssd


areinink
 Share

Question

Armbianmonitor:

Hello,

 

Since a week I try moving the OS on the sdcard to an attached SSD.

OS: Armbian 5.65 Ubuntu Xenial 3.4.113 desktop

Because the BPIM1 has a genuime SATA interface it should work.

I have found dozens of tutorials how to do this. Until now I did not find any tutorial that works.

Of course I started with nand-install expecting this would work out of the box.

But after the install and rebooting I got the notification that it couldn't find the ssd.

I guess I have to change something in the bootloader on the sdcard?

(I am not a Linux expert but an enthustiastic Linux user)

Is there any working tutorial including the final steps?

 

Kind regards,

André Reinink

 

From the Armbian docs:

On Allwinner devices after switching to boot from NAND or eMMC clearing the boot loader signature on the SD card is recommended:

dd if=/dev/zero of=/dev/mmcblkN bs=1024 seek=8 count=1 (replace /dev/mmcblkN with the correct device node – in case you run this directly after nand-sata-install without a reboot in between then it’s /dev/mmcblk0).

 

9FEB2019:

I did add this extra step after the nand-install.

After executing this and restarting, the BPIM2 doesn't boot anymore?

What did I do wrong?

 

10FEB2019:

After 7th attempts I changed the SSD (Intel 180GB) for an OCZ 120GB).
Attempt number 8 with the OCZ was succesfull with nand-sata-install. No problems at all. I am happy:-)

Edited by areinink
I have found the problem
Link to comment
Share on other sites

Recommended Posts

  • 0
9 hours ago, vobo70 said:

can you tell me is it enough?

 

Its enough to convince me the problem is real, but the main problem remains - I have no time to deal with this in a near future. 

Link to comment
Share on other sites

Help Armbian team helping you!

  • 0

I checked this image:

 

Armbian_20.05.0-trunk.133_Bananapipro_buster_current_5.4.40_minimal.img

 

and both my SSD and HDD are visible:

 

Disk /dev/sda: 111.8 GiB, 120034123776 bytes, 234441648 sectors
Disk model: SanDisk SSD PLUS
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

 

but wifi does not work in this build

Link to comment
Share on other sites

  • 0
On 5/12/2020 at 7:53 AM, vobo70 said:

Any news?

 

news for users

support terms

- communication rules

 

According to our tiny capacity which you don't support and existing plans I think this task might be addressed fastest by the end of the year https://armbian.atlassian.net/browse/AR-191 It might not be big, but it require time and focus. Perhaps the same amount then answering on this post.

Link to comment
Share on other sites

  • 0
On 5/14/2020 at 9:35 PM, vobo70 said:

but wifi does not work in this build

Better create a new topic for this issue and dont forget to add a up-to-date armbianmonitor -u output.

This one can so be marked as virtual solved.

Link to comment
Share on other sites

  • 0

Same:
[    2.659400] ahci-sunxi 1c18000.sata: supply ahci not found, using dummy regulator
[    2.659660] ahci-sunxi 1c18000.sata: supply phy not found, using dummy regulator
   
focal:
Linux bananapipro 5.10.60-sunxi #21.08.2 SMP Tue Sep 14 16:28:44 UTC 2021 armv7l armv7l armv7l GNU/Linux
ii  binutils-arm-linux-gnueabihf     2.34-6ubuntu1.1                   armhf        GNU binary utilities, for arm-linux-gnueabihf target
ii  linux-base                       4.5ubuntu3.6                      all          Linux image base package
ii  linux-dtb-current-sunxi          21.08.2                           armhf        Linux DTB, version 5.10.60-sunxi
ii  linux-image-current-sunxi        21.08.2                           armhf        Linux kernel, version 5.10.60-sunxi
ii  linux-libc-dev:armhf             21.08.1                           armhf        Armbian Linux support headers for userspace development
ii  linux-u-boot-bananapipro-current 21.08.2                           armhf        Uboot loader 2021.07
ii  selinux-policy-default           2:2.20190201-8                    all          Strict and Targeted variants of the SELinux policy
ii  selinux-utils                    3.0-1build2                       armhf        SELinux utility programs


Notes:

0. Correct connection (not over otg), 2 boards, 2 ssds, focal+bionic, bpi+bpipro images tested.


1. The error says about "AHCI not found".
"/proc/device-tree/" has a node "ahci-5v" and no "ahci".


2. My board in bananapipro same as
https://forum.armbian.com/topic/9578-my-armbian-does-not-see-my-ssd/?do=findComment&comment=72002

 

(Not the BP1 / not Pro)
https://forum.armbian.com/topic/9578-my-armbian-does-not-see-my-ssd/?do=findComment&comment=71999


3. It worked with older images (~2018-2019). Back from times when there were a mixup between lemaker banana pi and banana pro.

4. With bpi focal image (not PRO) comes the notorios power up failed:
[    2.695063] ahci-sunxi 1c18000.sata: PHY power up failed.
[    2.695422] ahci-sunxi: probe of 1c18000.sata failed with error -5
PS: I tried the BPI image because back then in another thread manually installing `linux-u-boot-bananapipro-next` (and now linux-u-boot-bananapipro-current) actually solved the problem (plus copying pro dtb to bananapi).

 

4. I have 2 boards, so both are currently unusable.

 

5. To compile a kernel I don't have any machine with required spec. Maybe a single working kernel could be provided by others who solved this by compiling? Thank you for your/any efforts/help.

 

[Happy new Year!]

photo_2021-12-31_02-43-23.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...