0
halim

Orange Pi R1 internal WIFI problem

Recommended Posts

Hi, 

After upgrade from xenial to bionic we found a problem with R1 internal WIFI.

First connection to any wireless network with nmtui works wihout problem. But after that if we try to switch to another wireless network it fails. It doesn't even reconnect to the first network ever.

If we plug in an external usb wifi adapter(which uses a different driver than the internal wifi driver) it works without problem as expected.

What do you think ? Have you experienced the same problem ever ? What is wrong with the internal wifi ? It was working good in xenial.

I blacklisted the internal driver and using external wifi adapter for now. "wlan0" in the logs might belong to external wifi adapter

 

I can reproduce this problem easily and provide any logs you want. Thank you

 

http://ix.io/1B6e

Description:    Ubuntu 18.04.2 LTS
Release:        18.04
Codename:       bionic

4.19.20-sunxi #5.75 SMP Sat Feb 9 19:02:47 CET 2019 armv7l

 

 

 

 

Share this post


Link to post
Share on other sites

If I'm not too late, I too have this issue with OPi R1, but I'm using Armbian Stretch 5.83.

I found a (very bad) workaround: rmmod 8189es; modprobe 8189es

I think there is something wrong with this driver, but I did not investigate further.

Hope this can help.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0