0
guidol

couldnt set Language de_DE.UTF8 permanently on some Neo2

Recommended Posts

I got 3 Neo2 - but only on 1 the setting for the language de_DE.UTF8 does work via armbian-config or dpkg-reconfigure locales :(

 

The one where it works does show after login
 

root@npi-neo2-22(192.168.6.22):~#  locale
LANG=de_DE.UTF-8
LANGUAGE=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES=en_US.UTF-8
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=

root@npi-neo2-22(192.168.6.22):~# uname -a
Linux npi-neo2-22 4.20.7-sunxi64 #5.75 SMP Fri Feb 8 10:37:18 CET 2019 aarch64 GNU/Linux

one of the non-working shows
 

root@npi-neo2-23(192.168.6.23):~# locale
LANG=de_DE.UTF-8
LANGUAGE=
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES=en_US.UTF-8
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=

root@npi-neo2-23(192.168.6.23):~# uname -a
Linux npi-neo2-23 4.20.7-sunxi64 #5.75 SMP Fri Feb 8 10:37:18 CET 2019 aarch64 GNU/Linux

and the other non-working one
 

root@npi-neo2-24(192.168.6.24):~# locale
LANG=de_DE.UTF-8
LANGUAGE=
LC_CTYPE="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_MESSAGES="C"
LC_PAPER="C"
LC_NAME="C"
LC_ADDRESS="C"
LC_TELEPHONE="C"
LC_MEASUREMENT="C"
LC_IDENTIFICATION="C"
LC_ALL=C

root@npi-neo2-24(192.168.6.24):~# uname -a
Linux npi-neo2-24 5.0.1-sunxi64 #5.77 SMP Fri Mar 15 19:47:20 +03 2019 aarch64 GNU/Linux

 

the 2 non-working ones will work (using de_de.UTF8) if I add the following lines to ~/.bashrc of my users

export LC_ALL=de_DE.UTF-8
export LANG=de_DE.UTF-8
export LANGUAGE=de_DE.UTF-8

 

but I dont know why the "non-working" ones dont get/set the language-setting like the working one :(
AND IP22 and IP23 do share the same armbian-image

IP24 has a new DEV-5.0.1/armbian 5.77-image
 

No_language_when_loaded_2nd_time.jpg

Share this post


Link to post
Share on other sites

also another Language error :(

Try to ouput a number via printf - but when I try to use the "fix" then I do get a error:

LC_NUMERIC=de_DE.UTF-8

root@npi-neo2-23(192.168.6.23):/home/guido# printf "%0.4f\n" $PERCENT
-bash: printf: 90.123456: invalid number
0,0000
 

I have to set LC_NUMERIC=en_US.UTF-8

then it works again (like before)

root@npi-neo2-23(192.168.6.23):/home/guido# export LC_NUMERIC="en_US.UTF-8" or LC_NUMERIC="C"
root@npi-neo2-23(192.168.6.23):/home/guido# printf "%3.4f\n" $PERCENT
90.1235

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
0