ashok

  • Content Count

    9
  • Joined

  • Last visited

Reputation Activity

  1. Like
    ashok got a reaction from saulobrito in Armbian for Amlogic S9xxx kernel 5.x   
    Hi all,
    I am using a HIFI Xplay Q TV Box.
    Configuration is Amlogic S912, 2GB RAM and 16GB storage with WIFI, Bluetooth, and Ethernet.
    The System works as desired in ANDROID. When Booted to Armbian 5.94,5.95,5.96,5.97, Bluetooth and WIFI stopps to work.
     
    I searched Armbian Forum and tried /etc/module entry. tried to load drivers manually. nothing works.
    Command 'lsmod' shows ath10k is loaded. Which is wrong. Android says Brcm for reference I am copying dmesg output from Android.
    [ 1.442709@2] aml_wifi wifi.34: [wifi_dev_probe] no power_on_pin2 [ 1.448606@2] aml_wifi wifi.34: [wifi_dev_probe] set pwm as 32k output [ 1.455240@2] aml_wifi wifi.34: [wifi_dev_probe] dhd_static_buf setup [ 1.461736@2] Wifi: bcmdhd_init_wlan_mem: bcmdhd_init_wlan_mem: WIFI MEM Allocated [ 1.469256@2] aml_wifi wifi.34: [wifi_dev_probe] interrupt_pin=241 [ 1.475477@2] aml_wifi wifi.34: [wifi_dev_probe] irq_num=100, irq_trigger_type=1 [ 1.482913@2] aml_wifi wifi.34: [wifi_dev_probe] power_on_pin=240 [ 1.489031@2] aml_wifi wifi.34: [wifi_dev_probe] clock_32k_pin=0 [ 1.495419@1] aml_wifi wifi.34: [wifi_setup_dt] wifi_setup_dt [ 1.500892@1] aml_wifi wifi.34: [wifi_setup_dt] interrupt_pin(241) [ 1.507065@1] aml_wifi wifi.34: [wifi_setup_dt] power_on_pin(240) =====================================NEXT==================== [ 7.223268@1] cfg80211: DFS Master region: unset [ 7.227703@1] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp) [ 7.227705@1] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm) [ 7.227708@1] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm) [ 7.227711@1] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm) [ 7.227715@1] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz), (300 mBi, 2000 mBm) [ 7.227718@1] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (300 mBi, 2000 mBm) [ 7.227720@1] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm) ======================================NEXT==================== [ 23.141394@0] aml_wifi wifi.34: [extern_wifi_set_enable] WIFI Disable! 240 [ 23.343296@0] aml_wifi wifi.34: [extern_wifi_set_enable] WIFI Enable! 240 [ 23.565941@5] avc open [ 23.565983@5] amvenc_avc check CMA pool sucess, max instance: 2. [ 23.568757@5] allocating phys 0x75200000, size 20480k, wq:ffffffc063655c00. [ 23.575866@5] amvenc_avc memory config sucess, buff start:0x75200000, size is 0x1400000, wq:ffffffc063655c00. [ 23.585764@2] avc release, wq:ffffffc063655c00 [ 23.587807@6] sdio: queuing unknown CIS tuple 0x01 (3 bytes) [ 23.595625@2] remove encode_work_queue ffffffc063655c00 sucess, _destroy_encode_work_queue line 4285. [ 23.601050@7] sdio: queuing unknown CIS tuple 0x1a (5 bytes) [ 23.606479@7] sdio: queuing unknown CIS tuple 0x1b (8 bytes) [ 23.607581@7] sdio: queuing unknown CIS tuple 0x14 (0 bytes) [ 23.610495@7] sdio: clk 200000000 SDR mode tuning start [ 23.610835@5] sdio: rx_tuning_result[1] = 10 [ 23.611125@5] sdio: rx_tuning_result[2] = 10 [ 23.611403@6] sdio: rx_tuning_result[3] = 10 [ 23.611654@6] sdio: rx_tuning_result[4] = 10 [ 23.611658@6] sdio: best_win_start =1, best_win_size =4 [ 23.611661@6] sdio: sd_emmc_regs->gclock=0x1000245,sd_emmc_regs->gadjust=0x32000 [ 23.611672@6] sdio: gclock =0x1000245, gdelay=0x0, gadjust=0x32000 [ 23.613015@6] sdio: queuing unknown CIS tuple 0x80 (1 bytes) [ 23.613082@6] sdio: queuing unknown CIS tuple 0x81 (1 bytes) [ 23.613149@6] sdio: queuing unknown CIS tuple 0x82 (1 bytes) [ 23.613185@6] sdio: new ultra high speed SDR104 SDIO card at address 0001 [ 23.614157@0] sdio: clock 200000000, 4-bit-bus-width [ 23.614157@0] [ 23.614157@0] [sdio_reinit] finish ======================================NEXT==================== [ 23.620885@0] wlan: [4353:E :HDD] wlan_hdd_cfg80211_init: wiphy->bands[i] is NULL, i = 2 ======================================NEXT==================== [ 25.151046@0] wlan: [4353:E :SAP] dfs_init_radar_filters[201]: Unknown dfs domain 0 [ 25.158257@0] +HWT [ 25.160792@0] Target Ready! : transmit resources : 3 size:1792, MaxMsgsPerHTCBundle = 32 [ 25.168237@0] HTC Service Index : 1 TX : 0x100 : alloc:3 [ 25.173573@0] HTC Service:0x0001, ULpipe:1 DLpipe:0 id:0 Ready [ 25.179325@0] -HWT [ 25.181594@0] MAILBOX SWAP Service is enabled! [ 25.185879@0] Reduced Tx Complete service is enabled! [ 25.190342@4] ionvid: info: ionvideo_stop_generating!!!! [ 25.190367@4] ionvid: info: ionvideo release [ 25.192964@5] ionvid: info: ionvideo open [ 25.205661@0] is_full_reorder_offloaded? 0 [ 25.208386@0] HTC Service TX : 0x300 : allocation is zero! [ 25.215154@0] HTC Service:0x0300, ULpipe:1 DLpipe:0 id:1 Ready [ 25.219480@0] HTC Service:0x0300 ep:1 TX flow control disabled [ 25.225398@0] htt_tx_attach:htt_desc_start:0xffffffc02cea0000 htt_desc_end:0xffffffc02cebc200 [ 25.234948@0] HTC Service:0x0100, ULpipe:3 DLpipe:2 id:2 Ready [ 25.239701@0] wma_pre_start-4928: WMA --> wmi_unified_connect_htc_service - success [ 25.247396@2] wma_mc_process_msg-21188: McThread: WNI_CFG_DNLD_REQ [ 25.261381@0] HTC using TX credit flow control [ 25.261905@4] wmitlv_check_and_pad_tlvs: WARN: TLV truncated. tlv_size_diff=24, curr_tlv_len=132 [ 25.268925@4] __wmi_control_rx: WMI UNIFIED SERVICE READY event [ 25.275184@4] wma_rx_service_ready_event-23912: WMA <-- WMI_SERVICE_READY_EVENTID [ 25.282794@4] wlan: [2802:E :WDA] wma_rx_service_ready_event: Firmware build version : 0000030a [ 25.291040@4] wlan: [2802:E :WDA] wma_rx_service_ready_event: Board version: 0.22014009 [ 25.298937@4] wma_rx_service_ready_event-24027: WMA --> WMI_INIT_CMDID [ 25.313068@4] __wmi_control_rx: WMI UNIFIED READY event [ 25.313116@4] wma_rx_ready_event-24056: WMA <-- WMI_READY_EVENTID ======================================NEXT==================== [ 196.039205@5] wlan: [6027:E :WDA] scan complete - scan_id a008, vdev_id 0 [ 196.041720@4] wlan: [4356:E :SME] Found 2 BSS [ 196.046836@4] wlan: [4356:E :PMC] PMC: Cannot enable BMPS timer. BMPS is disabled [ 211.117522@5] wlan: [4680:E :HDD] received scan request [ 211.118843@4] wlan: [4356:E :WDA] scan_id a009, vdev_id 0, scan type 0, msg_type 1103 [ 211.268276@5] wlan: [6027:E :WDA] scan complete - scan_id a009, vdev_id 0 [ 211.269796@4] wlan: [4356:E :SME] Found 1 BSS [ 211.276539@4] wlan: [4356:E :PMC] PMC: Cannot enable BMPS timer. BMPS is disabled [ 231.120904@4] wlan: [4680:E :HDD] received scan request [ 231.122129@7] wlan: [4356:E :WDA] scan_id a00a, vdev_id 0, scan type 0, msg_type 1103 [ 231.271651@5] wlan: [6027:E :WDA] scan complete - scan_id a00a, vdev_id 0 [ 231.273541@6] wlan: [4356:E :SME] Found 1 BSS [ 231.278958@6] wlan: [4356:E :PMC] PMC: Cannot enable BMPS timer. BMPS is disabled [ 251.123813@6] wlan: [4680:E :HDD] received scan request [ 251.125068@7] wlan: [4356:E :WDA] scan_id a00b, vdev_id 0, scan type 0, msg_type 1103 [ 251.274620@5] wlan: [6027:E :WDA] scan complete - scan_id a00b, vdev_id 0 [ 251.276513@7] wlan: [4356:E :SME] Found 1 BSS When doing same dmesg from Armbian no reference to wifi or any related thing.
    but lsmod shows ath10k is loaded but ifconfig doesnt report any wifi interface.dmesg
    can any one help me here?
     
    By the way i am using Meson-gxm-q201.dtb. if this helps.