Jump to content

praveenbm5

Members
  • Posts

    28
  • Joined

  • Last visited

Posts posted by praveenbm5

  1. For WiFi with Armbian Kernel - You need a tweak - #printf "xradio_wlan\nxradio_wlan" >> /etc/modules.d/xradio_wlan

     

    The xradio_wlan driver has a bug and it needs to be loaded twice. Restart.

     

    To configure WiFi from LUCI we need the /etc/config/wireless file in place.

     

    My /etc/config/wireless - AP not yet working, Scanning works from LUCI

    config wifi-device 'wlan0'
            option type 'mac80211'
            option channel 'auto'
            option hwmode '11ng'
            option path 'soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
            option htmode 'HT20'
    
    config wifi-iface
            option device 'wlan0'
            option network 'lan'
            option mode 'ap'
            option ssid 'OPiZero'
            option encryption 'psk2'
            option key 'password'
    
    
  2. I am not so advanced and i don't know how to replace busybox, but i add coreutils with all it's stuff in menuconfig, maybe you know what to do with it. For some reason i didn't make full image, only rootfs, but this is what is needed right? Unfortunately there is nothing for AllWinner wifi modules, but i added almost everything else (except exotic things and what i know will break compilation), so there have to be Network/Wifi menu in Luci. There is no OrangePi device in official source, it is in some other branches, but when i tried to compile there, i always had errors, so i build it for AllWinner Default package set. Boot loader is for LamoboR1, but i think you don't need this. There is no H2/3 anyway.

     

    Great... let me give this a try and will post the results back.

  3. Cheers @praveenbm5 . Quick clarification, do you mean megabits per second or megabytes per second (how file transfer is normally reported!)?

     

    One other thing that would be of great interest is your actual link speed/signal strength. If you've an Android device just tapping on the active connection in Wi-Fi settings should reveal the answer :D If it reports a low signal strength and a low link speed then improving the antenna could help matters... 

     

    (Single chain 802.11n in 20MHz should be able to achieve 144Mbps max let's see how close we can get to that with a 30 cent chip!)

     

    1. Its Mega bits per second unfortunately
    2. When I stand very close to the OPZ then the link speed is 65Mbps. But the upload/download is only ~5 Mbps even when standing close.
  4. Very interesting. How has the Wi-Fi performed for you? In terms of throughput/latency, etc...

     

    OpiZero as Hostspot -

     

    sftp: (standing nearby)

     

    Upload - 5 to 6 Mbps

    Download - 4 to 5 Mbps

     

    I just got my Opizero enclosure and now it sits snugly in there with its teeny wifi antenna. That could be an issue.

  5. @tkaiser - armbianmonitor - log  

     

    Activity:

     

    1. Hotspot with HostAPD and connected to it.

    2. Logging into Ajenti Core Dashboard

     

    Time        CPU    load %cpu %sys %usr %nice %io %irq   CPU
    02:13:09: 1008MHz  0.27  10%   2%   5%   0%   2%   0%   59°C
    02:13:14:  240MHz  0.25  10%   1%   5%   0%   2%   0%   59°C
    02:13:19:  240MHz  0.29  10%   1%   5%   0%   2%   0%   59°C
    02:13:24:  240MHz  0.26  10%   1%   4%   0%   1%   0%   60°C
    02:13:30:  240MHz  0.24  10%   1%   4%   0%   1%   0%   60°C
    02:13:35:  240MHz  0.22   9%   1%   4%   0%   1%   0%   59°C
    02:13:40:  240MHz  0.20   9%   1%   4%   0%   1%   0%   61°C
    02:13:45: 1008MHz  0.27   9%   1%   4%   0%   1%   0%   62°C
    02:13:50:  240MHz  0.25   9%   1%   4%   0%   1%   0%   62°C
    02:13:56:  240MHz  0.23   9%   1%   4%   0%   1%   0%   62°C
    02:14:01:  240MHz  0.21   9%   1%   4%   0%   1%   0%   61°C
    02:14:06:  240MHz  0.19   9%   1%   4%   0%   1%   0%   60°C
    02:14:11: 1008MHz  0.18   9%   1%   4%   0%   1%   0%   62°C
    02:14:16:  240MHz  0.24   9%   1%   4%   0%   1%   0%   61°C
    02:14:22:  240MHz  0.22   9%   1%   4%   0%   1%   0%   62°C
  6. Nope. Please stop spreading such wrong claims. With Armbian settings H2+ on this board remains in a good temperature range but as usual if you run constantly heavy loads some throttling will occur or you mount a heatsink. But there really is no need for one especially when you use this device as intended. Are your claims backed up by the output of 'sudo armbianmonitor -m'?

     

    I have been running Armbian legacy with Wifi as AP with HostAPD and Ajenti Core Web Configuration installed. It is running pretty hot. I will try armbianmonitor on this tomorrow.

     

    I also have a working OpenWRT build (Wifi not configured) and it is running cool.

  7. I've done it for LamoboR1 (A20), only Orange, supported by OpenWrt is Orange Pi Plus (with comment that is not bootable at the moment). I can try to build custom sunxi image with some stuff included, but i am not sure if wifi module in OpiZero (XR819) is supported by OpenWRT. I don't remember if there where any AllWinner wifi drivers and firmware. But googling around i come through this - ОбÑуждение Orange Pi Zero. Looks like some 4pda guy claim to have OpenWrt image with working wifi - http://4pda.ru/forum/index.php?s=&showtopic=782242&view=findpost&p=55805628. But image uploaded can't be downloaded. Maybe registration is needed, but i always forgot my login and conformation emails from this site takes forever to come.

     

    That image posted by Hyphop on 4pda.ru is the same as the one created by following my Gist posted on GitHub from my previous posts. In fact I created my image and that gist following @hyphop's and @dreamdream's cues and directions.

     

    It uses Armbian uBoot and Kernel (including modules and firmware) and the rest is OpenWRT. If you read through my gist you will understand it.

     

    Since Wifi works on Armbian with a small tweak ( #printf "xradio_wlan" >> /etc/modules ) it will work on OpenWRT too with a similar tweak ( #printf "xradio_wlan\nxradio_wlan" >> /etc/modules.d/xradio_wlan ). The trick is you need to load xradio module twice because of a bug.

     

    We can make a generic sunxi build of openwrt to boot on OpiZero with Wifi support following this gist.

     

    https://gist.github.com/praveenbm5/3c81692e6b2b651bb450fb7fc45dff4d

     

    So if you can build a generic OpenWRT image with Wifi and other menus / pages / plugins enabled, it will be great.

  8. I have updated the GitHub Gist to make things even more obvious and easy. Let me know if there is any step I can improve.

     

    Check it out - https://gist.github.com/praveenbm5/3c81692e6b2b651bb450fb7fc45dff4d

     

    On supported routers, OpenWRT comes with a WiFi menu item under Network Tab but here in this build of OpenWRT for Allwinner boards it is missing. Even I am looking for ways to enable it but so far nothing worked. 

     

    Ref: https://wiki.openwrt.org/doc/walkthrough_wifi

     

    There are other ways using HostAPD for AP and wpa_supplicant for Wifi Client but all these methods are too cumbersome and rely on shell commands and config files.

  9. This is my /etc/config/network

    
    config interface 'loopback'
    	option ifname 'lo'
    	option proto 'static'
    	option ipaddr '127.0.0.1'
    	option netmask '255.0.0.0'
    
    config globals 'globals'
    	option ula_prefix 'fd90:b7e4:45cc::/48'
    
    config interface 'lan'
    	option ifname 'eth0'
    	option force_link '1'
    	option type 'bridge'
    	option proto 'static'
    	option ipaddr '192.168.1.1'
    	option netmask '255.255.255.0'
    	option ip6assign '60'
    
    
    
  10. Thank you, your post appear to be the most useful here. But although i don't want to be mean, this topic appear to be one of those useless and time waste i already seen a lot. Someone brag to to something for himself, but no details and have to pull out words, one by one from his mouth. Well, i am happy for those persons success, but there was no need of this, really...

     

    I understand your frustration! Been there, felt that! but I beg to differ with you! Getting things up and running is a lot of hard work and more importantly guess work. Many a times we ourselves do not remember the exact steps taken.

     

    Over above that, once its working and if we report the results back in a forum like this, it suddenly becomes a duty of us to write a NOOB (me :P ) friendly guide to reproduce the results.

     

    By the way I sincerely thank those who report back their process diligently but I cannot condone those who do not. People get caught up in silly nuances of life in spite of best intentions   :) . Take a chill pill and hope for the best. You can ofcourse, borderline pester them for details.  :P

     

    And try to contribute something back to the community yourself before asking it of others. People generally reciprocate.

     

    I am taking the liberty to document DreamDreams process of porting OpenWRT to OPZ using Armbian uBoot and Kernel in this GitHub gist here - 

     

    https://gist.github.com/praveenbm5/3c81692e6b2b651bb450fb7fc45dff4d

     

    Please contribute... Everybody... its a humble request

  11. Sorry there is another folder from Armbian that needs to be retained, which is /lib/firmware. 

     

    To be sure whether it boots or had anything wrong during the process, you better have a TTL cable to attach to serial console. Otherwise you'd have to guess.

     

    Already ordered one and waiting for delivery  :)

     

    How did you connect to to the OPZ after preparing everything as above and booting OPZ with it?

  12. Here is the exact process I followed.

     

    1. Installed Armbian_5.24.161216_Orangepizero_Ubuntu_xenial_3.4.113.img onto a 16 GB SD card using Win32DiskImager.
    2. Mounted the uSD in Ubuntu Laptop and expanded the partition using GParted.
    3. Deleted everything from uSD except /boot and /lib/modules
    4. Mounted openwrt-15.05.1-sunxi-root.ext4 on Ubuntu using loopback interface on /mnt/openwrt
    5. Copied over the contents of /mnt/openwrt to the root of uSD by merging folders when prompted.
    6. Modified /etc/init.d/boot and added ulimit -n 10000 before /sbin/kmloader command (line39).
    7. Executed the following code inside /lib/modules/3.4.113-sun8i 

      for x in `find -name *.ko`
      do
          ln -s $x .
      done
      
      

    After executing the above steps, I transferred the uSD to OPiZero and booted from it. Then I connected the OPZ LAN to my wifi routers LAN socket and scanned my local network for new devices. Nothing showed up. Read on OpenWRT website that when OpenWRT is freshly installed, it assigns 192.168.1.1/24 to the LAN interface. I double checked that there is no IP conflict on my lan but still nothing showed up on my network scan. I was unable to ping or telnet to 192.168.1.1.

     

    I even tried connecting my OPZ directly to my laptop using normal ethernet cable. I assigned my Laptop LAN 192.168.1.2/24 and tried to ping OPZ. Nothing happened. Since my laptop has Gbit ethernet I assumed a cross cable is not necessary since Gbit NIC can auto configure connects.

  13.  

    What I did is simple:

    1. Install Armbian

    2. delete everything except /boot and /lib/modules from rootfs

    3. copy over OpenWRT rootfs 

     

    And that's it. This means I use u-boot, kernel, initrd and all settings from Armbian, only userland from OpenWRT. 

     

    And one minor tweak. Since how OpenWRT organize kernel modules is different, I have to do following:

    1. symlink all .ko files to /lib/modules/3.4.112 using

    for x in `find -name *.ko`
    do
        ln -s $x .
    done
    

    2. OpenWRT's /sbin/kmodloader seems trying to open all ko files at once for stat and Armbian has a lot of modules under /lib/modules/3.4.112 dir so kmodloader will run out of file handle. I'm lazy to try to figure out which one is needed, so I simply change ulimit before kmodloader is ran in /etc/init.d/boot. Add one line at line 40:

    ulimit -n 10000
    

     

    I did all the above and created a file system on a MicroSD card. Now after booting from this MicroSD card, how do I login to OpenWRT?

     

    I tried connecting my laptops LAN to the LAN on OPiZero and I tried connecting the LAN on OPiZero to my Wifi Router's LAN. Either ways I am unable to connect to the OPZero with above OpenWRT image.

     

    Please help.

     

    Thank you.

  14. Atleast we found a fix and my OPiZero is working as expected.

     

    I modified the /etc/modules-load.d/modules.conf and added a duplicate entry for xradio_wlan in the end and boom everything works as expected. You should probably put this in the legacy distro to avoid confusion until the driver is fixed.

    #w1-sunxi
    #w1-gpio
    #w1-therm
    #sunxi-cir
    xradio_wlan
    g_serial
    xradio_wlan
    
×
×
  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines