belfastraven

Members
  • Content Count

    56
  • Joined

  • Last visited

Reputation Activity

  1. Like
    belfastraven got a reaction from lanefu in Pinebook Pro   
    I can test, too.  I have been running with (currently) an armbian dev  build with 5.8.9 kernel on focal with a gnome desktop and pcm720's uboot on spi flash, botting  an nvme.   The only strangeness that I have been running across is that if I boot off of an SD card,  rebooting without shutting down seems to boot the NVME.    I haven't spent much time investigating, though--I was just so excited to be using armbian builds again..:-)   
  2. Like
    belfastraven got a reaction from Igor in Armbian v20.05 (Kagu) Planning Thread   
    @Igor,  I've been playing with the Cubox builds and everything is working well.    On WIndows,   I am thinking about suggesting the built-in powershell tool Get-FIlehash for verification  and  explaining how to write the hash into a file to  check it.     gnupg,  which installs gpg,  and gpg4win,  its windows graphic frontend with extra bells and whistles, work fine for authentication,  and the command line  use is the same as on linux.    If we have any windows experts here who would like to weigh in,  I'd love to here from them.   Of course,  if people are running WSL ,   they can just do this with the linux commands anyway...
     
    I will see what I come up with over the weekend and THEN make the pull request. :-)
     
     
  3. Like
    belfastraven got a reaction from Igor in Armbian v20.05 (Kagu) Planning Thread   
    Okay, thanks Igor,  I am working on it and I did sign up for the Alsassian project management stuff.  
  4. Like
    belfastraven got a reaction from TRS-80 in Pinebook Pro   
    Check out the attached screenshots of commits.  I believe you may need all three of these patches.  One is modifying the simple panel driver to include our specific panel, one changes timing ,   one is to force recognition of the panel, I believe.    I sent the screenshots becuase I couldn't figure out how to get the patches off of gitlab,  but I imagine you will know how to do that.   There have been many patches over the past 3 months,  but I think these are the ones that enabled the display.    There are more for bluetooth, wifi, sound, usb-c , etc.
     
    WE now have a mainline u-boot that will, when flashed to SPI , boot an NVME.   If you get a build that displays ,  I'd like to try to get it to boot with the new u-boot.   My poblem right now is that everytime I start making build system changes --I tend to get a headache   .  I did much better with the older ( from a few months ago) build system.  The problem is me, of course, not the build system.  
     
    At least serial is working well now.Schramm_panel_commits.zip
  5. Like
    belfastraven got a reaction from aaditya in Pinebook Pro   
    You might want to use the  dts from  Toobias Schramm's Manjaro source  Most things are working very well.   Someone else has built a mainline u-boot which  can be run from Spi flash (but doesn't support NVME boot yet--an earlier version based on Rockchip does.)  Manjaro for Pinebookpro is now running with 5.5 rc-something kernl,   The only thing that I have found not to work is suspend,  which people are still trying to make work on mainline.   Check the  Pine64 forum for more info.  I had started to try to test an armbian build,  but it takes me forever to figure out  the scripts.   
     
    I think mainline uboot with mainline kernel is a good way to go...
     
    If any one needs any testing/test building  let me know. 
     
  6. Like
    belfastraven got a reaction from Werner in allwinner h6 ethernet internal error   
    If it helps anyone,  I've been running succesfully with gigabit ethernet on eth0 using the dts and h6 dtsi from Icenowy's
     aosc-sunxi64-4.19-malimidgard-hack-2
     
    branch and the armbian dev kernel .    I force a stable mac_address by adding  
    allow-hotplug  eth0 
    iface eth0 inet dhcp
        hwaddress ether xx:xx:xx:xx:xx:xx  (replace the xx's of course with a good address)
     
    in the /etc/network/interfaces  file.  
     
    I haven't yet been able to get spi-jedec-nor  flashed to enable sdi boot,  I get an error indicating that there is a mismatch between what is specified in the DTS vs the overlay, but I am booting off of an sd card with the file system on a usb connected ssd.
    I'm going to try to build with the mainline 5 kernel soon,  to see If I can pick up the new graphics drivers...
     
    I believe version B of the device is supposed to be out soon...
  7. Like
    belfastraven got a reaction from TonyMac32 in Make 4.19 kernel available again for Rock64   
    As I noted earlier,  I had problems with usb storage not being recognzed on a rock64 after  update to the 4.20 kernel.  In my case on a Rock64 v2.0 , I seemed to have fixed the problem  by making the following changes which are reversions to the previous 4.19 dts values.    
     
    vcc_host1_5v: vcc_otg_5v: vcc-host1-5v-regulator {#############################  from 4.20,  changed A2 back to D3  to make things work
    compatible = "regulator-fixed";
    enable-active-high;
    gpio = <&gpio0 RK_PA2 GPIO_ACTIVE_HIGH>;




    usb2 {
    usb20_host_drv: usb20-host-drv {
    rockchip,pins = <0 RK_PA2 RK_FUNC_GPIO &pcfg_pull_none>;#################  from 4.20,  changed A2 back to D3  to make things work

    My board is version 2.0

    This problem did not affect other usb devices, btw,  just storage...  I tried to check the specs but didn't see find anything for vcc_host1_5v ,  vcc_otg_5v or usb20_host_drv.

    I did find usb_otg_drv at A2.....   
     
    I noted the aobe in the pine64rock64 forum,  but have had no response their yet.  I am now back to booting off of a ssd on USB3 and having a usb stick and mouse/mouse keyboard on the usb2  ports--  once again,  this is on a Rock64 v2.0