Jump to content

OpenglMan

Members
  • Posts

    29
  • Joined

  • Last visited

Everything posted by OpenglMan

  1. Hello, I get an error when i try to use the PH5 pin as digital output. PH5 is the number 229 according to the following equation: (8-1)*32+5 = 229 echo 229 > /sys/class/gpio/export -bash: echo: write error: Device or resource busy If i use other pins like PH13, PH19, PH20 or PH21, all work correctly. For example, for PH13 as digital output: echo 237 > /sys/class/gpio/export echo "out" > /sys/class/gpio/gpio237/direction echo "1" > /sys/class/gpio/gpio237/value echo "0" > /sys/class/gpio/gpio237/value echo 237 > /sys/class/gpio/unexport I get the same error in the Cubieboard2 and the Lime A20 board. Can someone help me ? Thanks in advance
  2. thanks a lot, giri and Igor, i changed the permissions to the direcotry and then it worked.
  3. Thank you Igor for your quick response. I show below the content of the output.log file: Thank you very much
  4. Hello, I'm newbie to armbian, I am trying to build my own image, and i following the steps of this link: https://docs.armbian.com/Developer-Guide_Build-Preparation/ (i am not using Virtualvox) My OS is: Distributor ID: Ubuntu Description: Ubuntu 16.04.3 LTS Release: 16.04 Codename: xenial And my GCC version: gcc (Ubuntu 5.4.0-6ubuntu1~16.04.5) 5.4.0 20160609 I apologize, since I'll probably be asking some nonsense. I follow the steps to build my own image, and I get the following error: [ o.k. ] Building deb [ linux-u-boot-next-lime_5.33_armhf.deb ] [ error ] ERROR in function compile_uboot [ compilation.sh:232 ] [ error ] Building u-boot package failed Can you help me to identify what is wrong? I wait for your answer, and thank you very much in advance
×
×
  • Create New...